Author Topic: Database Locked - Adept installer  (Read 1530 times)

pm_svefa

  • First post!
  • Posts: 1
    • View Profile
Database Locked - Adept installer
« on: January 16, 2009, 12:27:42 pm »
Hi ! I'm a newbie to Linux (but have been working with DOS and Windows since the 80's) and I'm now trying to set up MCE and have run into to problem with display driver (NVIDIA Geoforce 9600 GT which I will try to solve by following instructions on http://wiki.linuxmce.org/index.php/Display_Drivers). In the process of solving that I've several times run into ANOTHER problem and that is WHEN I try to install upgradable packackes using Adept Installer I get the message "Database Locked - Adept Installer" Another process is using the packaging system..... AND I can't figure out what to in order to unlock the db. I've been forced to re-install Kubuntu every time and since this is likely to happen in the future as well I would like to find a better way :-)

Asus P5Q Pro with latest BIOS, SATA-disks in AHCI-mode, NVIDIA Geoforce 9600 GT

seth

  • Guru
  • ****
  • Posts: 485
  • A day w/o LinuxMCE is like a day w/o sunshine!
    • View Profile
Re: Database Locked - Adept installer
« Reply #1 on: January 16, 2009, 02:29:42 pm »
 ;)
I don't use the Adept installer. I use 'apt-get install' usually called with 'sudo apt-get install <package>' and I have never had a locking issue.

LMCE uses KDE 710 for sure, but it is a custom version of it. I recommend installing only the applications you need. And I have never run an update, or updated any packages.

Just my 2 cents.  :D

Regards,

Seth
".....Because Once you've LinuxMCE'd....."
System stats located at my user page:

http://wiki.linuxmce.org/index.php/User:Seth

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Database Locked - Adept installer
« Reply #2 on: January 17, 2009, 12:19:29 am »
Do not use adept or any other package system like it - they are disabled for a reason. If LMCE attempts to autoupdate the OS it will break LMCE.

Carefully use sudo apt-get install as seth suggests.