Author Topic: Solved: IVR on final 10.04 doesn't work for me see post below  (Read 5246 times)


  • Veteran
  • ***
  • Posts: 82
    • View Profile

I followed the thread that was supposed to solve this in January, but it does not work for me in the final release of 10.04:,13068.0.html

I've changed the permissions to asterisk:asterisk rebooted asterisk (and the core for good measure) and still nothing happens:

 -- Executing [s@voice-menu-lmce-custom:4] Background("SIP/", "pluto/pluto-default-voicemenu")
[May 15 09:56:18] WARNING[11419]: file.c:663 ast_openstream_full: File pluto/pluto-default-voicemenu does not exist in any format
[May 15 09:56:18] WARNING[11419]: file.c:958 ast_streamfile: Unable to open pluto/pluto-default-voicemenu (format 0x8 (alaw)): No such file or directory
[May 15 09:56:18] WARNING[11419]: pbx.c:9781 pbx_builtin_background: ast_streamfile failed on SIP/ for pluto/pluto-default-voicemenu
    -- Executing [s@voice-menu-lmce-custom:5] Set("SIP/", "TIMEOUT(digit)=10")
    -- Digit timeout set to 10.000
    -- Executing [s@voice-menu-lmce-custom:6] Set("SIP/", "TIMEOUT(response)=20")
    -- Response timeout set to 20.000
[May 15 09:56:28] WARNING[11419]: pbx.c:5203 __ast_pbx_run: Don't know what to do with 'SIP/'

Also, when I dial *98 I get no voicemail prompts although Asterisk seems to think it is playing them:

    -- Executing [*98@from-internal:2] Wait("SCCP/202-0000000a", "1") in new stack
    -- Executing [*98@from-internal:3] VoiceMailMain("SCCP/202-0000000a", "") in new stack
    -- <SCCP/202-0000000a> Playing 'vm-login.gsm' (language 'en')
  == Manager 'admin' logged on from
    -- <SCCP/202-0000000a> Playing 'vm-password.gsm' (language 'en')
    -- Incorrect password '' for user '202' (context = default)
    -- <SCCP/202-0000000a> Playing 'vm-incorrect-mailbox.gsm' (language 'en')
    -- SEP001121116CEB is Onhook
  == SEP001121116CEB: Ending call 10 on line 202 (Connected)

No sound and no password entered....

I'll keep digging but if anyone has fixed this on their own core, I would appreciate any pointers. Thanks in advance.
« Last Edit: June 11, 2013, 08:28:23 pm by sedgington »


  • Veteran
  • ***
  • Posts: 82
    • View Profile
Solved: Re: IVR on final 10.04 doesn't work for me
« Reply #1 on: June 11, 2013, 08:27:25 pm »
OK, it took me some time to get back to this and then a bit more time to compare it to 8.10 to see what is wrong. Here are the steps to solve it:

ls -l /usr/share/asterisk/sounds

everything in this directory is listed as root:root in 10.04. In my working version of 8.10 it is listed as asterisk:asterisk. So I first changed ownership of all the gsm files:

chown asterisk:asterisk /usr/share/asterisk/sounds/*.gsm

Then stopped and started asterisk and still no love. Then went to look at the pluto directory and found that it was root:root so changed it:

chown asterisk:asterisk /usr/share/asterisk/sounds/pluto

Stop and start asterisk and dial in. Now asterisk can get into the directory where the files are located and play them. It was that simple. Just make sure that everything in that pluto directory is asterisk:asterisk as pointed out here:,13068.0.html

If you have problems with recordings or other things permission related with asterisk I would try this on the folder and contents of the files in question.

I'll file this as a bug. Hope this saves someone else hours of trying to figure this out.