LinuxMCE Forums

General => Users => Topic started by: toko on February 05, 2008, 04:26:50 pm

Title: GSD - sending simple sting to a serial interface
Post by: toko on February 05, 2008, 04:26:50 pm
target: sending a simple string to a RS232 interface

followed to all tutorials and howto's which I've found but with no success so far.

my situation currently is:
I added a new device as Pluto Generic Serial Device as category Interface::Specialized like I've found on the forums and configured like it was recommended. Then added the ruby-code "conn_.Send("#01000001\r")" to the Process Receive Command For Child command.

I added the device as top-level device in my devices-tree and tried to send a command via the link but always says "delivery failed"... and the interface doesn't get the command. The log-file for my new device is not even created and the function "Follow Log" does say "file not found".

one thread stated that the package 'pluto-generic-serial-device' must be present. I checked and it wasn't present. I fetched it via aptitude on the core (where the serial device is connected to) and restarted everything. Do I need to include the new package somehow/somewhere?

as well I checked process-tree if something with Generic Serial is around... but nothing around. (command:  ps -elf). Did as well Quick Reload Router and whatever.

My Configuration for COM Port is: "/dev/ttyS0", BaudRate: "B9600" and parity "N81". As well I specified "RS232" as means of communication. I furthermore checked directly from KDE with cutecom if the configuration and port-name is correct and if the teststring really works -> that worked perfectly (and yes, I've closed the port in cutecom after testing again in lmce).

DCERouter.log has this when I try send command (64 is ID of the top-level device I created in device-tree)...
Code: [Select]
13      02/05/08 16:57:40.562           TCPIP: Accepting incoming connection on socket 64, port 3450, from IP <0xb4407b90>
10      02/05/08 16:57:40.562           ServerSocket::Created 0x85b9a38 m_Socket: 64 <0xb4407b90>
10      02/05/08 16:57:40.562           Thread created for Incoming_Conn Socket 64 dev -1 ptr 0x85b9a38 <0xb4407b90>
10      02/05/08 16:57:40.562           Running socket 0x85b9a38... m_bTerminate: 0 <0xa468db90>
08      02/05/08 16:57:40.567           Received Message from 0 (^[[36;1munknown / ^[[0m) to 69 (^[[36;1mAdam#3 / Keller^[[0m), type 1 id 384 Command:^[[35;$
10      02/05/08 16:57:40.567           begin realsendmessage before lock <0xa468db90>
10      02/05/08 16:57:40.568           realsendmessage from 0 to 69 type 1 id 384  <0xa468db90>
10      02/05/08 16:57:40.568           realsendmessage after core release from 0 to 69 type 1 id 384  <0xa468db90>
05      02/05/08 16:57:40.568           ^[[33;1mThe target device 69 (routed to 69) has not registered.^[[0m <0xa468db90>
05      02/05/08 16:57:40.568           ^[[33;1mSender: 0 sent message type: 1 ID: 384 and expected a confirmation from 69^[[0m <0xa468db90>
10      02/05/08 16:57:40.568           realsendmessage - end <0xa468db90>
05      02/05/08 16:57:40.569           ^[[33;1mSocket::ReceiveData 0x85b9a38 failed, bytes left 0 start: 2080000 1: 0 1b: 0 2: 0 2b: 0 m_Socket: 64 Incomin$
13      02/05/08 16:57:40.570           Socket::Close() m_Socket 64 <0xa468db90>
13      02/05/08 16:57:40.570           Socket::Close() m_Socket 64 closesocket: 0 <0xa468db90>
05      02/05/08 16:57:40.570           ^[[33;1mSocket::ReceiveString2 ReceiveData failed m_Socket: -1 Incoming_Conn Socket 64^[[0m <0xa468db90>
05      02/05/08 16:57:40.570           ^[[33;1mTCPIP: Closing connection to -1003 (Router Dev #0) 0x85b9a38 m_Socket: -1^[[0m <0xa468db90>
10      02/05/08 16:57:40.570           Detected disconnect: detaching thread for -1003 <0xa468db90>
05      02/05/08 16:57:40.570           ^[[33;1mRouter::RemoveAndDeleteSocket 0x85b9a38 -1003^[[0m <0xa468db90>
10      02/05/08 16:57:40.571           Executed query UPDATE Device SET Registered=0,psc_mod=psc_mod WHERE PK_Device=-1003 (0 rows) <0xa468db90>
13      02/05/08 16:57:40.571           Socket::Close() m_Socket -1 <0xa468db90>
13      02/05/08 16:57:40.572           Removing socket 0x85b9a38 from socket listener <0xa468db90>
22      02/05/08 16:57:40.572           Stale Command handler (0x85b9a38) for ^[[34;1m-1003^[[0m closed. <0xa468db90>
22      02/05/08 16:57:40.572           Map server socket size 15, vector server socket size 45 <0xa468db90>
10      02/05/08 16:57:40.572           ServerSocket::~ServerSocket(): @0x85b9a38/-1 Is it running 0? <0xa468db90>
13      02/05/08 16:57:40.572           Socket::Close() m_Socket -1 <0xa468db90>
13      02/05/08 16:57:40.572           Socket::~Socket(): deleting socket @0x85b9a38 Incoming_Conn Socket 64 (socket id in destructor: m_Socket: $
so seems like the problem is that the device was not registered... that maybe because the GSD processes not running ...?

I can write much more detailed information if needed... just I would be glad to get some hints where to start checking and searching for the problem.

Thx in advance,
Title: Re: GSD - sending simle sting to a serial interface
Post by: toko on February 06, 2008, 08:39:45 am
can somebody tell me at least:

a) if I have to include a new package somewhere to get it loaded/running ?

b) what else could be reasons for a generic serial device to keep telling Registered: No ?

Title: Re: GSD - sending simple sting to a serial interface
Post by: Zaerc on February 10, 2008, 09:49:04 am
I fetched it via aptitude on the core (where the serial device is connected to) and restarted everything.

I know to little about the generic serial device to give you any real advice but there is a good chance that "aptitude" broke your system, I think you should only use "apt-get" instead.
Title: Re: GSD - sending simple sting to a serial interface
Post by: toko on February 12, 2008, 07:29:48 am
 ;D ;D
cool, that was the clue... I did a fresh installation of linuxmce 0710b3 and fetched pluto-generic-serial-device and pluto-libserial with apt-get instead aptitude and serial process show up in list of running processes - and the logfile was created.

I'm happy, and thank Zaerc so much for the hint - Zaerc for president!!