LinuxMCE Forums

General => Installation issues => Topic started by: Armor Gnome on March 23, 2013, 09:59:48 am

Title: [Solved] Cisco 7970 - missing firmware
Post by: Armor Gnome on March 23, 2013, 09:59:48 am
I working on getting my cisco 7970G working in linuxmce as outlined in the wiki article.

I was able to follow the directions and added my phones mac range to the 7970 template which did prompt a detected device on a nearby orbiter.  I have reloaded my router several times since then but the phone repeatedly restarts itself in a pattern.

Reboot, speaker button illuminated
white Cisco boot screen with a target icon in the lower left
white screen with Upgrading, current mac #
white Cisco boot screen with a checked square
white screen with Upgrading, current mac #
Reboot, speaker button illuminated

I attempted a tcpdump command on my core to see if there were any errors detectable but after doing apt-get install tcpdump I was told that "tcpdump -i eth1 was incorrect syntax.  I am not sure where to begin looking for an error/activity log to determine any other information.  In my webadmin I see that there is a 7979 listed under asterisk and that it had a child device of Cisco 7970 Orbiter.  Port listen number is 3452 as my webpad orbiter is on 3451.  Orbiter was fully regened, still nothing.

Perhaps this is a firmware issue?  How in the world though are people getting to the settings screen with ethernet disconnected or trapped in one of these reload loops?  
Title: Re: Cisco 7970 - upgrading chain
Post by: ggmce on March 23, 2013, 11:24:44 am
Not sure if this is correct, but it finally got my 7970 registered;

Press Menu Button on the phone, get to "Network Configuration" and select
Press "**#" to unlock
Scroll to Alternate TFTP and make it "Yes"
Scroll up to "TFTP Server 1" and put the address of your Core in (default
Press "Save"

That got my phone registered although I was unable to get the Orbiter on the screen, so this may not be the correct way to do this....

Title: Re: Cisco 7970 - upgrading chain
Post by: Armor Gnome on March 23, 2013, 12:25:08 pm
I appreciate the reply but I am unable to get to any phone menus currently.

After a full day if reading I have learned that the phone is talking to DHCP (LMCE in this case) and asking for a specific tftpboot file to match its firmware.  Since I don't have that log or know what firmware it wants it looks like I need to stuff my /tftpboot file with every version.

Alternatively there appears to be a call manager for windows I can push the latest .cop file to the phone.  I will continue working on it until I get the orbiter.  I have no other telephones outside of orbiter embedded, the 7970 will be a desktop orbiter and eventual way to call the front door.  Web admin lists this device as sccp, in case it matters.
Title: Re: Cisco 7970 - upgrading chain
Post by: Marie.O on March 23, 2013, 02:10:32 pm
you might want to look at your syslog file on the core. It might give you an insight as to what is causing the phone to not work correct. My money is on wrong or missing firmware in the tftpboot.
Title: Re: Cisco 7970 - upgrading chain
Post by: Armor Gnome on March 23, 2013, 07:42:02 pm
I watched the syslog for a few reboots and could not resolve the issue.  This is completely due to my lack of experience with tftp coding and socket communication.  I do not see a clear error, just repeated requests when the phone reboots.

dhcp request
dhcppack sent
atfptp request
70default.xml called


I am currently setting up a tftp32 machine to check the phones firmware and bring it up to date if necessary.  Does anyone know the cutoff point for 7970 firmware that no longer works with lmce's defaults?  I don't want to upgrade to a point where lmce's defaults will no longer work.
Title: Re: Cisco 7970 - upgrading chain
Post by: Armor Gnome on March 24, 2013, 11:23:15 am
Continuing to struggle with this phone as I only understand a fraction of the information I am looking for.  It seems cisco charges for firmware, however other users would have had to know their firmware, know their call manager and then pay to DL the matching fw to put in tftpboot.  Obviously I am mistaken somewhere...

SCCP firmware is available from cisco.  However you must know the current firmware (there are stepping stone versions, you can't go from 1.1 to 9.2).  You must also know the call manager version.

I know neither. 

There are no files in tftpboot other than subfolders named according to their MD' MAC and some default.xml files created since attaching my phone and having it detected.

So, phone turns on and asks for DHCP, (option 66, to please pass along the location of the tftp server where it can get its firmware).  I see dcerouter return with dhcppack which must have this information.  It seems rather like the way a MD is created and booted.

I can not find a cm running or any firmware running.  Does LMCE run something similar?  When blind guessing a download to pay for, can anyone tell me the version #?
Title: Re: Cisco 7970 - upgrading chain
Post by: Marie.O on March 24, 2013, 05:59:39 pm
I've heard of people downloading the firmware from sites outside of Cisco, but do not have a URL.
Title: Re: Cisco 7970 - upgrading chain
Post by: tschak909 on March 24, 2013, 06:13:10 pm
Pluto had packaged a copy of SCCP 7.0.3 with LinuxMCE until 7.10. We no longer have these firmware ZIPs.

Title: Re: Cisco 7970 - upgrading chain
Post by: Marie.O on March 24, 2013, 08:13:18 pm
Add software provided a way to get to those firmware files, but that was outside of the legal scope of Pluto, afaik.
Title: Re: Cisco 7970 - upgrading chain
Post by: cfernandes on March 24, 2013, 10:35:44 pm
i use firmware version 9.3.1  if you need you can download from
Title: Re: Cisco 7970 - upgrading chain
Post by: Armor Gnome on March 25, 2013, 03:59:46 am
I read the release notes closely on 9.3, which happens to be the only 'free' firmware available with my cisco site login.  The issue I saw with 9.3 is that if your current version is less than 8.5? you had to upgrade to that, and then upgrade again to 9.3.  Back to me not knowing what version my device is or the call manager version that lmce used I am lost a bit here still.  At this time I am still trying to find a solution that lets me see more of what is going on with the phones tftp request than syslog shows me.  What remains after that is knowing where to place this firmware once I have it in my possession. 

Could someone with an active SCCP 7970 please list their /tftpboot/ folder contents?  I just need to know roughly how many files I need and if there is any special structure to it, such as all in a mac address folder like MDs or xml docs seperate from default xml docs etc.

I also cant help be question if this is necessary and typical for all users who may connect a 7970 since 7.10?  I could start documenting my process for the wiki if so. 

Title: Re: [Solved] Cisco 7970 - missing firmware
Post by: Armor Gnome on March 26, 2013, 01:38:11 am
As some speculated my issue was with missing firmware.  It is my assumption that prior to shipment the previous owner did a wipe or hard factory reset.  Since adding the necessary files to my /tftpboot/ location I have been able to boot the phone (as far as ethernet disconnected) with it detached from my network.

For any users reading this in the future I highly recommend some time spent getting familiar with tschakmac's wiki article, cisco firmware release notes and an overview of the tftpboot process.

Phone has compatible firmware,
 Update the cisco 7970 template for pnp mac detection, phone connects, asks for dhcp and location of tftpboot location (referred to as option 66), lmce generates the needed configuration files.

Phone has incompatible or missing firmware,
Follow the above but if the phone becomes stuck in a loop of syslog entries and reboots while displaying an "upgrading" screen there is a chance you may need to help it out. 

Acquire cisco firmware, the latest is available typically with just a registration login, older releases are harder to come by and could end up costing you $.
unzip, tar, etc once you have the compressed firmware and place those files into your /tftpboot/ folder.  I used 7.0.3 as there was mention that it was used at the time of the detection/configuration script creation.  I agree that for the most part once the orbiter loads it takes over the phone with its refreshes so any added xml screens or options will be hard to access anyways if you wish to use more recent versions.

Best of luck to future users and a sincere thank you for the work developing this automagic configuration.  This will be my first time trying to use telecom with lmce and an outside VOIP service so I still have some work and study ahead of me to get this talking with the rest of the world.