Author Topic: Install with revA 3g connections. Problems and my mostly working solution.  (Read 3276 times)


  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1084
    • View Profile
So because of my location I cannot get "real" internet. My only options are a verizon mifi2200, and a tethered droid. All of the warnings to use eth0 are correct. You need to do that. So after a lot of renaming/disabling etc I realized faking it doesn't work so much. My only option to get the WWAN to eth0 was using windows ICS (internet connection sharing). This seemed to bring up a host of new problems, and this is how I dealt with them.

Asus m3n78-ev
phenom II... cant rememb clock
4GB ram ddr2 800
128 gb SSD for OS
LSI Megaraid 150-6 (cheap, slow, but effective. Shame I dont have a board running around with pcix) caps logical drive size to 2tb, I don't care what the firmware update says.
4x2tb in raid5 + HSS

Done this install with many different types, at least 6, all w same problem.

OSs using ICS (not at same time)
xp pc
vista pc
7 pc

Here is the problem.
update typically stalls out downloading
dist-upgrade always stalls out downloading
lmce always stalls out downloading

These failures occur on files of any size... in different places. Now what it looks like to me is that IPv6 is querying the piss out of the router and after enough of that the connection is lost until broken and re-tried. The bugs related to this are supposed to have been fixed in karmic... and it seems to only be an issue for me on the ICS side of downloading.

Except the ttf-mscorefonts. That fails on any connection.

Now when these scripts are done, some of them do cleanup which removes things necessary for the install. The broken packages show as existing, and do not install further.

So, my advice, if you are forced to use this sort of setup, is firstly, during update/dist-upgrade,  to drop the 2nd nic from the router/switch/hub. Then save the output of any term sessions. Go back and find the broken dl links, apt-get remove them... --purge does not work out so clean, so avoid if possible. I don't know why. I am sure it is due to my ignorance in linux. Then apt-get install them again.

Once the AVWizard comes alive, this stalling out nonsense seems to fix itself, so plug your 2nd nic back in.

Mythtv components are AWESOME at committing suicide on dl. You have to watch them, in particular, very carefully.

ICS SEEMS to be happier on XP... but I could be making that up.

Lastly, wtg guys on beta 2. I want to be like you when I grow up.

« Last Edit: January 29, 2010, 12:29:59 am by l3mce »
I never quit... I just ping out.


  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1084
    • View Profile
I am reading the dist-upgrade might have been a mistake and the source of my mythtv probs... due to the .22 to .23 in avenard. Don't know. Not working. Not avail in computing. Fighting now. Will prob start over again.

Will let you know.

PS... on the ICS wireless thing above... best to turn off DHCP on router.


NICs were swapped. Odd... as each other time the on board gblan has been eth0. Strange. I wonder how many times this has been a lurking issue... because when I have checked in the past eth0 has indeed been the on board. I will have to do some fresh installs on different drives and track.
« Last Edit: January 25, 2010, 10:32:09 pm by l3mce »
I never quit... I just ping out.


  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1084
    • View Profile
So... a note on linuxmce and wireless connections. This is the solution that worked for me outside of the networkmanager which is disabled.

I currently tether my phone to a pc, which is connected to a linksys router, and a wifi dongle on the core.

First you need to edit your /etc/network/interfaces

Presumably you have the following already

Code: [Select]
auto lo

auto eth0 inet dhcp

auto eth1
iface eth1 inet static

after booting with my dongle in, there is no change here or in admin page... but I know my dongle is recongizable, the networkmanager is just disabled, and I didn't install with the dongle, because I didn't want confusion. So I just injected what I knew from previous installs that it wanted to see, as follows...

First, we must edit the /etc/network/interfaces. I use vi, I don't see many others suggesting it, but I seem to get into trouble opening things in dolphin as administrator, and sometimes kate... this is no doubt due to my being green. So:
Code: [Select]
sudo vi /etc/network/interfaces

Then press <Ins> and insert the line
Code: [Select]
auto wlan0
iface wlan0 inet dhcp

After the eth1 lines.
In vi, you will need to press esc and then ":write" w/o quotes to save, and then ":q"  w/o " to quit.

Now, I live in the middle of nowhere and have no need to secure my connection... so this is for an unsecured wifi network, which is typically not recommended. We will make a little config file to catch a specific essid, so you will need to know your it.

Now back to prompt we type
Code: [Select]
sudo vi /etc/rc.local

Press "Ins" and enter on the line above "exit 0"
Code: [Select]
ifconfig wlan0 down
dhclient -r wlan0
iwconfig wlan0 essid "ESSID_IN_QUOTES"
iwconfig wlan0 mode Managed
ifconfig wlan0 up
dhclient wlan0

Now, let's make that an executable that starts when the pc does.
Code: [Select]
sudo chmod +x /etc/rc.local
For instant gratification, or if the connection is lost for any reason after boot, type

Code: [Select]
sudo sh /etc/rc.local
This should all be used only AFTER linuxmce is successfully installed. The install requires input on eth0

See for more on unmanaged wireless connectivity with wifi... but my experience is to ignore code requesting you bring the wired adapters down or up.

After the install I basically switched my nework from the wireless router (w/o DHCP) connected to the linux box on install, feeding my tethered/wireless connection FROM my windows pc, to the router over a hard line, to dropping a wireless dongle on the LinuxMCE  and the router on the PC side, still without dhcp.

*as a side note, the reason I choose the tethered droid over the mifi is that verizon has a 5 gb cap on the mifi, and on a tethered droid if you pay for the service... however if you tether outside of the vzmanager you are on an unlimited plan.
« Last Edit: February 07, 2010, 04:22:01 pm by l3mce »
I never quit... I just ping out.