Author Topic: New MD need help with RS232 connections  (Read 1794 times)

usaf-lt-g

  • Veteran
  • ***
  • Posts: 75
    • View Profile
New MD need help with RS232 connections
« on: July 29, 2008, 05:39:53 pm »
Hey all,

FINALLY got my new MD working (what a pain in the arse...) after struggling with openchrome drivers, and several configuration issues. Anyways... so now I'm trying to figure out how to configure my MD (which is located in my living room where all the main equipment is).

As of right now, the MD is hooked directly via 2 Null Modem Serial cables to each of the RS-232C ports on my components.

The TV is an Element 42" PLX-4202B

The A/V Receiver is a Marantz SR5002

I'm currently running LMCE 704 B3 (yes I know, I need to upgrade to 710... i'm getting there i'm getting there ;) ).

Obviously the MD doesn't detect the RS-232C connection by default, so I'm not sure what my next steps should be. Any help would be much appreciated! Thanks!

v/r

-=USAF=- LT G

                          []                         []                        
                          ||   ___     ___     ___   ||                       
                          ||  /   \   /| |\   /   \  ||                       
                          || |  O  |__|| ||__|  O  | ||                       
                          ||  \___/--/^^^^^\--\___/  ||                       
                      __  ||________|       |________||  __                   
   .-----------------/  \-++--------|   .   |--------++-/  \-----------------.
  /.---------________|  |___________\__(*)__/___________|  |________---------.\
            |    |   '$$'   |                       |   '$$'   |    |         
           (o)  (o)        (o)                     (o)        (o)  (o)         


usaf-lt-g

  • Veteran
  • ***
  • Posts: 75
    • View Profile
Re: New MD need help with RS232 connections
« Reply #1 on: August 01, 2008, 04:01:59 am »
ping

rwilson131

  • Veteran
  • ***
  • Posts: 118
    • View Profile
Re: New MD need help with RS232 connections
« Reply #2 on: August 01, 2008, 05:47:16 am »
In order for you to be able to control devices via the serial port there has to be a device template. 

You really need to update to the latest version, as a lot of bugs have been fixed and everyone else here is using the latest version, so everything may not be correct for that old of a version.

take a look at: http://wiki.linuxmce.org/index.php/Marantz_SR5600

If the serial commands are the same then this template might even work for you, but at the very least it will give you an idea on how to build the template for your receiver.

As for your TV, I do not see Element listed as a Manufacturer in the database, so  I would also venture to say that you will also have to add it as a template in order to use it.

Take a look at this page for templates for TV: http://wiki.linuxmce.org/index.php/LG_42LB5D

Thanks,
Rob