Archive > Xine Player - Users

(Solved) Xine won't play any mp3 or dvx files after .32

(1/2) > >>

After .32 upgrade I'm not able to play divx files.

Here follows the xine device log:

--- Code: ---
10 11/10/05 10:56:58.872 Device: 38641 starting.  Connecting to:
10 11/10/05 10:56:59.463 XServer aspect 0.997884
10 11/10/05 10:56:59.465 Loading config from /etc/pluto/xine.conf
10 11/10/05 10:57:01.061 Using Video driver xv and Audio driver auto
10 11/10/05 10:57:01.063 Setting the audio output speaker arrangement.
10 11/10/05 10:57:01.063 Current value: Stereo 2.0
10 11/10/05 10:57:01.063 Trying to set the value to: Stereo 2.0
10 11/10/05 10:57:01.064 Value changed to: Stereo 2.0
10 11/10/05 10:57:01.064 Connect OK
10 11/10/05 10:57:01.655 Requesthandler 0x809e6e8 (device: 38641) runThread now running
05 11/10/05 10:57:29.141 Xine_Player::CMD_Play_Media() called for filename: /home/public/data/videos/SharkTale - [DivX - Ita].avi () with slave 0x80a6138.
10 11/10/05 10:57:29.141 Instructing ratpoison to do this: ":select pluto-xine-playback-window"
10 11/10/05 10:57:29.173 Command result: ""
10 11/10/05 10:57:29.173 Exiting rat poison command
10 11/10/05 10:57:29.174 Got a create stream command command for /home/public/data/videos/SharkTale - [DivX - Ita].avi
10 11/10/05 10:57:29.174
10 11/10/05 10:57:29.174 Testing to see if we can reuse the stream.
10 11/10/05 10:57:29.174 Nope .. making a new one
10 11/10/05 10:57:29.174 Opening Video Driver
10 11/10/05 10:57:29.204 Opening Audio Driver
05 11/10/05 10:57:29.206 I'm unable to initialize m_pXine's 'auto' audio driver.
01 11/10/05 10:57:29.206 Xine_Player::CMD_Play_Media() failed to play /home/public/data/videos/SharkTale - [DivX - Ita].avi
05 11/10/05 10:57:29.208 Xine_Player::CMD_Play_Media() ended for filename: /home/public/data/videos/SharkTale - [DivX - Ita].avi with slave 0x80a6138.
10 11/10/05 10:57:29.208 Could not find a handler for message - from 38631 to 38641 Type: 1 ID: 192 (device: 38641) Command_Impl1 Dev #38641
10 11/10/05 10:57:29.210 Xine_Player::CMD_Stop_Media() Got a stop media for stream ID 1 (0x80a6138)
Return code: 139
Thu Nov 10 10:57:30 CET 2005 died

--- End code ---

The same applies when trying to play an mp3 file.

I couldn't realize it before because I rebooted my box only yesterday.

It sounds like something is wrong with alsa, but I cannot understand what.

Has something changed with .32 or is it something that I may have messed up in my box?


The key is in this message:

--- Code: ---Could not find a handler for message - from 38631 to 38641 Type: 1 ID: 192 (device: 38641) Command_Impl1 Dev #38641
--- End code ---

Well ... let's try to shed some light on this ...

Device 38631 is Media Plug-in under DCERouter, while device 38641 is Xine Player under Core/Hybrid -> OnScreen Orbiter.

If I understand well it looks like Media Pug-in is sending an "ON" command (ID=192) to Xine Player, but Xine Player does not know how to handle it.

Is it correct?

And if so, what can I do to settle things (besides rebuilding my Pluto box from scratch)?

Could you tell me something more about the message:

--- Code: ---
05   11/10/05 10:57:29.206      I'm unable to initialize m_pXine's 'auto' audio driver.

--- End code ---

Should I worry about that, or is it normal?



I'm not sure if this will help you, but AFAIK :

- in my /etc/pluto/xine.conf I have :

--- Code: ---# audio driver to use
# { auto  null  alsa  oss  arts  esd  none  file }, default: 0

--- End code ---

that means that alsa is used as default audio player (I'm not sure if I changed that file anytime or is original from Pluto distro).

I think that initialization of your xine player fails and then it won't proceed.... Try to play with that settings and see if this will solve your problem... You can also try to run xine player from command line....




Hi Rob and thanks for your help.

I have already checked xine.conf and settings are like yours.
I also tried to take down all pluto stuff and start xine from command line.
The result is that video is played, but no audio.

Then I rebooted my box, and during reboot I noticed the following error:

--- Code: ---
alsactl: set_control:909: failed to obtain info for control #50 No such file or directory)

--- End code ---

So IMHO there is also an issue related to alsa.

I tried to issue

--- Code: ---
alsactl store

--- End code ---

in order to rebuild /var/lib/alsa/asound.state and then rebooted again.

The previous error during boot has disappeared, nevertheless in xine device log nothing has changed and I'm still not able to play anything.

Just to add more info, the day before yesterday I made some tests recompiling kernel and modules. AFAIK this should not affect any particular device, as long as the proper kernel - modules set is loaded.
In fact here modules appears to load properly, just conf data are wrong and this sounds strange.

I'm going to reboot my box with knoppix, just to make sure that hardware is not faulty.

Has anyone some hints form me?



[0] Message Index

[#] Next page

Go to full version