Author Topic: pvr 250 remote  (Read 4622 times)

broschb

  • Newbie
  • *
  • Posts: 8
    • View Profile
pvr 250 remote
« on: January 23, 2008, 06:06:21 am »
I have linuxMCE installed and everything works except for my remote.  I am using a hauppauge pvr 250, and am using the ir sensor that comes with that card, and plugs into the card.  I am using the radioshack15-2116 remote.  I had this working fine under mythtv, but am not sure how to set this up in MCE.  I selected the radioshack remote under media directors but am unsure what to select for infrared recievers, any help is appreciated.

thanks,

broschb

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: pvr 250 remote
« Reply #1 on: January 25, 2008, 01:28:04 am »
I still havn't had any luck, I have changed the lirc.conf files and still am not having success.  Does anyone have any suggestions, or actual steps to take to the remote working?

I may just go back to mythtv, as I know I can easily get that running.

thanks,

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: pvr 250 remote
« Reply #2 on: January 25, 2008, 04:03:25 pm »
Did you have to do anything special to add your pvr250

It was not PNP was it?
You had to add it in the webadmin right?
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

broschb

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: pvr 250 remote
« Reply #3 on: January 25, 2008, 04:26:21 pm »
That is correct, I had to select it from webadmin, and then restart, once I did that everything worked, I can view channels, etc. from mythtv but the remote will not work.


broschb

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: pvr 250 remote
« Reply #4 on: January 28, 2008, 06:43:00 pm »
Has anybody had any success with this card and ir reciever?  I really want to get this working, is there anywhere on the wiki that explains how mce uses lirc, from what I have read it doesn't appear to be set up the same way as a standard lirc install?  Any information on how it is setup would help me to figure out what I need to do to get this working.


thanks,

leonja

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Re: pvr 250 remote
« Reply #5 on: January 29, 2008, 03:09:39 am »
broschb
You don't say much about your equipoment.  Which version of LMCE are you running?  If the PVR-250 comes with the same type of IR receiver (SMK on the back) and remote (RC6 on the back) as the PVR-150 and you are using LMCE 0704, your problem is that the SMK receiver is not supported out of the box by LMCE 0704.  You might want to check this thread.

http://forum.linuxmce.org/index.php?topic=3049.0

Support is supposed to be included out of the box in LMCE 0710.

Good luck,
Jaime
Selectron 42 inch LCD TV
AMD Athlon 2800+ on MSI K7N Motherboard
2x512MB DDR400 RAM
PNY Nvidia FX 5700 AGP video card
Hauppauge PVR-150 MCE capture card
Integrated Realtek 5.1 audio

broschb

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: pvr 250 remote
« Reply #6 on: January 29, 2008, 04:03:17 am »
I am using the following remote, that I had working with mythtv.  It is a radioshack 15-2116, here is a link to the manual, it is not on the radioshack website any longer http://www.radioshack.com/search/manualResults.jsp?sr=1&origkw=15-2116&kw=15-2116&kwCatId=&hideBackToAll=true
If i go to media directors on the admin page it is an option, and I have that selected.  The card is the pvr-250 it has an ir reciever that plugs into the back to the card, I'm not sure what you are referring to by 'SMK'?  I hope this helps, i know that this reciever is compatable with lirc using the i2c module, at least that is how it worked in mythtv.  I am not sure what to select in the admin page under infrared recievers for this? The reciever is small it is jjust a cord with a round(about the size of a penny) reciever on the end, no lights or anything else.

I am using version 710.

below are my logs that show my pvr-250 card and lirc startup

//card
Jan 28 20:37:47 dcerouter kernel: [   87.378447] ivtv:  version 1.0.0 (2.6.22-14-generic SMP mod_unload 586 ) loading
Jan 28 20:37:47 dcerouter kernel: [   87.378745] ivtv0: Autodetected Hauppauge card (cx23415 based)
Jan 28 20:37:47 dcerouter kernel: [   87.379448] ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 5
Jan 28 20:37:47 dcerouter kernel: [   87.379465] ACPI: PCI Interrupt 0000:00:0a.0[A] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
Jan 28 20:37:47 dcerouter kernel: [   87.379488] ivtv0: Unreasonably low latency timer, setting to 64 (was 32)
Jan 28 20:37:47 dcerouter kernel: [   87.456140] input: PC Speaker as /class/input/input2
Jan 28 20:37:47 dcerouter kernel: [   87.578246] input: PS/2 Generic Mouse as /class/input/input3
Jan 28 20:37:47 dcerouter kernel: [   87.605213] parport_pc 00:0a: reported by Plug and Play ACPI
Jan 28 20:37:47 dcerouter kernel: [   87.605279] parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
Jan 28 20:37:47 dcerouter kernel: [   88.667085] ivtv0: loaded v4l-cx2341x-enc.fw firmware (3490834768 bytes)
Jan 28 20:37:47 dcerouter kernel: [   88.754745] ivtv0: loaded v4l-cx2341x-dec.fw firmware (3490834776 bytes)
Jan 28 20:37:47 dcerouter kernel: [   88.975780] ivtv0: Encoder revision: 0x02060039
Jan 28 20:37:47 dcerouter kernel: [   88.983787] ivtv0: Decoder revision: 0x02020023
Jan 28 20:37:47 dcerouter kernel: [   89.056153] tveeprom 1-0050: Hauppauge model 48012, rev G326, serial# 2603871
Jan 28 20:37:47 dcerouter kernel: [   89.056168] tveeprom 1-0050: tuner model is Temic 4036FY5 (idx 26, type 8)
Jan 28 20:37:47 dcerouter kernel: [   89.056176] tveeprom 1-0050: TV standards NTSC(M) (eeprom 0x08)
Jan 28 20:37:47 dcerouter kernel: [   89.056183] tveeprom 1-0050: audio processor is MSP3445 (idx 12)
Jan 28 20:37:47 dcerouter kernel: [   89.056188] tveeprom 1-0050: has radio
Jan 28 20:37:47 dcerouter kernel: [   89.056195] ivtv0: Autodetected Hauppauge WinTV PVR-250
Jan 28 20:37:47 dcerouter kernel: [   89.107686] tuner 1-0061: chip found @ 0xc2 (ivtv i2c driver #0)
Jan 28 20:37:47 dcerouter kernel: [   89.181430] saa7115 1-0021: saa7115 found (1f7115d0e100000) @ 0x42 (ivtv i2c driver #0)
Jan 28 20:37:47 dcerouter kernel: [   89.341464] msp3400 1-0040: MSP3445G-B8 found @ 0x80 (ivtv i2c driver #0)
Jan 28 20:37:47 dcerouter kernel: [   89.341475] msp3400 1-0040: MSP3445G-B8 supports radio, mode is autodetect and autoselect
Jan 28 20:37:47 dcerouter kernel: [   89.350427] tuner 1-0061: type set to 8 (Temic NTSC (4036 FY5))
Jan 28 20:37:47 dcerouter kernel: [   89.634240] ivtv0: Registered device video0 for encoder MPEG (4 MB)
Jan 28 20:37:47 dcerouter kernel: [   89.634645] ivtv0: Registered device video32 for encoder YUV (2 MB)
Jan 28 20:37:47 dcerouter kernel: [   89.635050] ivtv0: Registered device vbi0 for encoder VBI (1 MB)
Jan 28 20:37:47 dcerouter kernel: [   89.635334] ivtv0: Registered device video24 for encoder PCM audio (1 MB)
Jan 28 20:37:47 dcerouter kernel: [   89.635754] ivtv0: Registered device radio0 for encoder radio
Jan 28 20:37:47 dcerouter kernel: [   89.703224] ivtv0: Initialized Hauppauge WinTV PVR-250, card #0
Jan 28 20:37:47 dcerouter kernel: [   89.704076] ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11


//lirc
Jan 28 20:37:47 dcerouter kernel: [   92.835024] lirc_dev: IR Remote Control driver registered, at major 61
Jan 28 20:37:47 dcerouter kernel: [   92.850146] lirc_i2c: no version for "lirc_unregister_plugin" found: kernel tainted.
Jan 28 20:37:47 dcerouter kernel: [   92.995567] bttv: driver version 0.9.17 loaded
Jan 28 20:37:47 dcerouter kernel: [   92.995581] bttv: using 8 buffers with 2080k (520 pages) each for capture
Jan 28 20:37:47 dcerouter kernel: [   93.167809] cx2388x v4l2 driver version 0.0.6 loaded
Jan 28 20:37:47 dcerouter kernel: [   93.177957] lirc_i2c: chip 0x10020 found @ 0x18 (Hauppauge IR)
Jan 28 20:37:47 dcerouter kernel: [   93.178075] lirc_dev: lirc_register_plugin: sample_rate: 10


Thanks again for your help.
« Last Edit: January 29, 2008, 04:43:51 am by broschb »

broschb

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: pvr 250 remote
« Reply #7 on: January 29, 2008, 06:13:49 am »
technoobie, thanks for your help, I'll give this a shot tommorrow.  What exactly did you have to do to load the driver, and also if you wouldn't mind providing your conf files, so that I can compare them with the ones I have that worked in mythtv.  Thanks again for your help, I'll give this a shot tommorrow and post my results.

broschb

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: pvr 250 remote
« Reply #8 on: January 30, 2008, 05:33:51 am »
Thanks to everyone for their help, I have things mostly working but have an additional question.  I have the remote working but need to map a few more keys, is there somewhere that I can get a list of all of the valid key names to put in my lircd.conf?  I believe they are stored in the database, is this correct and if so how would I retrieve them? 

For anyone else who may encounter the card and reciever that I have I did the following to resolve my issue.

I used the Ir-kbd-i2c driver, Since all of the documentation for adding a device I found, wasn't quite correct for the version of lmce that i am using below is how I added my remote.  I went to Wizard>devices>media detectors and selected add device at the bottom.  In the popup I selected hauppauge as the manufacturer, (i don't really think this matters other than to find the device). and in the device categor I selected LIRC Remote Controls<RemoteControls < Peripherals and clicked add device template.  IN the next dialog i gave it a name and clicked add.  Now the part that I couldn't find any documentation on.  Go to advanced<configuration<device templates.  Now select the manufacturer and device category and device template for the device you just added, and click pick device template, this opens a new dialog, here I just copied the settings from an existing hauppauge lircd.conf and updated according to my remote.  Under current data i had to add a new parameter #59 configuration(String) and in the default value paste the lircd.conf that you wish to use.  the click save.  Then under media directors select the new remote, for IR reciever I tried to create a new device but it never worked, i finally selected default and rebooted and it worked.

broschb

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: pvr 250 remote
« Reply #9 on: February 05, 2008, 04:12:55 am »
I edited the file using a text editor and then using the admin console pasted it in the default value of the device template.  For you're remote I believe one of the included conf files will work.  I you use the hauppauge manufacturer and then select LIRC remoteControls<Remote Controls< peripherals and use the lircd.conf.hauppauge for the device template that should work.  If you want to verify the codes you can run mode2(sudo mode2 -d /dev/lirc0) or whatever your lirc is.  Then press buttons to see the codes, these should match the codes in your lircd.conf for example on mine for up in mode 2 it shows 0x1266 and in my lircd.conf I have 'Up          0x0000000000001266'.  Once your lircd.conf is set up correctly you can run irw and you will see console output if the keycodes are mapped correctly.  Hope this helps.