Author Topic: Nas box doesn'T let me access my files  (Read 5336 times)

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Nas box doesn'T let me access my files
« on: December 30, 2015, 08:49:01 pm »
I got a seagate blackarmor as a nas. my lmce runs on 12.04. The nas is detected and lmce can see all the files. I'm using lmce file structure there.
Now all my files there belong to root. Even though the acl says, that everyone can do anything...my windows10 pcs cannot access anything, even though I've connected with credentials from lmce.
Do you guys have any idea, what I could do?

Marie.O

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3675
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Nas box doesn'T let me access my files
« Reply #1 on: December 30, 2015, 11:20:39 pm »
So LinuxMCE can access everything on the NAS, but the Windows system trying to access the files directly on the NAS can't?

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #2 on: December 31, 2015, 09:33:23 am »
That is correct

Marie.O

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3675
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Nas box doesn'T let me access my files
« Reply #3 on: December 31, 2015, 11:24:34 am »
Sound like Win10 uses a different access scheme and needs to be allowed to access less secure resources... or you go via the LinuxMCE share to the Seagate share.

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #4 on: December 31, 2015, 04:50:12 pm »
The problem is....whether I access the nas directly, or via linuxmce share, its the same

cht_winston

  • Newbie
  • *
  • Posts: 14
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #5 on: January 02, 2016, 09:26:11 am »
Hi Guys,

I've seen this a couple of times now and it's probably due to using an older version of Samba but I must say that I have not seen the problem for a few months so thought Win10 may have been patched. Try the following:-

 In Windows 10 (or Win7 for that matter) in Control Panel and in Category view click on the text “System and Security”, then click on the text “Administrative Tools”.
Now double click and open “Local Security Policy”.
In the Local Security Policy screen on the left navigation tree, expand the “Local Policies –> Security Options” then about 2/3rd’s the way down the list you’ll see a Policy called “Network Security: LAN Manager authentication level”. Double click and change the setting to be “Send LM & NTLM – use NTLMv2 session security if negotiated.”
Then just press OK and close all of the open windows and then try again

In the case of Windows 10 Home, Local Security Policy does not exist; therefore make the change in the registry (use regedit).

HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\LSA
Add:
LMCompatibilityLevel
Value Type: REG_DWORD – Number (32 bit, hexadecimal)
Valid Range 0-5
Default: 0, Set to 1 (Use NTLMv2 session security if negotiated)
Description: This parameter specifies the type of authentication to be used.

Convergent Home Technologies Ltd
Personal Core
Asus M2NPV-VM, AMD Athlon 4200+ X2
Integrated C51PV (Nvidia 6150)
3 * 500GB NAS
2 * NIC (Marvell + Intel PCI-E pro 1000)
Hauppauge Nova-T 500
Thermaltake Lanbox Lite case
Nesteq semi-Fanless 45
HomePro Zwave Interface

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1751
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #6 on: January 02, 2016, 08:17:43 pm »
Thanks for the suggestion cht_winston!  That's not a simple one to track down!  Mav, hopefully that helps you out.

J.

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #7 on: January 03, 2016, 02:46:53 pm »
I wish, but I don't think so. Upon closer inspection, I made a wrong report. Accessing the nas directly, everything is ok. However accessing it through the share of linuxmce, I cannot get to the files, because there everything belongs to root. I can confirm this, by accessing the same path with my android device, which gives  me the same result. So  I believe the  problem lies with linuxmce, rather win10 or android.

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1751
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #8 on: January 04, 2016, 03:08:03 am »
mhm, seems strange.  I have no problem accessing my NAS directly or through linuxmce.  When you attempt to access through linuxmce you should be asked for your lmce username and password, is that occuring?

J.

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #9 on: January 04, 2016, 11:32:50 am »
nope, that is not ocurring

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1751
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #10 on: January 04, 2016, 01:45:02 pm »
Windows should be asking you for credentials to access all the lmce shares, if it does not you will not be able to access the files.  My windows boxes pop up a username/password screen when I attempt to access the lmce shares, after that I have full access to the shares.

J.

maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #11 on: January 04, 2016, 10:02:58 pm »
okay...that is occuring, when I try to access the normal shares. I was a bit on the wrong track, since I thought you suggested it would ask me again, if I tried to go through the share to the nas. my mistake then.
when I first put the nas to use I created a public share, that give access to everybody. thats how I can access it by bypassing lmce, but I would much rather like to go through lmce, but there lmce is hogging it all for itself and doesn't like to give access

phenigma

  • LinuxMCE God
  • ****
  • Posts: 1751
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #12 on: January 04, 2016, 10:08:11 pm »
If you try to access the files through dcerouter then windows should ask you for a username and password, they would be the same username and password you use for webadmin.

J.

Govo

  • Guru
  • ****
  • Posts: 204
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #13 on: January 06, 2016, 08:03:57 pm »
Hi maverick0815

In windows are you able to access using run ? open up RUN from the start menu  and enter \\192.168.80.1  this will open the network  enter your root username and password for LinuxMce.

If you get any errors, like can't find the path then your windows machine is not on the same network as LMCE, if your using virtualbox you need to change the network settings from NAT to bridged.

Cheers
Govo





maverick0815

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 858
    • View Profile
Re: Nas box doesn'T let me access my files
« Reply #14 on: January 07, 2016, 08:37:50 am »
all components, my pc, nas, dcerouter are in the same Network. dcerouter is dhcp for everything. on my Windows pc I have several drives successfully mapped from dcerouter like \\dcerouter\public\data\videos for example. absolutely no Problem there. accessing the nas, which has a public share, through linuxmce is also working, with the acception, that I cannot Access anything. Going to \\dcerouter\pulic\data\videos\[windows share of my nas]\ I can see Folders there, but I cannot Access them.