Author Topic: Phoenix solo usb mic in 10.04 media director--crashes system--guidance needed  (Read 3248 times)


  • Veteran
  • ***
  • Posts: 82
    • View Profile
First apologies if this is the wrong place to post this.

After seeing Tschak909's post about simple phone and Phoenix solo:,13314.0.html

I thought I would dust mine off and try it. In 8.10 there had been a number of glitches with symbolic links and the version of alsa being used which I was able to fix:,10428.15.html

But in 10.04 my Phoenix solo never worked on my Media Director. Back in May 2013 when I first installed the MD I got this after I plugged it in:

dmesg gives this:

[ 9120.397530] usb 2-1: new full speed USB device using uhci_hcd and address 3
[ 9120.608612] usb 2-1: configuration #1 chosen from 1 choice
[ 9120.614550] input: AKM                       AK4571                    as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.3/input/input8
[ 9120.614806] generic-usb 0003:0556:0004.0004: input,hidraw3: USB HID v1.10 Device [AKM                       AK4571                   ] on usb-0000:00:1d.0-1/input3

then when I ran the command:


The MD froze. In other words, the system would initially see the mic and register it, but when I would command line lsusb the whole system froze and you had to do a hard boot.

Now, several update/upgrades later I was hoping this had been fixed: I boot the MD with nothing attached except the USB UIRT, HDMI and network cable (no keyboard, mouse, usb hub etc) and see this with dmesg:

Code: [Select]
[  252.416030] usb 2-2: new full speed USB device using uhci_hcd and address 3
[  252.676833] usb 2-2: configuration #1 chosen from 1 choice
[  252.821353] usbcore: registered new interface driver hidden
if I run aplay -l or lsusb it get this in dmesg:
Code: [Select]
[  317.829503] BUG: soft lockup - CPU#3 stuck for 61s! [modprobe:10775]
[  317.829503] Modules linked in: usbhid(+) snd_usb_audio(+) hid snd_usbmidi_lib nls_utf8 cifs snd_hda_codec_nvhdmi snd_hda_codec_realtek snd_pcm_oss snd_hda_intel snd_mixer_oss snd_hda_codec snd_hwdep snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device snd soundcore snd_page_alloc appletalk ppdev lp parport autofs4 ftdi_sio psmouse asus_atk0110 usbserial serio_raw xhci nvidia(P) nfsd exportfs nfs lockd nfs_acl auth_rpcgss sunrpc raid10 raid456 async_raid6_recov async_pq raid6_pq async_xor xor async_memcpy async_tx raid1 raid0 multipath linear nbd atl1c fbcon tileblit font bitblit softcursor uvesafb ahci r8168 intel_agp agpgart [last unloaded: soundcore]
[  317.829573]
[  317.829573] Pid: 10775, comm: modprobe Tainted: P        W  (2.6.32-46-generic #108-Ubuntu) System Product Name
[  317.829573] EIP: 0060:[<f0621e40>] EFLAGS: 00000282 CPU: 3
[  317.829573] EIP is at find_audio_control_unit+0x30/0x70 [snd_usb_audio]
[  317.829573] EAX: ecd8863d EBX: ed2efd78 ECX: ecd8863d EDX: ecd88677
[  317.829573] ESI: 00000006 EDI: ed2efcd4 EBP: ed2efc4c ESP: ed2efc40
[  317.829573]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[  317.829573] CR0: 8005003b CR2: 223bc2e4 CR3: 2c0d6000 CR4: 000006d0
[  317.829573] DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
[  317.829573] DR6: ffff0ff0 DR7: 00000400
[  317.829573] Call Trace:
[  317.829573]  [<f0621ead>] check_input_term+0x2d/0x240 [snd_usb_audio]
[  317.829573]  [<f0623c84>] parse_audio_unit+0x5d4/0xce0 [snd_usb_audio]
[  317.829573]  [<c034faea>] ? idr_get_empty_slot+0x9a/0x130
[  317.829573]  [<f0623802>] parse_audio_unit+0x152/0xce0 [snd_usb_audio]
[  317.829573]  [<c0263444>] ? __sysfs_add_one+0x24/0xc0
[  317.829573]  [<c021f035>] ? iput+0x25/0x60
[  317.829573]  [<c0595373>] ? notifier_call_chain+0x43/0x60
[  317.829573]  [<f0624418>] ? snd_usb_create_mixer+0x88/0x370 [snd_usb_audio]
[  317.829573]  [<f06244fa>] snd_usb_create_mixer+0x16a/0x370 [snd_usb_audio]
[  317.829573]  [<f0621637>] usb_audio_probe+0x227/0x7b0 [snd_usb_audio]
[  317.829573]  [<c044feb0>] usb_probe_interface+0xc0/0x180
[  317.829573]  [<c0263a47>] ? sysfs_create_link+0x17/0x20
[  317.829573]  [<c03ebdfd>] really_probe+0x4d/0x140
[  317.829573]  [<c03f270e>] ? pm_runtime_barrier+0x4e/0xc0
[  317.829573]  [<c03ebf2c>] driver_probe_device+0x3c/0x60
[  317.829573]  [<c03ebfd1>] __driver_attach+0x81/0x90
[  317.829573]  [<c03eb413>] bus_for_each_dev+0x53/0x80
[  317.829573]  [<c03ebcce>] driver_attach+0x1e/0x20
[  317.829897]  [<c03ebf50>] ? __driver_attach+0x0/0x90
[  317.829897]  [<c03eb695>] bus_add_driver+0xd5/0x280
[  317.829897]  [<c03ec2ca>] driver_register+0x6a/0x130
[  317.829897]  [<c044fc51>] usb_register_driver+0x81/0xf0
[  317.829897]  [<c01a9337>] ? tracepoint_module_notify+0x27/0x30
[  317.829897]  [<c0595373>] ? notifier_call_chain+0x43/0x60
[  317.829897]  [<f03e503a>] snd_usb_audio_init+0x3a/0x3c [snd_usb_audio]
[  317.829897]  [<c016de44>] ? __blocking_notifier_call_chain+0x54/0x70
[  317.829897]  [<c0101131>] do_one_initcall+0x31/0x190
[  317.829897]  [<f03e5000>] ? snd_usb_audio_init+0x0/0x3c [snd_usb_audio]
[  317.829897]  [<c0183960>] sys_init_module+0xb0/0x210
[  317.829897]  [<c01033ec>] syscall_call+0x7/0xb
[  317.829897]  [<c0590000>] ? acpi_processor_power_init+0x90/0x14b
I can take the same Phoenix solo usb mic and run it with no problems on Raspberry Pi or Mac OS 10.9 so I am sure it is not the device itself.

From google I found that there was a bug in 10.04 for usb devices which was fixed by changing the grub script:

or patching the kernel:

But when I start digging into doing this on a MD all of the solutions listed above can not be done from the command line in moon because (I am assuming) of the diskless boot. It turns out that my MD and my core are using different kernels--just to make things more complex.

So, I am wondering what the best way to proceed might be:

1. Upgrade the kernel on the MD?

2. Upgrade a package on the MD?

3. Upgrade (or down grade) alsa on the MD?

4. Change the grub2 script

In all these cases, I need to understand better how you change the image for the diskless boot. While I get hints here and there I can't find anything that allows you to only change the image for the MD without touching what is going on on the core.

Not wanting to destroy everything that is working just for this microphone I am wondering if anyone has experience/suggestions on how best to fix this. Any advice/experience would be greatly appreciated.
« Last Edit: October 30, 2013, 04:18:34 pm by sedgington »