AgoControl > Developers

MCE mini install issue on Intel D525MW - realtek 8111 on fedora 12

(1/3) > >>

in my quest to get Linux home automation to work on my low power Mini board of Intel D525MW, i am now trying to install the mini install based upon Fed 12.
Fedora 12 installs fine, but now i have an issue that the NIC Realtek 8111/ 8168B does not work anymore.

I have checked the forums and it seems to be a general problem, also with Fed 13.
several attempts to install the new driver from Realtek did not work yet.
get error msgs when executing "make clean modules"..
found  /linux-networking-3/how-to-install-the-rtl-8168-8111-driver-555491/ describing the same issue, but did not come up with a solution.

anyone any suggestions on how to continue with the mini install ?  would like to be able to use Linux and zwave for home automation.. but sofar not much luck..
i am not a expert in Linux, but do know my way around with the command line..


sofar i have tried to install the complete Linux MCE version 810. This one failed during the install with the message "installing Firefox".. seems to be a know issue.
tried to install fedora 13 with ISO download - this one failed to load - apparently due to know issues on gigabit motherboards ?
now tried to install fedora 12, but blocked due to NIC realtek 8111....

what did not work with the driver installation?

Hi Hari,

thanks for looking at the issue. Pulling my hair out to get a linuxmce to work on this machine..

issue is similar as something posted a long time ago in the general forum. I copied that below. for me its a different directory, but similar errors are occuring for me. error 2..
I get up to the command: make clean modules and then similar as below occurs.. (but with different directory). i can post the exact when i am home.

make -C /lib/modules/2.6.18-1.2798.fc6xen/build SUBDIRS=/usr/local/src/r1000_v1.05/src modules
make: Entering an unknown directory
make: *** /lib/modules/2.6.18-1.2798.fc6xen/build: no that file or directory。 stop。
make: Leaving an unknown directory
make[1]: *** [modules] error 2
make[1]: Leaving directory `/usr/local/src/r1000_v1.05/src'
make: *** [modules] error 2

maybe i have to install the driver differently? i saw somewhere a suggestion to do ": sudo ./ but i have not tried it..

where did you get that instructions from?

Hi Hari,

I have been searching the internt  for a solution.

have found the following :

sudo apt-get install linux-headers-$(uname-r)
sudo aptitude install build-essential
tar xvfs r8168-8.018.00.tar.bz2  (should be the new driver probably r8168-8.026.00.tar.bz2)
cd r8168-8.018.00/
sudo ./
sudo reboot

have not had time to try it out yet.. will do so soon


[0] Message Index

[#] Next page

Go to full version