Author Topic: [SOLVED] Solo USB microphone problem  (Read 15663 times)


  • Veteran
  • ***
  • Posts: 82
    • View Profile
Re: [SOLVED] Solo USB microphone problem
« Reply #15 on: November 30, 2012, 08:21:34 pm »
Here is a fix that worked for me when my 8.10 system went down with Sandy and as I rebuilt it I decided to fix all those little things that irritated me along the way:

This problem is apparently a bug that has been documented with other ubuntu users of that era and was successfully fixed by upgrading alsa to later versions. I decided to upgrade to the most recent alsa version after my tv, video etc were all working and I found that when I downgraded, as suggested above, the phone worked but the tv, video sound did not and I didn't want to jump into the morass of an earlier alsa to figure it out.

I worked from the instructions found here:

but found that the libncurses-dev file was the wrong one for upgrading the alas-utils. I have changed that in the instructions below:

remove the existing alsa:

apt-get remove alsa-modules-`uname -r`

you can replace it later if you have problems with:

apt-get install alsa-modules-`uname -r`
then reboot
now the drivers load, the phone rings, but the video and tv sound don't work
after the reboot:

root@dcerouter:~# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.17.
(the previous version which you just removed was 1.0.23)

so rather than mess around with the old driver lets dive in and try and install the latest alsa driver and see if that improves things:
Make a directory where you are going to store things initially:

sudo mkdir -p ~/downloads/alsa
Get all the files you will need to build alsa:

apt-get -y install build-essential libncursesw5-dev get text xmlto

sudo apt-get -y install linux-headers-`uname -r`
Switch into the directory you made and start downloading the alsa files:
cd ~/downloads/alsa

make a directory where you will unpack everything

sudo mkdir -p /usr/src/alsa

then copy the files you just downloaded into that directory:

cp * /usr/src/alsa
now unpack:

cd /usr/src/alsa/

sudo tar xjf alsa-driver*

sudo tar xjf alsa-lib*

sudo tar xjf alsa-utils*

Compile alsa driver:
cd alsa-driver*

sudo ./configure

sudo make
(this takes awhile)
sudo make install
compile  alsa-lib:
cd ../alsa-lib*
sudo ./configure
sudo make
sudo make install

compile alsa-utils
cd ../alsa-utils*
sudo ./configure
sudo make
sudo make install

cat /proc/asound/version

Advanced Linux Sound Architecture Driver Version 1.0.25.

aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: AK4571 [AK4571], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

then go unmute everything in:


(highlight and press m for any columns that are marked MM and use your keyboard arrows to navigate to raise or lower sound levels)
hit esc
play a video, and tv--works
call the MD with the Phoenix Solo--attached speakers work

Hope this helps!