Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - CentralMedia

Pages: 1 ... 8 9 [10] 11
136
Users / Re: MKV's with mediatomb
« on: August 27, 2013, 03:55:11 pm »
See below

Quote
g++ id3tagTesting.c
id3tagTesting.c:1: error: expected constructor, destructor, or type conversion before â<â token
In file included from /usr/include/c++/4.4/string:53,
                 from id3tagTesting.c:2:
/usr/include/c++/4.4/bits/basic_string.h:2242: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.h:2243: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.h:2243: error: âtypename __gnu_cxx::__enable_if<std::__is_char::__value, bool>::__type std::operator==(const int&, const int&)â must have an argument         of class or enumerated type
/usr/include/c++/4.4/bits/basic_string.h:2488: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.h:2488: error: template-id âoperator>><>â for âstd::basic_istream<char, std::char_traits<char> >& std::operator>>(std::basic_istream<char, std::char_t        raits<char> >&, int&)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.h:2547: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.h:2547: error: template-id âgetline<>â for âstd::basic_istream<char, std::char_traits<char> >& std::getline(std::basic_istream<char, std::char_traits<        char> >&, int&, char)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.h:2553: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.h:2553: error: template-id âgetline<>â for âstd::basic_istream<wchar_t, std::char_traits<wchar_t> >& std::getline(std::basic_istream<wchar_t, std::cha        r_traits<wchar_t> >&, int&, wchar_t)â does not match any template declaration
In file included from /usr/include/c++/4.4/string:56,
                 from id3tagTesting.c:2:
/usr/include/c++/4.4/bits/basic_string.tcc:1111: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.tcc:1114: error: âstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1114: error: template-id âoperator>><>â for âstd::basic_istream<char, std::char_traits<char> >& std::operator>>(std::basic_istream<char, std::char        _traits<char> >&, int&)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1117: error: expected â,â or â...â before â&â token
/usr/include/c++/4.4/bits/basic_string.tcc:1117: error: template-id âoperator<< <>â for âstd::basic_ostream<char, std::char_traits<char> >& std::operator<<(std::basic_ostream<char, std::cha        r_traits<char> >&, int)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1120: error: âstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1120: error: template-id âgetline<>â for âstd::basic_istream<char, std::char_traits<char> >& std::getline(std::basic_istream<char, std::char_trait        s<char> >&, int&, char)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1123: error: âstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1123: error: template-id âgetline<>â for âstd::basic_istream<char, std::char_traits<char> >& std::getline(std::basic_istream<char, std::char_trait        s<char> >&, int&)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1126: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/basic_string.tcc:1129: error: âwstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1129: error: template-id âoperator>><>â for âstd::basic_istream<wchar_t, std::char_traits<wchar_t> >& std::operator>>(std::basic_istream<wchar_t,         std::char_traits<wchar_t> >&, int&)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1132: error: expected â,â or â...â before â&â token
/usr/include/c++/4.4/bits/basic_string.tcc:1132: error: template-id âoperator<< <>â for âstd::basic_ostream<wchar_t, std::char_traits<wchar_t> >& std::operator<<(std::basic_ostream<wchar_t,         std::char_traits<wchar_t> >&, int)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1135: error: âwstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1135: error: template-id âgetline<>â for âstd::basic_istream<wchar_t, std::char_traits<wchar_t> >& std::getline(std::basic_istream<wchar_t, std::c        har_traits<wchar_t> >&, int&, wchar_t)â does not match any template declaration
/usr/include/c++/4.4/bits/basic_string.tcc:1138: error: âwstringâ has not been declared
/usr/include/c++/4.4/bits/basic_string.tcc:1138: error: template-id âgetline<>â for âstd::basic_istream<wchar_t, std::char_traits<wchar_t> >& std::getline(std::basic_istream<wchar_t, std::c        har_traits<wchar_t> >&, int&)â does not match any template declaration
In file included from /usr/include/c++/4.4/bits/ios_base.h:43,
                 from /usr/include/c++/4.4/ios:43,
                 from /usr/include/c++/4.4/istream:40,
                 from /usr/include/c++/4.4/sstream:39,
                 from id3tagTesting.c:3:
/usr/include/c++/4.4/bits/locale_classes.h:213: error: âstringâ does not name a type
/usr/include/c++/4.4/bits/locale_classes.h:611: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/locale_classes.h:786: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
In file included from /usr/include/c++/4.4/bits/locale_classes.h:809,
                 from /usr/include/c++/4.4/bits/ios_base.h:43,
                 from /usr/include/c++/4.4/ios:43,
                 from /usr/include/c++/4.4/istream:40,
                 from /usr/include/c++/4.4/sstream:39,
                 from id3tagTesting.c:3:
/usr/include/c++/4.4/bits/locale_classes.tcc: In member function âvirtual int std::collate<_CharT>::do_compare(const _CharT*, const _CharT*, const _CharT*, const _CharT*) constâ:
/usr/include/c++/4.4/bits/locale_classes.tcc:142: error: request for member âc_strâ in â__oneâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:143: error: request for member âdataâ in â__oneâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:143: error: request for member âlengthâ in â__oneâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:144: error: request for member âc_strâ in â__twoâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:145: error: request for member âdataâ in â__twoâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:145: error: request for member âlengthâ in â__twoâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc: In member function âvirtual int std::collate<_CharT>::do_transform(const _CharT*, const _CharT*) constâ:
/usr/include/c++/4.4/bits/locale_classes.tcc:180: error: request for member âc_strâ in â__strâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:181: error: request for member âdataâ in â__strâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:181: error: request for member âlengthâ in â__strâ, which is of non-class type âconst intâ
/usr/include/c++/4.4/bits/locale_classes.tcc:206: error: request for member âappendâ in â__retâ, which is of non-class type âintâ
/usr/include/c++/4.4/bits/locale_classes.tcc:212: error: request for member âpush_backâ in â__retâ, which is of non-class type âintâ
In file included from /usr/include/c++/4.4/ios:43,
                 from /usr/include/c++/4.4/istream:40,
                 from /usr/include/c++/4.4/sstream:39,
                 from id3tagTesting.c:3:
/usr/include/c++/4.4/bits/ios_base.h: At global scope:
/usr/include/c++/4.4/bits/ios_base.h:223: error: expected â,â or â...â before â&â token
/usr/include/c++/4.4/bits/ios_base.h:234: error: âstringâ does not name a type
In file included from /usr/include/c++/4.4/bits/basic_ios.h:39,
                 from /usr/include/c++/4.4/ios:45,
                 from /usr/include/c++/4.4/istream:40,
                 from /usr/include/c++/4.4/sstream:39,
                 from id3tagTesting.c:3:
/usr/include/c++/4.4/bits/locale_facets.h:1643: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/locale_facets.h:1744: error: âstringâ does not name a type
/usr/include/c++/4.4/bits/locale_facets.h:1812: error: âstringâ does not name a type
/usr/include/c++/4.4/bits/locale_facets.h:1872: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/c++/4.4/bits/locale_facets.h:2102: error: âstringâ has not been declared
In file included from /usr/include/c++/4.4/bits/locale_facets.h:2599,
                 from /usr/include/c++/4.4/bits/basic_ios.h:39,
                 from /usr/include/c++/4.4/ios:45,
                 from /usr/include/c++/4.4/istream:40,
                 from /usr/include/c++/4.4/sstream:39,
                 from id3tagTesting.c:3:
/usr/include/c++/4.4/bits/locale_facets.tcc:123: error: expected â,â or â...â before â&â token
/usr/include/c++/4.4/bits/locale_facets.tcc:131: error: âstringâ has not been declared
/usr/include/c++/4.4/bits/locale_facets.tcc: In member function â_InIter std::num_get<_CharT, _InIter>::_M_extract_float(_InIter, _InIter, std::ios_base&, std::_Ios_Iostate&, int&) constâ:
/usr/include/c++/4.4/bits/locale_facets.tcc:190: error: âstringâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:190: error: expected â;â before â__found_groupingâ
/usr/include/c++/4.4/bits/locale_facets.tcc:192: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:256: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:263: error: request for member âclearâ in â__xtrcâ, which is of non-class type âintâ
/usr/include/c++/4.4/bits/locale_facets.tcc:277: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:300: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:336: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc: In member function â_InIter std::num_get<_CharT, _InIter>::_M_extract_int(_InIter, _InIter, std::ios_base&, std::_Ios_Iostate&, _ValueT&) constâ        :
/usr/include/c++/4.4/bits/locale_facets.tcc:446: error: âstringâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:446: error: expected â;â before â__found_groupingâ
/usr/include/c++/4.4/bits/locale_facets.tcc:448: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:494: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:534: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:547: error: â__found_groupingâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc: In member function âvirtual _InIter std::num_get<_CharT, _InIter>::do_get(_InIter, _InIter, std::ios_base&, std::_Ios_Iostate&, float&) constâ:
/usr/include/c++/4.4/bits/locale_facets.tcc:674: error: âstringâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:674: error: expected â;â before â__xtrcâ
/usr/include/c++/4.4/bits/locale_facets.tcc:675: error: â__xtrcâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc: In member function âvirtual _InIter std::num_get<_CharT, _InIter>::do_get(_InIter, _InIter, std::ios_base&, std::_Ios_Iostate&, double&) constâ:
/usr/include/c++/4.4/bits/locale_facets.tcc:689: error: âstringâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:689: error: expected â;â before â__xtrcâ
/usr/include/c++/4.4/bits/locale_facets.tcc:690: error: â__xtrcâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc: In member function âvirtual _InIter std::num_get<_CharT, _InIter>::do_get(_InIter, _InIter, std::ios_base&, std::_Ios_Iostate&, long double&) co        nstâ:
/usr/include/c++/4.4/bits/locale_facets.tcc:721: error: âstringâ was not declared in this scope
/usr/include/c++/4.4/bits/locale_facets.tcc:721: error: expected â;â before â__xtrcâ
/usr/include/c++/4.4/bits/locale_facets.tcc:722: error: â__xtrcâ was not declared in this scope
In file included from /usr/include/id3/utils.h:37,
                 from /usr/include/id3/tag.h:34,
                 from id3tagTesting.c:4:
/usr/include/id3/id3lib_strings.h: At global scope:
/usr/include/id3/id3lib_strings.h:198: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/id3/id3lib_strings.h:198: error: invalid type in declaration before â;â token
/usr/include/id3/id3lib_strings.h:199: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/id3/id3lib_strings.h:199: error: invalid type in declaration before â;â token
/usr/include/id3/id3lib_strings.h:200: error: wrong number of template arguments (1, should be 3)
/usr/include/c++/4.4/bits/basic_string.h:104: error: provided for âtemplate<class _CharT, class _Traits, class _Alloc> class std::basic_stringâ
/usr/include/id3/id3lib_strings.h:200: error: invalid type in declaration before â;â token
id3tagTesting.c: In function âint main()â:
id3tagTesting.c:9: error: âstringâ was not declared in this scope
id3tagTesting.c:9: error: expected â;â before âmystrâ
id3tagTesting.c:12: error: âmystrâ was not declared in this scope


137
Users / Re: MKV's with mediatomb
« on: August 27, 2013, 01:30:58 am »
Really silly, but my c++ is none existant and I am trying to test reading the id3 tags.

Pieced this together of the internet but getting compile errors, advice welcomed. Just want to pass the id3 tag file and then display output, just checking to see how it works, yes will get a c++ for dummies

Quote
#include <iostream>
#include <string>
#include <sstream>
#include <id3/tag.h>
using namespace std;

int main ()
{
  string mystr;

  cout << "Enter file ";
  getline (cin,mystr);
  ID3_Tag myTag(mystr);
  //use an std::auto_ptr here to handle object cleanup automatically
   ID3_Tag::Iterator* iter = myTag.CreateIterator();
   ID3_Frame* myFrame = NULL;
   while (NULL != (myFrame = iter->GetNext()))
   {
     cout << "Frame " << myFrame << "yea";
   }
   delete iter;
 
  return 0;
}


138
Users / Re: MKV's with mediatomb
« on: August 26, 2013, 11:46:14 pm »
I have been looking on their forum and found this taglib and LNMCE version used is complied with it, though id3lib is not

I have yet to figure out how its works and from where (how to run it). But my plan hopefully is to get it or a similar tool reading the existing id3 tags that are in LMCE.


139
Users / Re: MKV's with mediatomb
« on: August 26, 2013, 04:55:13 pm »
Quick question, anyone got linuxmce coverart display in mediatomb?

140
Users / Re: MKV's with mediatomb
« on: August 26, 2013, 04:09:56 pm »
Got the mkv to show without transcoding, it seems that mediatomb does not just add the new mime types, so I thought of an re-import, but no luck.

I then deleted all the files on the mediatomb site http://192.168.80.1:49153/, drop the database tables in pluto_mediatomb, recreated them using the /usr/share/mediatomb/mysql.sql and restarted the core; no luck with sudo /etc/init.d/mediatomb restart.

This then started the DB import, and I can see the mkv files now.

Also added the following <map from="mka" to="video/x-matroska"/>

Next step, see if I can get my galaxy tab to see and play the files, that should be easy now as the WD live tv, does it.

If there is a better way to do it, I am open to suggestions.

141
Installation issues / Re: Best download location
« on: August 25, 2013, 02:17:34 pm »
I downloaded 10:04 from http://linuxmce.iptp.org/release/LinuxMCE-1004-final.iso

Use image burn on win 7 and also verified the image, it has served me will doing multiple re-installs as I messed things up.


142
Users / MKV's with mediatomb
« on: August 25, 2013, 01:11:20 am »
I do not want to re-encode my mkv's at this time, as the WD live, supports mkv's. Unfortunately I do not see any MKV's via mediatomb.

I add the following to mediatomb config, reboot the machine,  to see if its helps, but not luck, I still only see avi's

<map from="mkv" to="video/x-matroska"/>






143
Installation issues / Re: HDMI NO AUDIO GT 430
« on: August 22, 2013, 07:20:37 pm »
No I did not do that upgrade of alsa, will look at this over the weekend, should have some free time then.

144
Installation issues / Re: HDMI NO AUDIO GT 430
« on: August 21, 2013, 12:24:19 am »
Na that did not help.

Every thing seems to work well with the 260 driver I might very well keep it or might stick with the 720p resolution

145
Installation issues / Re: HDMI NO AUDIO GT 430
« on: August 20, 2013, 01:44:41 pm »
Will try that this afternoon, when I reach home from work and let u know

146
Installation issues / Re: HDMI NO AUDIO GT 430
« on: August 20, 2013, 11:19:24 am »
Yes it has an xorg.conf, its using the nvidia driver and  "720p (16:9)".

147
Installation issues / Re: HDMI NO AUDIO GT 430
« on: August 20, 2013, 09:51:31 am »
Yes it was removed saw the message saying it did not exist and I also rebooted with this

/usr/pluto/bin/RebootWithAVWizard.sh


148
Installation issues / Re: HDMI NO AUDIO GT 430
« on: August 20, 2013, 02:57:52 am »
Ok

I went ahead and tried upgrading to the current Nvidia driver following below. On reboot, it kept re-installing the 260 driver, so I removed the card entry from nvidia-install.sh and rebooted, which kept the 304*.

Quote
/usr/pluto/bin/Stop_X.sh
add-apt-repository ppa:ubuntu-x-swat/x-updates
apt-get update
apt-get install -y nvidia-current

The issue is, I cannot choose 1080p for my resolution, it bigger than the screen, only getting through with 720p, is this expected with the 304*


149
Installation issues / Re: HDMI NO AUDIO GT 430
« on: August 17, 2013, 03:03:15 am »
Ok although I got audio in Av Wizard, did not get any on xine. Found someone else who disable Use AC3/DTS pass-through, and rebooted, then I got audio, maybe its the TV, its a simple Toshiba, no receiver.

 So still smiling, thus far. Also I believe I am using vdpau, set it in the admin page and also for Deinterlace Quality.

150
Installation issues / Re: HDMI NO AUDIO GT 430
« on: August 17, 2013, 02:01:35 am »
I did the following

Quote
apt-get update
CurKernel="-generic"
if uname -r | grep "pae"; then CurKernel="-generic-pae"; fi
NewKernel="linux-image${CurKernel}-lts-backport-natty"
NewHeaders="linux-headers${CurKernel}-lts-backport-natty"
apt-get -yf install "$NewKernel"
apt-get -yf install "$NewHeaders"
apt-get -yf remove linux-headers${CurKernel}
apt-get -yf remove linux-image${CurKernel}
apt-get -yf dist-upgrade

When it finished I rebooted, the headers were not installed realized after I rebooted, as the second variable NewHeaders seemed to have not been set, so I installed the hearders after.

Then I did the following

Quote
/usr/pluto/bin/Stop_X.sh
add-apt-repository ppa:ubuntu-x-swat/x-updates
apt-get update
apt-get install -y nvidia-current

But on reboot, the nvidia-install.sh, redid the 260 install and then rebooted twice and then dumped me into the Av Wizard, where sound did work this time, nice :).

Well I am not using the latest nvidia driver, but ok, see below

Quote
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 430] (rev a1)
     ................................................
        Kernel driver in use: nvidia
        Kernel modules: nvidia-glx-260, nouveau, nvidiafb

Plan, play a movie make sure it working, then backup the system and then try upgrading alsa as alsamixer claims its v1.0.22. Then try upgrading the nvidia version, hopefully editing the nvidia-install.sh, removing the card ID from 260 group and putting it in current may help. will tell you the progress.

Thanks Crumble, that did the trick

Pages: 1 ... 8 9 [10] 11