LinuxMCE Forums

General => Installation issues => Topic started by: gumis on June 14, 2009, 09:48:36 pm

Title: MPlayer won't play HD files in 8.10 alpha 2.22?
Post by: gumis on June 14, 2009, 09:48:36 pm
Hi guys,

I finally managed to find some spare time and install 8.10alpha on one of my spare disks.
Until now, I was using 7.10 which was quite stable - only few little issues.

So far I've noticed that my LMCE won't play any HD content from HDD. I've tried HD DVD (I've copied it onto my HDD) and few .mkv files and every time I try any of them, I get:

- .mkv files (after forcing it to play via MPlayer by changing 'Type' option of this file to 'LinuxMCE HD-DVD'):

Code: [Select]
05      06/14/09 20:40:48.088           MPlayer_Player::Log I'm a child <0xb7263b90>
05      06/14/09 20:40:48.089           MPlayer_Player::Log Starting mplayer <0xb7263b90>
05      06/14/09 20:40:48.089           MPlayer_Player::Log execle() failed <0xb7263b90>
05      06/14/09 20:40:48.092           MPlayer_Player::Log I'm a parent <0xb7263b90>
05      06/14/09 20:40:48.092           MPlayer_Player::Log [EngineOutputReader] EngineOutputReader - started <0xb6261b90>
01      06/14/09 20:40:58.103           MPlayer engine didn't set up within 10 seconds, something is wrong <0xb7263b90>
Return code: 141
3       06/14/09 20:40:58       25 (spawning-device)    Device died... count=2/50 dev=25
Sun Jun 14 20:40:58 BST 2009 died
========== NEW LOG SECTION ==========
1       06/14/09 20:41:08       25 (spawning-device)    Starting... 3
1       06/14/09 20:41:08       25 (spawning-device)    Found ./MPlayer_Player
05      06/14/09 20:41:08.336           MPlayer_Player::CMD_Stop aborts because Player Engine is not initialized <0xb71f5b90>

- HD-DVD content (from hdd):
Code: [Select]
05      06/14/09 20:42:17.299           Socket::ReceiveData 0x82fd028 failed, bytes left 0 start: 10000 1: 0 1b: 0 2: 0 2b: 0 m_Socket: 6 Command_Impl1 Dev #25 <0xb71f5b90>
05      06/14/09 20:42:17.299           Socket::ReceiveString2 ReceiveData failed m_Socket: -1 Command_Impl1 Dev #25 <0xb71f5b90>
01      06/14/09 20:42:17.299           Receive string failed in HandleRequestSocket 18:ReceiveData failed Command_Impl1 Dev #25 <0xb71f5b90>
05      06/14/09 20:42:17.299           Dumping 1 locks <0xb71f5b90>
05      06/14/09 20:42:17.299           finished check for exceptions <0xb71f5b90>
05      06/14/09 20:42:17.299           OL: (0x82fd174) (>75) MessageQueue Command_Impl.cpp l:822 time: 1:00:00a (1245008537 s) thread: 3080678288 Rel: Y Got: Y <0xb71f5b90>
05      06/14/09 20:42:18.295           Dropping all sockets... <0xb79f76c0>
05      06/14/09 20:42:18.295           Done dropping sockets! <0xb79f76c0>
Return code: 2
2       06/14/09 20:42:18       25 (spawning-device)    Device requests restart... count=3/50 dev=25
Sun Jun 14 20:42:18 BST 2009 Restart
========== NEW LOG SECTION ==========
1       06/14/09 20:42:26       25 (spawning-device)    Starting... 3
1       06/14/09 20:42:26       25 (spawning-device)    Found ./MPlayer_Player
1       06/14/09 20:42:29 25 (spawning-device)    1203 Dev: 25; Already Running list: 15,17,26,27,16,18,20,34,21,29,22,24,25,
1       06/14/09 20:42:29 25 (spawning-device)    1203 Device 25 was marked as 'running'. Not starting
1       06/14/09 20:42:29 25 (spawning-device)    1203 Dev: 25; Exiting because not starting

Xine seams to work well, it's only MPlayer that gives me a headache... ;]

I would appreciate any help... Thanks.
Title: Re: MPlayer won't play HD files in 8.10 alpha 2.22?
Post by: tschak909 on June 15, 2009, 09:50:52 am
mplayer_player is only used for HD-DVD and BD playback. This will always be the case. Xine_Player is our main player, until someone makes another DCE interface to another media player.

I play mkv files  with the xine player just fine, what happens with you?

Title: Re: MPlayer won't play HD files in 8.10 alpha 2.22?
Post by: gumis on June 15, 2009, 07:35:37 pm
Hi Tom,

That's what I get when I change .mkv file type back to 'LinuxMCEVideo File' and try to open it in Xine:
Code: [Select]
05      06/15/09 18:30:55.874           Xine_Player::CMD_Play_Media() called for id 1001 filename: /home/public/data/videos/films/PlanetEarth/PlanetEarth.Caves.1080i.DivX.AC3.mkv () <0xb6ce0b90>
05      06/15/09 18:30:55.875           Xine_Player::CMD_Play_Media() stopping PSS <0xb6ce0b90>
05      06/15/09 18:30:55.875           Xine_Stream_Factory::GetStream streamID is 0 <0xb6ce0b90>
05      06/15/09 18:30:56.053           Created new stream with ID=1001 deint 0  100 0 <0xb6ce0b90>
05      06/15/09 18:30:56.053           Xine_Player::CMD_Play_Media() set stream 1001 as last rendering to screen. <0xb6ce0b90>
05      06/15/09 18:30:56.053           Xine_Player::CMD_Play_Media() called for id 1001 filename: /home/public/data/videos/films/PlanetEarth/PlanetEarth.Caves.1080i.DivX.AC3.mkv () with corresponding stream 0x8434800. <0xb6ce0b90>
05      06/15/09 18:30:56.053           Opening media without chapters/title position: 'file:///home/public/data/videos/films/PlanetEarth/PlanetEarth.Caves.1080i.DivX.AC3.mkv'  <0xb6ce0b90>
05      06/15/09 18:30:56.117           Xine_Stream::changePlaybackSpeed no running seekers found <0xb6ce0b90>
05      06/15/09 18:30:56.117           Xine engine set new zoom level to X:100, Y:100 <0xb6ce0b90>
05      06/15/09 18:30:56.127           Read media A/V information: []/[] => []/[] <0xb16f0b90>
05      06/15/09 18:30:56.127           Xine_Player::EVENT_Playback_Started(streamID=1001) <= AV info <0xb16f0b90>
05      06/15/09 18:30:56.128           Read media A/V information: []/[] => []/[] <0xb16f0b90>
05      06/15/09 18:30:56.128           Xine_Player::EVENT_Playback_Started(streamID=1001) <= AV info <0xb16f0b90>
05      06/15/09 18:30:56.834           Read media A/V information: [A/52 5.1]/[ISO MPEG-4 (DivX5, ffmpeg), 1920x1080] => [dolby digital 5]/[16:9] <0xb6ce0b90>
05      06/15/09 18:30:56.835           Xine_Player::EVENT_Playback_Started(streamID=1001) <0xb6ce0b90>
05      06/15/09 18:30:56.887           Xine_Stream::changePlaybackSpeed no running seekers found <0xb16f0b90>
05      06/15/09 18:30:56.888           Xine_Player::EVENT_Playback_Completed(streamID=1001) <0xb16f0b90>
05      06/15/09 18:30:57.034           [ID: 1001]  CHAPTER:0 POS:0 TITLE:0 SUBTITLE:-1 AUDIO:-1 TOTAL:0 (seek 0) t.c. ctr 0 freq 1, <0xb0cffb90>
05      06/15/09 18:30:57.035           DisplayOSDText() : Attempting to display 0x     0:00 <0xb0cffb90>
05      06/15/09 18:30:57.535           DisplayOSDText() : Attempting to display 0x     0:00 <0xb0cffb90>
05      06/15/09 18:30:57.835           Xine_Player::CMD_Play_Media() ended for filename: /home/public/data/videos/films/PlanetEarth/PlanetEarth.Caves.1080i.DivX.AC3.mkv with stream 0x8434800. <0xb6ce0b90>
05      06/15/09 18:30:57.836           Xine_Player::CMD_Stop_Media() with corresponding stream id 1001 0x8434800. <0xb6ce0b90>
05      06/15/09 18:30:57.836           Xine_Stream::changePlaybackSpeed no running seekers found <0xb6ce0b90>
05      06/15/09 18:30:57.837           Xine_Player::EVENT_Playback_Completed(streamID=1001) <0xb6ce0b90>
05      06/15/09 18:30:57.936           XineStreamEventListener called on non-initialized stream - aborting command <0xb16f0b90>
05      06/15/09 18:30:58.099           Closed stream AV with ID=1001 <0xb6ce0b90>
It gives me GREEN screen for about 1sec and then goes back to screen saver...

Any idea what could cause this?
Title: Re: MPlayer won't play HD files in 8.10 alpha 2.22?
Post by: Lexje on August 13, 2009, 11:46:21 pm
Hi guys,

Sorry to hijack like this, I seem to have exact the same behaviour (7.10) and would like to dig in a little.
Where can I find these log files such as you are posting above? Or do you start manually with extra command options?

Thanks for helping out!

Title: Re: MPlayer won't play HD files in 8.10 alpha 2.22?
Post by: colinjones on August 14, 2009, 12:48:08 am
You shouldn't have any issue starting playback of mkv files in 0710 or 0810 ... however, I note that some codecs/encodings in an mkv file have been known to cause crawling green artifacts on the left of the screen that sometimes create green cloud effects following motion to the right, but it doesn't stop playback. The log file doesn't really indicate any specific problem except that the playback ceases immediately after starting (which obviously isn't correct)

The only time I have seen this behaviour was not related to a file type or codec, it was after I installed the Marantz SR device to control my amp, then all video media immediately stops after starting with similar log entries (Hari had this behaviour too)... however, the log entries are so non-specific that the issue is probably quite different.
Title: Re: MPlayer won't play HD files in 8.10 alpha 2.22?
Post by: Lexje on August 14, 2009, 11:52:01 am

FYI, until recently I did not much look into videocontainers and codecs, just tried them with either VLC or PowerDVD. I dropped PowerDVD alltogether lately, as they seem to get more and more restricted with each new release, so I'm not expecting important evolution on the linux platform from their behalf either.

It was just yesterday that I found this ( wiki item.
In my case changing the extension from mkv to m2ts did the trick.
Allthough functioning was not fully normal (no FF, REW etc, no image when stopping/restarting)
I agree with Thom and you that it's absolutely not advisable to have mplayer play video in LMCE for known reasons.

My interest lies solely in being capable to retrieve information of LMCE in how it's handling and evt. why not video media. Hence my question: where do I find these logs, or, are you starting xine / mplayer with different command options?
This would also be usefull to evaluate network throughput in case of HD content I guess.

Thanks for helping out!

Title: Re: MPlayer won't play HD files in 8.10 alpha 2.22?
Post by: colinjones on August 14, 2009, 04:32:50 pm
the log files are in the same place as all other LMCE log files - /var/log/pluto

all media playback in LMCE is performed by a DCE device, not simply mplayer or xine.... and these "devices" have device log files, plus the DCERouter log file for the central hub and the mediaplugin logs (which are logged into the DCERouter log as well)

Xine the UI application is NOT used in LMCE. only the xinelibs are used, these are the xine programming libraries, that the Xine GUI player is based on.... LMCE has its own UI which simply uses the xine libraries to implement video playback.... so there are no command line options because there is no command line use of xine in the first place.... you would need to dig into the xine_wrapper code to see how it uses the xine libraries.... either way it is unlikely there is a specific don't_do_green_blurry_bits_flag :)

this is not specific to LMCE as I have found other comments elsewhere about xine doing the same thing, but nothing yet that explains what the bug is...