LinuxMCE Forums

General => Installation issues => Topic started by: NWNewell on April 24, 2009, 03:12:01 am

Title: New installation woes....
Post by: NWNewell on April 24, 2009, 03:12:01 am
Well, first of all... I'm new to the Linux game, so be gentle.

While researching some things for a potential future HTPC, I stumbled upon the LinuxMCE tutorial video.  The more I read, the more impressed I am with this light weight free software.  I recently upgraded my desktop and am trying to make the LinuxMCE work as a core on my old desktop.  It's a P4 2.0Ghz with a GA-8Ik1100 Motherboard.  Currently only 512MB of RAM and a 40GB HD (have a second 60GB drive that was going to use to store PVR, and will likely buy an additional 1TB+ drive for ripping my DVD's to as well as a little more RAM).

The first problem I'm encountering that after I do the DVD install and all seems to go well (tells me to eject disk and press "enter" to continue), when it reboots it will not boot.  It checks for a boot CD and then just hangs.  If I insert the DVD and boot from the DVD, then select "boot from first hard disk" during the initial menu options, it will then perform it's first boot properly.  But for some reason the booting from the HD needs to be initialized by the DVD.  ???

The second thing I'm having a problem with is when I get to the audio portion of the A/V Set-Up Wizard I can not hear any analog audio.  (Even when I try turning the Linux menu volume up to 100% and my speakers are turned all the way up).  I'm using the same speakers and the same audio out port that I used previously when this was an XP machine.  ???

Thoughts?  Suggestions?  Is it a Mobo compatibility issue??

Thanks for the assistance.

Title: Re: New installation wows....
Post by: pigdog on April 24, 2009, 03:29:29 am
Hi NWNewell,

I keep asking this question because some people are downloading the 710 version and some are downloading the 810 version.

What version are you on and is it 32 or 64 bit (if it is 710)?

Title: Re: New installation wows....
Post by: NWNewell on April 24, 2009, 03:33:49 am
Downloaded the 0710 version and burned to a single layer DVD per the link below.

Running the 32 bit version I believe (downloaded this torrent iso image from the instructions above: LinuxMCE-DVD-i386-rc2.iso )

Sorry, should have clarified that.

I did notice that in the Linux MCE Launch Manager on the KDE desktop, the Audio tab does not havfe an "audio driver" listed (but the Video table shows the "video driver" as "ati".  Not sure if that means anything or not.
Title: Re: New installation wows....
Post by: pigdog on April 24, 2009, 03:51:42 am

If you go into webadmin you can check the media director to see what your audio setting is.

If you are using the mobo AC97 audio out audio settings should say S.

This is the default analog setting you would have set in the AVWizard.

You can also search the threads for alsa or alsamixer.  You can run alsamixer from the command line in a terminal window.

Sometimes speakers are muted, you'll see the check box or a M. 

Sometimes you need to push the volume to 100%.

If you have a soundblaster, etc search for that in the threads.


p.s. Make sure to view all in alsamixer.
Title: Re: New installation wows....
Post by: pigdog on April 24, 2009, 04:08:19 am

To run alsamixer you'll have to be logged in as root.

Oh, I just reread your initial post.  If you are talking about the initial screen when you booted the disk for the first time you should have said install.

If you said install the first time you inserted the DVD and it does not boot from the hard drive then something is wrong.

Did you change your BIOS setting to boot from the hard drive as the first choice?

Did you do a md5sum on the iso before burning an image?

Just a couple of thoughts.

Title: Re: New installation wows....
Post by: NWNewell on April 24, 2009, 09:56:36 pm
I tried downloading a new DVD ISO image from a different source and re-burned the ISO image but still had the same problems.

I think it is a motherboard issue.  I tried installing the same empty HD in my new computer (AMD 9950 2.6GHz Quad Core with an ASUS M3A78-T Motherboard, 4GB RAM).  I installed LinuxMCE on the 40GB hardrive that I placed in my new PC. Both of my initial installation issues went away.  New install properly booted from the HD and sound was playing as it is suppose to be during the MCE A/V Wizard audio set-up.

The problem is I don't want my new PC to be a Core or a Core/Hybrid and I didn't want to have to shell out money for all new hardware at the moment.

Anyone know of any fixes to get the GA-8IK1100 Motherboard set-up working properly?  Or will it not be compatible with LinuxMCE??
Title: Re: New installation wows....
Post by: Pnuts on April 24, 2009, 10:31:56 pm

I didnt see a response on if you went into the alsa mixer yet. I had a similar problem on a diff PC and I was only able to get sound after I went into alsa mixer and un-muted everything and set everything to 100%.

You could also try installing Kubuntu 7.10 and seeing if you get sound in it prior to loading LMCE. This could be done on a live CD. This will atleast let you know it is loading drivers and your getting sound.
Title: Re: New installation wows....
Post by: colinjones on April 24, 2009, 11:21:20 pm
On the boot issue, it certainly sounds exactly like your HDD is not in your Boot order in BIOS. You need to go back in there and add it to the Boot sequence, and preferably move it to the top, above CD.

Typically, when BIOS boots, after it has done POST, it will then look at the boot sequence stored in CMOS battery backed memory. And attempt to boot from the devices in that order. If the particular HDD isn't in the sequence then it won't attempt to boot from it. Or if something else is first, and for some reason holds the boot sequence...

If it is getting to the HDD, the next step the BIOS does is go to the main boot sector of the disk and loads the code there and executes it. This is responsible for understanding the partitioning of the disk, finding which is the "active" partition, and loading the boot sector of that partion, then executing that code... which in turn actually loads the kernel boot strap code, and proceeds to boot that OS. So it is essential that the drive be correctly formatted with appropriate partitions and boot sectors. If you built using the DVD, it should have formatted and partitioned the drive correctly to do this. So it is most likely that your BIOS doesn't have the HDD in the boot sequence, at the top...

On sound, definitely check using alsamixer, etc, as suggested, and booting vanilla Kubuntu 0710 Live CD is a good test of sound compatibility. You may just need to install updated sound drivers. You should look up the sound chip and check on the (mobo or just sound chip) manufacturer's site for a Linux ALSA driver for that chip that is compatible with kernel version 2.6.22-14. Install that, then reboot, hold shift down during the Kubuntu loader screen to re-activate the AV Wizard. Configure the sound again, and check alsamixer again.
Title: Re: New installation wows....
Post by: NWNewell on April 25, 2009, 01:55:22 am
I didn't check the alsa mixer yet because if I can't get it to boot right, it makes it kind of moot (and it seemed to work on my new PC).  But I'll check that.

I'm pretty sure I have the boot sequence set right.  I've tried changing it so that all three boot priority levels are set to the HD (and I only had one HD installed with no partitions).  That didn't work.  After POST it just hangs.  It is the same thing that happens when I have the boot priority set to CD drive first except that before it would check the CD drive for a bootable disk and when one wasn't installed, it would hang instead of booting from the HD.  But with all the boot priorities set to HD, it simply doesn't even try to check the CD driver (as expected) and simply hangs after post.  I've tried various combination ranging from the HD being first, last, or all of the three motherboard boot priority rankings.

Thanks for the responses!  I'll definitely be trying your sound solution suggestions, but I don't think the boot problem is a simple boot priority order problem.  But I'll triple check and try some variations.

Thanks again!  The help is much appreciated!
Title: Re: New installation wows....
Post by: colinjones on April 25, 2009, 02:13:14 am
Is there anything in the BIOS that selects either the primary harddrive for booting, or the primary/active partition? If it is able to boot using the GRUB boot menu off the installation DVD then it sounds like the partitions and boot stuff are fine.... which tends to suggest that the BIOS does know how to boot from that boot sector for some reason... theoretically interpretation of the partition type should be the responsibility of the boot code in the boot sector (iirc)