LinuxMCE Forums

General => Installation issues => Topic started by: djieno on October 06, 2008, 11:51:58 am

Title: Modeline troubles - Can't display
Post by: djieno on October 06, 2008, 11:51:58 am
Dear reader,

I’m ‘desperately’ trying to get linux mce working on my Samsung LE37M87BDX. It’s a 37” lcd and capable of full HD (1920x1080) but for some reason Linux mce has troubles with it. If I select 1080P/720P from the linux mce wizard my television indicates that it isn’t capable of displaying these settings. I’m using the Asus M2N-VM DVI with integrated Nvidia Geforce 7 Series video on a VGA cable. I can only see something after selecting 480P from the linux mce wizard.

I’ve been testing with (same motherboard/lcd other harddisk) windows XP and it displays the full resolution without any problem (of course using the proper nivida driver). I’ve been reading into and experimenting with different mode lines in /usr/pluto/share/Resolutions.conf with no avail. The best results will not (even) display a divx movie. I’ve tried the modeline from powerstrip under XP and the manuals values. Drove me nuts ;)

PowerStrip timing parameters:

Generic timing details for 1920x1080:
HFP=64 HSW=32 HBP=64 kHz=67 VFP=3 VSW=5 VBP=23 Hz=60

VESA detailed timing:
PClk=138.54 H.Active=1920 H.Blank=160 H.Offset=48 HSW=32 V.Active=1080 V.Blank=31 V.Offset=3 VSW=5

Linux modeline parameters:
"1920x1080" 138.541 1920 1984 2016 2080 1080 1083 1088 1111 +hsync -vsync

Installing ubuntu Hardy Heron desktop (same motherboard/lcd other harddisk) and works flawlessly after selecting restricted ‘nvidia glx new’ driver and rebooting. I can display everything even 1080P content under Hardy.

I’ve tried selecting the restricted drivers from the kde desktop in linux mce. I couldn’t find the restricted driver menu under kmenu/system as stated on the linux mce forum. After installing this I showed that it had already selected the restricted nvidia driver. After ticking it on and of again it started to download and install the ‘nvidia glx new’ driver. It needed a reboot but everything went black afterwards. I’ve disabled the /usr/pluto/share/Resolutions.conf from being updated/changed the /etc/X11/xorg.conf and copied the xorg.conf from the working hardy but still nothing worked. It keeps returning to the second stage from DCE router to linux mce stage. It doesn’t actually load the linux mce interface nor the linux mce settings menu.

Does anybody have similiar problems with this hardware/settings?

There are probably many things I can do. Is there somebody who can point me in the right direction?

Greetings Gino
Title: Re: Modeline troubles - Can't display
Post by: djieno on October 06, 2008, 01:42:32 pm
Hi rodercot!

Thanks for your reply! I had the 'nvidia glx new' installed by accessing/retick the restricted drivers. I will try the wiki/nvidia procedure as described later on. What kind of logs would you be interested in? Wild guess would be Xorg.log  ::)

The strange thing is that having the same computer on the same lcd monitor/tv (actually only changed the harddrive) DOES work perfectly under Ubuntu Hardy Heron. I can see mpeg4/720p without any problems. So I'm certain that this specific hardware can do it under Linux by using VGA.

I wonder anyone else has this problem/solved. I couldn't find a solution without mentioning hdmi.

Greetings Gino
Title: Re: Modeline troubles - Can't display
Post by: pigdog on October 06, 2008, 03:09:30 pm

When I setup my LCD as 1080p/DVI via wizard (on a diskless MD/Nvidia card running LMCE default Nvidia driver) the screen on initial boot would run as 1080p until LMCE loaded and the screen would then default to 640.  All I did to run in native resolution (1080p on my LCD) was edit the xorg,conf EDID settings (two places) to = true.  After reboot everything ran natively as 1080p.

Hope this helps.
Title: Re: Modeline troubles - Can't display
Post by: Zaerc on October 06, 2008, 06:47:34 pm
Another thing to try is to transplant the modelines from the working hardy xorg.conf to the lmce xorg.conf.  See also for more info on these matters.
Title: Re: Modeline troubles - Can't display
Post by: colinjones on October 07, 2008, 02:42:06 am
Thanks Dave! I was just skimming, now I have to go back and read the whole thread properly :)

Seriously though, Gino - happy to look at the files and logs with you. Post (in a code block) your /etc/X11/xorg.conf and /var/log/Xorg.0.log files.

And as Dave says, update your driver to the latest version first using the guide in the wiki, I just did this yesterday to 173.14.12 which is the latest version and the guide is acurate and very easy. Don't use the feature to modify the xorg.conf file automatically.

Also, you should put the Option "useedid" "true" in your xorg.conf file (I put it in both the Device and Screen section), then reboot and allow it to start/fail and write the log out. You can then switch to one of the console screens (CTRL-ALT-F2), log in and review the log file, or SSH in and cut and paste the results into this thread.

The UseEDID option just makes sure that X interrogates your screen for its capabilities during mode validation, and sometimes logs useful info that can help use troubleshoot the problem. We can also crank up the verbosity of the logging later if we need to.
Title: Re: Modeline troubles - Can't display
Post by: colinjones on October 07, 2008, 02:53:51 am
OK, just started re-reading the thread properly... should have done that first! Are you actually trying to get 50Hz or 60? Given that you are in NL I assumed 50Hz but some of the data you listed was for 60Hz...

Either way, Samsung definitely has some issues trying to get resolutions at particular refresh rates, in specific circumstances and is tilted towards 60Hz. Just as a starting point, try:

1) Menu -> Picture -> scroll through to Size, and in there choose Just Scan instead of 16:9  (hoping your menus are the same as mine!)

I found that only Just Scan would allow me to generate 1080p50Hz without overscanning, but it could help with the timing too...


2) Add this modeline in the Monitor section of your xorg.conf file

Modeline "1920x1080@50" 148.50 1920 2448 2492 2640 1080 1084 1089 1125

Then in the Screen section, subsection Display make it:

Modes "1920x1080@50"
Virtual 1920 1080

And reboot again, and we can look at that Xorg.0.log file as well..