LinuxMCE Forums

Archive => Archive => Pluto Main General Issues => Topic started by: archived on August 03, 2005, 10:39:21 am

Title: media issues
Post by: archived on August 03, 2005, 10:39:21 am
Here is a message from a user with inline comments:

Hi, I registered, downloaded and have been trying Pluto for a couple of days now. For the most part everything is up and running, but I am having a lot of trouble with features of the system. I am not sure if I am in between builds or somthing else is going on. I have linux knowledge and built a clean system from the quickstart CD. I am running a hybrid/core on installation #1410. The orbiter loads and I am able to get a remote orbiter to run, but here are some of the problems I am encountering:

1. Cannot FTP or telnet to the box so I can upload media files. I even opened ports 21 and 23 on the firewall in the admin tool, rebooted several times, but I still cannot connect to the box to add media. I even watched the startup sequence say that it opened up port 21 and 23 on the firewall. I cannot ping, telnet or ftp to the box, but I can run the admin website. How can I copy media to the core?

>> Please refer to the quick start guide.  There are links to it throughout the website.  It's the bold link on, and it's also there on the open source site,, and also on the download page, and also on when you click support.  If you have a suggestion or recommendation how we can make it more prominent, please let me know.  You're not the first one who didn't find it, but we did try to put it everywhere, so I'm not sure how it's getting overlooked.  Anyway in the quick start guide:
There's a section: "Upload your media" that explains everything.  Also, the programmer's guide in the 'what can I do with Pluto', topic 'flagging your media' has a technical explanation:
We use samba shares since we figure that way users with Linux, Windows or Mac can attach the network drive.  Also that way it works with tools like mp3 software that synchronizes a directory.

2. I cannot get the core out of the orbiter app. Eveytime I stop the orbiter or pluto, they just start up again. None of the computing options work (web, kde, etc), so I am stuck in the orbiter and can never get to the linux side or kde desktop. Can i stop the orbiter on the core from autoloading? Why does the KDE not load?

Refer to the document "I'm already a Linux user":
It has information for people like yourself who also use it.  As it mentions all the devices are running in screen sessions.  man screen to get help on screen.  They are in a constant restart loop because that way if a device has a problem and crashes, it won't die permanently--it just restarts.  Since users can add all sorts of custom modules you don't want a situation where somebody wrote a security panel interface, for example, it dies the first day of their vacation due to some glitch, and then the security system is permanently "dead".  This way no matter what all the devices are always restarted.  So if you want to kill the device for good, kill the screen session in which the respawn loop is running.  Then it will go away until you reboot or restart it manually.

3. Cannot play DVDs from the local orbiter on the core. When I insert a DVD, the screen goes blank, then pauses and returns to the orbiter.

Is it a css encrypted DVD?  Did you see this site?  On the Quick Start Guide there's a notice with a big IMPORTANT above it explaining this.

I would really like to use the product, but I am having trouble bringing up the base system. I can't send you log files because I can't get into the system. I believe it has the latest code because when I reboot, it sometimes pull an update.

My core is running on an AMD 1700 1.1Ghz 1GB Ram 20GB HD. It has 2 optical drives. A DVD and a CD burner.

Please let me know if there is a document to help with the troubleshooting these items or if these are known issues.

Thank you in advance,
Title: media issues
Post by: archived on August 04, 2005, 04:12:47 am
Aaron, thank you for the info. I also sent you an email directly.

I am still having trouble with issue #1. When I perform a \\192.168.0.x, it tells me that the server is inaccessbile. I tried to also browse it using network neighborhood and I see a Pluto workgroup in addition to mine, but when I click on the pluto workgroup, it still tells me that it is inaccessible. Any thoughts?

For #2, I have read the documentation. 2 small errors in the documentation. In the Quick Start guide it references the admin url as site/pluto_admin. It is actually site/pluto-admin. Also the linux document references Advanced -> Boot Scripts. In the admin tool it is called Advanced -> Boot Sequence.

#3 was straight forward. I downloaded the additional packages and will be testing it soon.

Please let me know any thoughts on #1. If it helps here are my firewall settings from the inital install.

tcp 22 to 0 0  core_input  Delete
tcp 80 to 0 0  core_input  Delete
tcp 3450 to 0 0  core_input  Delete
tcp 3306 to 0 0  core_input  Delete
udp 4569 to 0 0  core_input  Delete
udp 5060 to 0 0  core_input  Delete
Title: media issues
Post by: archived on August 04, 2005, 12:31:51 pm
I'll fix the docs re #2, which BTW is wiki style if that wasn't apparent--anybody can add/edit documents on their *local* Core (not our public site), and then do a sqlCVS checkin to commit their changes for the next release.

Regarding #1, in a "standard" setup it's easy--from any network in the house do start, run \\  However everybody's setup varies so much it may vary.  Here's what happens on my setup.  I have a Core with dual NIC cards, which is our normal recommended configuration since the Core needs to be a DHCP server to provide the network boot and plug and play services, yet most people already have a dhcp server in their dsl/cable modem.

So, just a Wi-fi access point (which has the same situation usually), there's one network port for the Internet (we call that the 'external' port), and another for the LAN within the home (we call the 'internal' port).  The system will attempt to auto-configure, but in a normal situation the external port GETS an address from DHCP, and the internal serves addresses in the 192.168.80.x range.

Incoming connections are enabled by default on the internal network.  I can plug a windows pc into the internal network get a 192.168.80.x address and go to \\ (the default for the core) and login with the same username and p/w I use for pluto admin--they stay in sync and you must drop any . (period) you put in your username since it's not valid for samba.

If I plug my windows pc into the external network, then I get a dhcp address from our internet connection, in my case in the 10.x range.  In this case I need to know the ip of the Core, which is also getting an address from dhcp.  If I try to go to it with \\ it is by default blocked, since we don't by default allow incoming connections from the outside.  But, if I ssh/login and type: iptables -P INPUT ACCEPT
then I can connect the same.

In your case, do an: ifconfig on the server.  See if you have dual nic's.  If you have only 1, it is probably bound both to and also some other address.  try doing the: iptables -P INPUT ACCEPT  also.  What address does your windows pc have?  Also a 192.168.80.x?  Is the Core giving it an IP?  If so, you should never have had any problems.

Network neighborhood under Windows always works like crap.  But it's not a linux/samba thing.  We have lots of windows pc's in our office and sometimes you can see them in network neighborhood, sometimes you can't.  I don't know why, it's a windows thing, but that's why it's normally better to connect by typing in the ip directly and avoiding the windows naming service.
Title: media issues
Post by: archived on August 07, 2005, 01:48:37 am
Aaron, I tried a bunch of different things, but the iptables -P INPUT ACCEPT seemed to do the trick.


Title: media issues
Post by: archived on August 07, 2005, 10:52:06 am
That setting will be lost at each reboot.  I *think* the solution is to open some firewall setting.  But I don't know what it is.  I'll ask around and post a follow-up.
Title: media issues
Post by: archived on August 08, 2005, 12:24:34 pm
When .28 is released it will include a new quick start guide that is more streamlined and not so many big blocks of text.