LinuxMCE Forums

General => Installation issues => Topic started by: rsvp on October 29, 2016, 03:27:49 am

Title: Intel Nuc
Post by: rsvp on October 29, 2016, 03:27:49 am
This software looks like what I been looking for.  Problem is the hardware I have to spare at moment is an Intel Nuc 5i3.
The threads I found pertaining to Nuc are from 2014.  I have tried to install various methods and fail. I think it boils down to intel nuc ethernet adapter if I install kubuntu first.  And If i do the all in one option i get a black screen.  Newer version of Kubuntu have no problems but the earlier versions don't recognize this hardware. But MCE is built on those.  I have some experience with free bsd with freenas and pfsense.  But trying to update this driver is a new problem for me, as are these linux distros, and my skills aparently are not tranferable to this problem.

So my questions are:
Is there a better recipe out there on how to get this NUC serviceable that I can follow? Man I hope so.
Or am I looking at having to get on pcpartpicker to complete a different build that will work.  Any advice or pointers I would really appreciate.

Title: Re: Intel Nuc
Post by: Marie.O on October 29, 2016, 06:39:24 pm
You failed to tell us, which version of LinuxMCE you tried to install.
Title: Re: Intel Nuc
Post by: rsvp on October 29, 2016, 07:38:54 pm
I tried all of them.
started with 1004 final.  Reboots to cursor and black screen.  Read that it was probably driver issues with Intel graphics.
Then I went to the under development options because i figure they would likely work with newer hardware.. Same thing. So I figured i needed to try to get Kubuntu on there then try to put package on..  made a few mistakes and learned that the new versions of Kubuntu look great and work fine with my Nuc.  But the versions required to get the package for Linux had issues.  The intel drivers were there they just didn't work.

All in all I tried just about any combination available to me, and why I came to the board.. There wasn't much info regarding the Nuc and it all mirrored my issue but couldn't follow the solution.

Thanks for replying, I appreciate that.   cheers 
Title: Re: Intel Nuc
Post by: Marie.O on October 29, 2016, 09:05:19 pm
Do a kubuntu 1404 install first. This will verify that your hardware is working. After that, do the netinstall option. And let us know the outcome.

And *always* remember rule #1 ;)
Title: Re: Intel Nuc
Post by: rsvp on October 29, 2016, 09:36:16 pm
Yes that was the first of 3 different versions I tried.  I will try again.  If I recall correctly when it promps to reboot it goes to black screen.  Putting it on USB again, and will see if it works... Will respond when I am done.

I have to take that by these responses that there has been success with a NUC, therefore will continue.. Great little devices to hide behind monitors/tv.
Title: Re: Intel Nuc
Post by: rsvp on October 29, 2016, 09:46:28 pm
black screen after load screen , was able to read prior to that "request for firmware failed".  Just don't think this device is going to work with this software. Great little nuc has cec built in and works great with kodi. maybe thats it. or have to roll back the firmware. either way. think i am done trying to get this device to work. back to repeating everhthing i allready did. and I have no confirmation that nuc even work with this.  I have read nothing stating anything other than this problem..IF it dosnt work with nuc, i see no use for it.
Title: Re: Intel Nuc
Post by: Marie.O on October 29, 2016, 10:48:53 pm
So you get the black screen with the initial kubuntu install, or after starting the LinuxMCE install?
Title: Re: Intel Nuc
Post by: rsvp on October 29, 2016, 10:59:53 pm
I cannot install that version of Kubuntu.  I have never gotten to the point of installing LinuxMCE... New version of Kubuntu is fine. Just not this one. or the other one recommended for the other "alpha" versions.  In that version I can install it but it doesnt recognize the nic.

Can you tell me if anyone has done this?  IF not, I need to reassess.  I had hoped to get this to work , then build a core. 
Title: Re: Intel Nuc
Post by: Marie.O on October 29, 2016, 11:45:08 pm
I know that Tschak used NUCs in general, I do not know which one in specific.

Due to last minute changes of Ubuntu to the way MySQL works/which MySQL version is being used within 1604, we were unable to switch to 1604. We, mainly phenigma, is working to clear things out, which isn't a small issue, as sqlCVS, our main way of storing database information centrally, uses MySQL in a way that isn't really compatible with the new way of doing things. That's why we haven't published a working set of 1604 binaries so far.

Sorry for not being able to help you more, but maybe searching for the ubuntu 1404 and your NUCs specifics will provide a solution to get Ubuntu running on your hardware. Once that has been accomplished, LinuxMCE should install just fine.
Title: Re: Intel Nuc
Post by: rsvp on October 30, 2016, 02:30:41 am
The wiki internet installation for 1204 goes smooth and recognized the wifi in the nuc.  After entering the instructions for installing LinuxMCE in terminal it reboots says its installed. Reboots again and a blue screen shows up  AVwizard failed to setup x. after that the machine is done and is unusable.

Title: Re: Intel Nuc
Post by: Marie.O on October 30, 2016, 09:45:31 am
Interesting. So Ubuntu 1404 doesn't install, while Ubuntu 1204 does install, but the LinuxMCE install fails. Does that sum it up?
Title: Re: Intel Nuc
Post by: phenigma on October 30, 2016, 04:07:49 pm
Failed to setup X means there is a video driver mismatch.

pastebin the contents of /etc/X11/xorg.conf, /etc/pluto/xine.conf && /etc/asound.conf please.

Title: Re: Intel Nuc
Post by: rsvp on October 31, 2016, 05:22:05 am
Thanks for your help.

I have some choices here...

In its current state i can reboot and I dcerouter login?  I read entering "ubuntu" here can get past this it didn't.  I cant get past this and i cant shh in because there is no lease on ip address.

Or am i to reinstall kubuntu and then past those files you mention?  I assume start from scratch again install Kubuntu and not to install linuxmce.

Title: Re: Intel Nuc
Post by: phenigma on October 31, 2016, 03:53:08 pm
You should be able to log-in with the user you created when you first installed kubuntu.  The files in question are created by lmce so this needs to be done after installation. 

Sent from my Nexus 5 using Tapatalk

Title: Re: Intel Nuc
Post by: rsvp on October 31, 2016, 10:22:34 pm

I am building a xeon e3/supermicro box thought be good for this will throw in a crappy vid card and see if it installs when rest of bits arrive.  Was hoping the nuc be easy install to test compared to current nuc/rp3 kodi with freenas / ubuntu running similar servers as offered in linuxmce. 

The nuc is not reachable, cant ping it.  ifconfig reveals a host of problems.  Thank you for your help, but I can see this is going to be endless. And I am not going to continue on rule 1 waste your time and mine.

If this is this difficult on a nuc and has no rasp pi support.  This isnt for me.

Title: Re: Intel Nuc
Post by: Marie.O on October 31, 2016, 11:18:22 pm
People have the raspberry pi as working media directors. Core is something that is not really suggested, due to i/o speed issues. If you want to run your core on an ARM processor, you can do using an odroid xu4.
Title: Intel Nuc
Post by: JasonFus on November 12, 2016, 07:06:50 am
Hello ahenning,

I would like to use intel nuc with ESXI. There is with one nic for both management traffic and production VMs traffic. Would your setup with LAN/WAN also apply to my scenario? Or is there something else which needs to be configured?

According some references there needs to be VMkernel port also added together virtual port group on virtual switch. However both scenarios are not working for me. I am able to connect to ESXi on management IP. But if I try to connect on specific VMs IP which is in same segment this is not working. I can also not ping between VM IP X.X.X.10 and VMkernel port X.X.X.11 which are in same VLAN on virtual switch.

Thanks in advance for your replay.