LinuxMCE Forums

General => Installation issues => Topic started by: bri_jac on June 20, 2012, 09:20:21 am

Title: 10.04, my WGR614v6 AP wont connect
Post by: bri_jac on June 20, 2012, 09:20:21 am

I have installed 10.04 in a Levono T61, using the laptops internal ethernet RJ45 plug connect to my ADSL router, using an USB RJ45 ethernet to my internal network and have tried both to connect this into my Netgear WGR614v6 wireless access point, both using the WAN and the LAN rj45 plug. I have disabled the WGR614v6 DHCP server, and set a static LAN ip adress - Think this should be allright, but the WGR614v6 just wont connect to my LinuxMCE at all, I can se my SSID on my WGR614v6 (Have tried both with wpa and with a no security) but neither my other laptop nor my phone can connect via the wifi
Can somone point out what I should search for/do to make my AP connect to my LinuxMCE?
Title: Re: 10.04, my WGR614v6 AP wont connect
Post by: sambuca on June 20, 2012, 09:26:12 am
If you set up the AP to use a static IP, I guess you need to configure a default gateway too. Alternatively, you can set up the AP to receive a DHCP address from LMCE.

Also check the MAC addresses of your cards (it is often printed on the back of the device or laptop) and compare that to what the web admin says, so you are sure that the correct one is used as external by LMCE.

Title: Re: 10.04, my WGR614v6 AP wont connect
Post by: bri_jac on June 20, 2012, 12:45:00 pm
Hi thanks for quick reply,
I think connections are all right. My ADSL plugs into "External network card eth0". My "Internal network card eth1" plugs into my Access Point (MAC addr for eth1 is checked).

To bypass my AP I instead connected the eth1 from LinuxMCE stright into a laptop (client), so my connection is now like this: ADSL -> LinuxMCE eth0  and  LinuxMCE eth1 -> Client laptop eth0 (right laptop on picture), LinuxMCE laptop is on the left on the picture.

I would assume I should have a DHCP lease, to be shown in LinuxMCE, but nothing shows up and my client laptop does NOT get an IP address ?!?, look at my pics - I still don't get it?
Title: Re: 10.04, my WGR614v6 AP wont connect
Post by: JaseP on June 20, 2012, 05:18:24 pm
The first things to check are the simplest. And forgive me if I,ve made incorrect assumptions on how your setup is configured... Try switching which Ethernet device accesses the modem, and which accesses the internal network. I would assume the laptop's built in Ethernet port should be a better choice for the internal network (LinuxMCE to the MD's etc.), the USB Ethernet adapter better for external internet (USB may be a bottleneck for internal communication; video streaming, etc., but less of a barrier for internet, the bottleneck being DSL). I would also assume that the built in port would be ID'd as eth0, and the adapter as eth1 (but with udev,... who knows)

Also, I'm unclear which port you used on the wireless AP to connect to the LinuxMCE core. You should probably be using one of the (4, I'm assuming) local network ports, not the upstream port used for internet (That is the port most routers use when doing DHCP server duty). Turn off the AP's DHCP server, but allow it to USE the DHCP to connect (if that's confusing, sorry)... Also,... Just to be sure that the core is working the way you think, confirm that your core has DHCP server active, before connecting the router (use the Advanced menu option from the main menu). It is possible you set it up in the Web admin panel, but some how didn't commit those changes (in other words, restarting all the services).

Title: Re: 10.04, my WGR614v6 AP wont connect
Post by: seth on June 20, 2012, 06:01:51 pm
I am not sure how this device is connected, but I can say with a Linksys WRT54G, I have disabled the dhcp server on the router. Connected port 1 of the integrated router switch to a port on my "Internal" 16 port gigabit switch. Any device accessing the wireless ESSID ( echo1 ) is automatically assigned an IP address from the core.

I required no further configuration. I access the internet through the core, via the "Internal" network on any wireless device connected to the WRT54G.

I use it for android tablets and phones, my laptop and netbook, the wife's laptop, as well as my Wii.

Hope that helps.

Best Regards,

Title: Re: 10.04, my WGR614v6 AP wont connect
Post by: JaseP on June 21, 2012, 12:06:30 am
My setup is similar to Seth's excepting I have a second Linksys router (DHCP server turned off also) connected to the first, for an extra Wireless AP in a hard to reach area of the home.
Title: Re: 10.04, my WGR614v6 AP wont connect
Post by: bri_jac on June 21, 2012, 12:23:31 pm
Thanks guys for your replies - I will later today try to switch between my ethernet cards, so I use build in Ethernet card for internal, and check how it's behaving. And glad for the responses that the AP are working in your setup's. I tried both the WAN and the LAN rj45 ethernet plug on my AP. But I will for now continue to use my client laptop connected via wire, so I avoid use wrong rj45 plug and also the wireless connection for now.
Title: Re: 10.04, my WGR614v6 AP wont connect
Post by: l3mce on June 21, 2012, 04:38:12 pm
Might need a crossover cable for that setup just looking at the picture. If neither of those nics does autoswitching, it will never pick up an ip lease.
Title: Re: 10.04, troubles using Level One USB-0401
Post by: bri_jac on June 21, 2012, 05:46:54 pm
Oki I got it now :-) well almost... It's my Level one USB-0401 usb ethernet adapter that isn't working in 10.04. I did try it yesterday in my client laptop (Kubuntu 12.04) and it was working perfect, so I didn't think that it might not fully work in 10.04, because it seemed to load correct and read the mac address from it..

I tried to swap NIC interfaces, and as soon my laptop used the build-in Ethernet rj45 plug and I connected my client laptop, I could see ig got an IP from LinuxMCE :-)

So thanks for your support and help.

Now I will check if I can get the Level One USB-0401 to be working in 10.04, I have already digged out some help ;-) (

And have downloaded the new driver from here: (

I keep you updated...
Title: Re: 10.04, my WGR614v6 is online and fully functionally
Post by: bri_jac on June 21, 2012, 06:27:04 pm
Yes now everything is working according to plan  ;D

So I did as the link I previously posted..
Downloaded new driver from Asix.

modprobe -r asix
untar the archive
sudo make install
modprobe asix

plug in the device.  and then I just rebooted to be sure it's all ok.

Now I have my setup like this:
Laptop internal Ethernet plug connected to my ADSL.
Laptop USB-0401 Level One connected to my WGR614v6 router in LAN port and disabled DHCP in AP, and set LAN to a static IP (As you guys have described)

And now my client laptop can connect via wifi, and also my phone (Nokia N9) is connected via wifi and they both get DHCP IP from my LinuxMCE.

I wanted my Level One to be serving my internal network, due to it's a gigabit ethernet, so it wont be the bottleneck ( I will keep an eye if it instead will use all USB bandwith in the future, and then swap those NIC interfaces).

Thank you all for your positive and helpful comments :-)