LinuxMCE Forums

General => Users => Topic started by: am on January 16, 2011, 04:31:25 am

Title: TMD400 zaptel.conf and Silent IVR issues
Post by: am on January 16, 2011, 04:31:25 am
I have a TMD400 with 4 red modules, I installed the card before running the install DVD,(thought I would get lucky and not have to bash my head on the keyboard) my issue seems to have migrated from the installation section to the users section.
After I could not find the zaptel.conf file and apt-get install zaptel failed, I made an empty zaptel.conf file and then ran apt-get install zaptel...fxload also was installed.
I ran genzaptelconf -svdM
which rebuilt a zaptel.conf and I can now recieve inbound calls, I can not seem to configure my outbound routes and I did make 4 recordings for the IVR using my Polycom, but when I do 7777 from a phone or even call in on that zap trunk I hear nothing, I can press an ext and it will route correctly to the proper ext(s)
I see my wav files in the GUI and in /var/lib/asterisk/sounds/custom
I tried in General settings to allow anon sip (no luck) I made sure to allow any incomming did's (no good)
I did clean up my log files it complained of no manager_custom.conf and manager_ sumpthin file so they were made too...
I need some help getting my outbound zap trunks configured, and find out why the IVR has wav files but does not play that file
I expect I did something wrong?
Help me if you can..thanks
Title: Re: TMD400 zaptel.conf and Silent IVR issuesUPDATED
Post by: am on January 17, 2011, 01:44:27 pm
I have both inbound and outbound working ZAP trunks and routes.
My issue is now the IVR, as stated, I can make save and see wav files in my /var/lib/asterisk/sounds/custom I can download and play the files. I generated an IVR using builtin gsm files, they work because they are at /var/lib/asterisk/sounds/pluto
So if I convert a wav recording to sln and move it into ..../pluto my IVR works.

I see my symbolic link is not like /pluto symbolic link at
/usr/share/asterisk/sounds/ (pluto or custom) I think I can fix that
But why does my GUI save my announcment system recording wav files from an extension
as user:group  www-data?   It should be asterisk:asterisk???
Where did I screw up?
Hope this can also help someone someday