Author Topic: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer  (Read 3916 times)

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #15 on: July 16, 2010, 11:24:09 am »
Any updates to this topic?

Looks like the rest LinuxMCE users don't have such problems ;)
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #16 on: July 16, 2010, 11:36:45 pm »
OK, I'm not entirely sure this has anything to do with the problem as I see it probably has more to do with vdpau than xine but here is a conversation I had that may help a bit...

I asked: whats the recommend way to get mkv and other h264 codecs to work?

[Fri Jul 9 2010] [21:00:48] <TSCHAKeee>
first, a correction
what you're experiencing has nothing to do with h.264
we supply h.264 codecs already, as part of ffmpeg
and an appropriate GPU can decode them on-card via VDPAU
with that said, what you're experiencing
is the fact that you're downloading pirated movies off bittorrent
(don't deny it)
which are using a newer MKV encapsulation
MKV is a container format
we do have an updated xine, which niz23 has backported the demuxer from the upcoming xine release
however, we do not currently supply them as part of the build
because they break VDR
at least until we can rebuild vdr-sxfe to properly handle the new xine libs
IF you want the new xine, you will have to forcefully install the debs
they are located here: http://tschak.homelinux.com/deb/
install them all at the same time, with dpkg
keep in mind however, that you are on your own
we can't provide any support for these packages, as we are still working things out with it relating to what I mentioned above.

if you do not know how to install packages by hand with dpkg
much less how to install a batch of them at the same time
either (a) google it or (b) forget it
the mplayer player will be removed.
we will remove it from the build soon.


This got video and sound to work correctly.... kinda... I'm working on it; but it does seem to work
« Last Edit: July 17, 2010, 03:26:26 am by joerod »

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #17 on: July 17, 2010, 07:44:00 pm »
joerod,

Your problem is related to xine. Not vdpau as demux of audio/video is done i software and not hw.
The demuxed video data is passed to gpu through vdpau and hence offloaded from cpu.

As TSCHAK pointed out we have a version of Xine that is unable to demux newer matroska containers in current release because we are unable to get vdr to run with the my backported version. I have started to look at how to port vdpau to xine 1.1.18.1. It´s a huge job that need to be done manually.
If you do not use vdr your problem can be solved either by installing the updated xine 1.1.16.3 with mkv backports as suggested or by building your own xinelib >1.1.17.
Unfortunately any version newer of xine than 1.1.16.3 do not have vdpau because the Xine devel team decided to focus on upcoming version 1.2 instead.
Before you ask I can say that v1.2 is not a possible road due to so much dependencies on newer libraries and also because 1.2 is not abi compatible with 1.1.x releases.

/niz23

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #18 on: July 19, 2010, 08:49:15 am »
Quote
As TSCHAK pointed out we have a version of Xine that is unable to demux newer matroska containers in current release
I understand why the newest versions of MKV files are not played. But what about the old ones? I cannot play files which were played fine under 0710 (with artefacts of course but at least with sound and picture). And mplayer doesn't work at all under 0810. Why do not use it the same way as it was in 0710 till xine will be fixed?
« Last Edit: July 19, 2010, 08:53:41 am by nite_man »
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

willow3

  • Veteran
  • ***
  • Posts: 55
    • View Profile
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #19 on: October 27, 2010, 10:34:22 pm »
I can not playback m2ts files from my panasonic AVCHD camcorder under MCE 810. The problem seems similar to yours nite_man,  when I read this thread. Did you have any progress? (I did not try the backported xine since I do not want to break VDR) or shall I forget about this?

Regards

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #20 on: October 27, 2010, 11:07:09 pm »
from what I understand all these problems were fixed; xine was updated/patched and using vdpau with supported nvidia cards ought to play all your mkv contained videos.  What I have noticed is that a few of my recently acquired m2ts files play slow and the video looses sync with the sound.

but all my hd mkv videos work great.