Author Topic: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer  (Read 4275 times)

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Hi,

Does somebody use successful VDPAU hardware acceleration under 0810? I set it in the admin page of media director. But when I play MKV file no video or audio are available. Here is a peach of Xine log:
Code: [Select]
05      04/21/10 21:40:42.313           Xine_Player::CMD_Play_Media() called for id 1003 filename: /home/public/data/videos/Windows Share-Volume_1 [39]/Heat.1995.BD.Rip.720p.h264.Rus.Eng.mkv () with corresponding stream 0x8be7058. <0xb6db3b90>                                                                                                                            
05      04/21/10 21:40:42.344           Opening media without chapters/title position: 'file:///home/public/data/videos/Windows Share-Volume_1 [39]/Heat.1995.BD.Rip.720p.h264.Rus.Eng.mkv'  <0xb6db3b90>                                                                                                                                                                      
05      04/21/10 21:40:42.587           Xine_Stream::changePlaybackSpeed no running seekers found <0xb6db3b90>
05      04/21/10 21:40:42.587           Xine engine set new zoom level to X:100, Y:100 <0xb6db3b90>
05      04/21/10 21:40:42.595           Read media A/V information: []/[] => []/[] <0xb1046b90>
05      04/21/10 21:40:42.595           Xine_Player::EVENT_Playback_Started(streamID=1003) <= AV info <0xb1046b90>
05      04/21/10 21:40:42.597           Read media A/V information: []/[] => []/[] <0xb1046b90>
05      04/21/10 21:40:42.597           Xine_Player::EVENT_Playback_Started(streamID=1003) <= AV info <0xb1046b90>
05      04/21/10 21:40:42.598           Read media A/V information: []/[] => []/[] <0xb1046b90>
05      04/21/10 21:40:42.598           Xine_Player::EVENT_Playback_Started(streamID=1003) <= AV info <0xb1046b90>
05      04/21/10 21:40:52.588           [ID: 1003]  CHAPTER:0 POS:0 TITLE:0 SUBTITLE:-1 AUDIO:-1 TOTAL:0 (seek 0) t.c. ctr 0 freq 1, <0xb02ffb90>
05      04/21/10 21:40:52.588           Read media A/V information: []/[] => []/[] <0xb6db3b90>
05      04/21/10 21:40:52.588           Xine_Player::EVENT_Playback_Started(streamID=1003) <0xb6db3b90>

Also there is a problem with playback m2ts files using mplayer:
Code: [Select]
5      04/21/10 21:36:47.309           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[h264_vdpau @ 0x88ae6e0]B picture before any references, skipping| <0xb60dbb90>
05      04/21/10 21:36:47.309           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[h264_vdpau @ 0x88ae6e0]decode_slice_header error| <0xb60dbb90>
05      04/21/10 21:36:47.309           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[h264_vdpau @ 0x88ae6e0]B picture before any references, skipping| <0xb60dbb90>
05      04/21/10 21:36:47.309           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[h264_vdpau @ 0x88ae6e0]decode_slice_header error| <0xb60dbb90>
05      04/21/10 21:36:47.309           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[h264_vdpau @ 0x88ae6e0]no frame!| <0xb60dbb90>
05      04/21/10 21:36:47.309           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |Error while decoding frame!| <0xb60dbb90>
05      04/21/10 21:36:47.309           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[VD_FFMPEG] Trying pixfmt=0.| <0xb60dbb90>
05      04/21/10 21:36:47.309           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |Could not find matching colorspace - retrying with -vf scale...| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |Opening video filter: [scale]| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |The selected video_out device is incompatible with this codec.| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |Try appending the scale filter to your filter list,| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |e.g. -vf spp,scale instead of -vf spp.| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[h264_vdpau @ 0x88ae6e0]decoding to PIX_FMT_NONE is not supported.| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[h264_vdpau @ 0x88ae6e0]decode_slice_header error| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[VD_FFMPEG] Trying pixfmt=0.| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |Could not find matching colorspace - retrying with -vf scale...| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |Opening video filter: [scale]| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |The selected video_out device is incompatible with this codec.| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |Try appending the scale filter to your filter list,| <0xb60dbb90>
05      04/21/10 21:36:47.310           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |e.g. -vf spp,scale instead of -vf spp.| <0xb60dbb90>

Any idea howto solve that?

Sure I have integrated GeForce 8300 which supports VDPAU.
« Last Edit: April 22, 2010, 08:52:32 am by nite_man »
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Re: Hardware acceleration, i.e. VDPAU under 0810
« Reply #1 on: April 21, 2010, 11:42:39 pm »
I have no idea about your problems but I can confirm that vdpau does in fact work.  Not sure if I tried .mkv files, but .mp4 and MythTV both play great on an ION netbook after enabling VDPAU in the web admin AND in MythTV.  HDTV was unwatchable until I set this, I didn't try any ripped blu-ray movies before turning on VDPAU, but I suspect they would also have sucked.  I also learned if you enable VDPAU in MythTV on a MD with a non-vdpau video card you cannot get into MythTV at all.  LMCE jumps straight to TV, which fails and exits.  I had forgot I swapped an older card into my core/md... 

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Hardware acceleration, i.e. VDPAU under 0810
« Reply #2 on: April 21, 2010, 11:52:27 pm »
Thanks for your replay, skeptic. But I use VDR and I'm interested to playback MKV and M2TS files. And I have a big problems with it. When I use xv acceleration the MKV is played but with 90% using CPU, and as result, twitching. Even under 0710 the situation is much better because there mplayer takes about 50% of CPU.

My 0810 is up-to-date. So, I have no idea what is the problem. Maybe some codecs are missed?
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4540
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Hardware acceleration, i.e. VDPAU under 0810
« Reply #3 on: April 22, 2010, 12:35:39 am »
Thanks for your replay, skeptic. But I use VDR and I'm interested to playback MKV and M2TS files. And I have a big problems with it. When I use xv acceleration the MKV is played but with 90% using CPU, and as result, twitching. Even under 0710 the situation is much better because there mplayer takes about 50% of CPU.

My 0810 is up-to-date. So, I have no idea what is the problem. Maybe some codecs are missed?

Sounds like vdr is not using vdpau then.


Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Smart Home consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: Hardware acceleration, i.e. VDPAU under 0810
« Reply #4 on: April 22, 2010, 06:03:43 am »
I was talking with TSCHAK 2 days ago about a similar thing.  I had a m2ts file playing in mplayer, CPU usage was 90+%.  vdpau is set as the driver in Webadmin but doesn't seem to be working (at least with mplayer)

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Hardware acceleration, i.e. VDPAU under 0810
« Reply #5 on: April 22, 2010, 08:52:08 am »
Regarding the VDR. I know that under 0810 it doesn't support vdpau. But I know a few people from Russian VDR community who have it enabled under 1.7.X, of course. Currently I'm not going to watch HD TV. The most important for me is possibility to playback MKV/M2TS files with hardware acceleration regardless what player will be used - Xine or mplayer. Currently I cannot playback that kind of files with enabled vdpau acceleration at all. That's why I ask you, guys, about success example of using vdpau and not with mythtv but with Xine or mplayer video playback :)
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #6 on: April 22, 2010, 11:00:56 am »
With my nvidia ion board installed using default settings, .mkv files are jerky and unwatchable.

After changing hardware acceleration to vdpau in webadmin for that MD, the .mkv files play fine (apart from the odd one here and there). So it would appear that it was working in my case.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #7 on: April 22, 2010, 12:42:33 pm »
With my nvidia ion board installed using default settings, .mkv files are jerky and unwatchable.

After changing hardware acceleration to vdpau in webadmin for that MD, the .mkv files play fine (apart from the odd one here and there). So it would appear that it was working in my case.

Great! If you can play .mkv files that means Xine does it and not mplayer. Could you, please, try to rename .mkv file to .m2ts and play it? Also I'll be very appreciated if you post an info about your xine and mplayer packages:
Code: [Select]
apt-cache policy xine
apt-cache policy mplayer
Also what is CPU usage when you play .mkv/.m2ts files?
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #8 on: April 22, 2010, 02:11:06 pm »
With my nvidia ion board installed using default settings, .mkv files are jerky and unwatchable.

After changing hardware acceleration to vdpau in webadmin for that MD, the .mkv files play fine (apart from the odd one here and there). So it would appear that it was working in my case.

Great! If you can play .mkv files that means Xine does it and not mplayer. Could you, please, try to rename .mkv file to .m2ts and play it? Also I'll be very appreciated if you post an info about your xine and mplayer packages:
Code: [Select]
apt-cache policy xine
apt-cache policy mplayer
Also what is CPU usage when you play .mkv/.m2ts files?

No problem, I can do that in slower time (I'm away for a few days). How do I check CPU usage?
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #9 on: April 22, 2010, 02:13:29 pm »
Can I ask what changing .mkv to .m2ts is supposed to achieve? Does it force it to use mplayer or something?
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #10 on: April 22, 2010, 02:46:23 pm »
To see CPU usage during playback login to your core or hybrid and type command top. You'll see the percentage of CPU using by mplayer or xine (actually all others programs as well). m2ts files are played by mplayer and not xine. That approach is used since 0710 where xine shows HD video with artefacts. And yes, it forces LinuxMCE to use mplayer instead of xine. The system also sets type Blu-ray instead of Video file. But I'm not sure that last one is true.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

skeptic

  • Addicted
  • *
  • Posts: 615
    • View Profile
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #11 on: April 22, 2010, 04:11:34 pm »
nite_man - I think you mean to say to log onto the MD that is playing the video, which may be a hybrid but will not be a dedicated core.

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #12 on: April 22, 2010, 04:20:44 pm »
nite_man - I think you mean to say to log onto the MD that is playing the video, which may be a hybrid but will not be a dedicated core.

Sure, login to that PC where video is playing. I have core/hybrid only. That's why I didn't tell about dedicated one :)
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #13 on: April 23, 2010, 12:24:43 am »
Just guessing. Maybe package  nvidia-glx-195 conflicts with nvidia-195-libvdpau?
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: Hardware acceleration, i.e. VDPAU under 0810 with Xine or mplayer
« Reply #14 on: July 16, 2010, 12:37:39 am »
Any updates to this topic?