Author Topic: Audio settings for media type.  (Read 902 times)

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Audio settings for media type.
« on: March 28, 2010, 06:18:32 pm »
Hia,
maybe it's not the right place to post this, but could not find the answer anywhere, so  ihope to get a little help from the developers.
How do i set the audio mode for a media type. i.e. Live TV will switch the DSP mode off and have stereo, Video will switch the DSP mode to ON and select Movie Theather, Audio will select the DSP mode to ON and select Concert Hall?
I'm asking this because i did not find where to define it and because when i select Live TV, DSP mode is switched to ON and mode to Dolby Digital Enhanced, and this produces no sound, so i have to stand up and switch manually the mode.
TIA,
Paulo

Thingie

  • Veteran
  • ***
  • Posts: 114
    • View Profile
Re: Audio settings for media type.
« Reply #1 on: March 29, 2010, 07:01:09 pm »
Look at Media Scenarios in the left pane of the web admin
http://wiki.linuxmce.org/index.php/Media_Scenarios
Here you can add the command to the LiveTv scenario to switch the DSP

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: Audio settings for media type.
« Reply #2 on: March 29, 2010, 10:29:28 pm »
Hi Thingie,
thx for answering.. but how? Where do i add the command to switch the DSP mode (must be a set of 2 "key strokes")?
TIA
« Last Edit: March 29, 2010, 10:35:10 pm by pw44 »

Thingie

  • Veteran
  • ***
  • Posts: 114
    • View Profile
Re: Audio settings for media type.
« Reply #3 on: March 30, 2010, 07:36:03 pm »
Ok,

I think my solution wasn't the right one. Are you using USB UIRT for controlling the devices? If you do, did you add the 'to be controlled devices' (TV, surround system, ...) under A/V equipment added all the commands and learned the IR-codes? Let me know first before we go any further. I think I have a solution for you.

grts

Thingie

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: Audio settings for media type.
« Reply #4 on: March 30, 2010, 08:36:46 pm »
Hi,
i did create a new template for each of the devices (amp, tuner and cassete deck), did not pick any of the pronto templates, and did cut and paste all the ir codes, including the DSP modes (picketd from remote central), tested all of them (all worked) and after that, under AV Devices, added each of them, all controlled by  USB UIRT Embedded Transmit, under connecton wizard created the pipes or every device, and after that, under AV Properties, tested all the IR controls and all did work.
When i go to the OSD menu and select TV, amp switches to correct input, but selects the wrong DSP mode, which does not produces sound, since the TV signal is stereo only even if being sent via SPDIF/Optical to the amp.
The question is about how to define the " key strokes" to be sent to the amp when TV is selectd, in order to disable DSP mode and having it stero.
Another question is regarding the IR code set in the template. My IR control (the original one) has 12 buttons (1 to 12) and each of them has 2 or 3 DSP modes, i.e, hitting 1 i get concert hall 1, hitting 1 twice, i get concert hall 2, but 1 must be pressed twice in a time delay or i will select again concert hall 1.
I would lke to know how can i define DSP mode 2 sending the hex code twice with a time interval between both codes (they are equal = button 1).
Thx in advance for you r help.

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: Audio settings for media type.
« Reply #5 on: April 03, 2010, 08:06:14 pm »
Any way to make this work?
TIA,
Paulo

Thingie

  • Veteran
  • ***
  • Posts: 114
    • View Profile
Re: Audio settings for media type.
« Reply #6 on: April 04, 2010, 12:55:51 pm »
I'm not at home for a few days so I can't test anything. As soon as I'm home I'll try a few ideas.
Keep you posted

Thingie