Author Topic: CM15A USB type with wall outlet  (Read 747 times)

dcubox1

  • Veteran
  • ***
  • Posts: 130
    • View Profile
CM15A USB type with wall outlet
« on: March 16, 2010, 01:06:31 pm »
Hi Again,

I am trying to setup my X10 controller, its a CM15A usb type.
Does anyone know the easiest method of doing this?

I have a wall outlet that I can get working using my Windows OS however I want to have everything working
off my new Hybrid I just built...

I have tried a few different things like setting the house code on the outlet to B1 instead of A1 etc..
However I have had no luck to date.

I would really like to get this working as I am looking at putting this system all over the house if I can get it working!

Thanks for the advice in advance.

mythtified

  • Guru
  • ****
  • Posts: 176
    • View Profile
Re: CM15A USB type with wall outlet
« Reply #1 on: March 16, 2010, 03:41:47 pm »
First you will need to make sure that you are using Beta 0810 lmce.  The CM15a will not work with 0710.  Also, since you have had it connected to a windows host, were you using the active home software?  In any case it would be a good thing to clear the CM15a memory of any devices, timers, macros you may have created.  This can be done from the active home software.  Also, while in the active home software you may want to make sure which house codes will be transceived.  Once you clear the memory and check the house codes you want to transceive then you should update the cm15a and remove it from the windows host.  I usually install lmce then once it is installed I connect the CM15a to the LMCE box.  It should be detected quickly.  Just select yes and the os will set it up.  Once the router reloads you can start setting up lighting devices.

dcubox1

  • Veteran
  • ***
  • Posts: 130
    • View Profile
Re: CM15A USB type with wall outlet
« Reply #2 on: March 16, 2010, 03:55:27 pm »
Cheers for the reply mythtified

Yes I am using beta 810, a snapshot from the start of March.
I can see the system detecting the device but what I am struggling with is setting up the wall socket!
What is the easiest way to do this?
The wall socket is an x10 device in case I didnt clarify that.

Thanks for the help

mythtified

  • Guru
  • ****
  • Posts: 176
    • View Profile
Re: CM15A USB type with wall outlet
« Reply #3 on: March 16, 2010, 07:53:49 pm »
In the wizard, click on lights.  At the bottom of the window you will see update, cancel, and add device.  Click add device.  A lighting device template window will appear.  At the device template dropdown select the template that most matches the device that you are trying to set up.  It will either be a dimmable device or an on/off device.  Click get device template.  Then fill in the data of the device that appears.  In the Port/channel text box enter the house code/device code address of your x10 device:  A1, B12, G15, etc.  It will be one letter and one number.  Fill in the other info if it is relevant.  The description text box and the room drop down are the only other things I usually bother with.  I have not attempted to do floor plans yet so I cannot help you there.

I hope this helps.

Also, there is a lot of info in the wiki.  wiki.linuxmce.org.  Some of it is dated but most is still relevant.

Enjoy

dcubox1

  • Veteran
  • ***
  • Posts: 130
    • View Profile
Re: CM15A USB type with wall outlet
« Reply #4 on: March 23, 2010, 10:36:41 am »
Ok so I finally solved this issue....

It was the wall socket the controller was connected to!!
All I did was try a different set of sockets and it worked straight away...
Suggest anyone having issues like this try another socket first before you drive yourself mad!

I guess this is down to how your house is wired! the X10 might not work on sockets if they are a spur set!