Author Topic: apt-get tries to downgrade pacakges on MD  (Read 775 times)

stallione

  • Veteran
  • ***
  • Posts: 59
    • View Profile
apt-get tries to downgrade pacakges on MD
« on: March 09, 2010, 03:28:23 pm »
not sure how to troubleshoot this issue but two of my MDs want to downgrade the installed packages every time I run apt-get upgrade

Code: [Select]
root@moon80:~# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
  cups cups-bsd cups-client cups-common cupsys-client kdeplasma-addons-libs4 libcups2 libcupsimage2
The following packages will be DOWNGRADED:
  libmyth-0.22-0 libmyth-perl lmce-mythtv-scripts mythtv-backend mythtv-common mythtv-frontend mythtv-transcode-utils pluto-boot-scripts pluto-disk-drive pluto-libresolution pluto-mplayer-player pluto-photo-screen-saver
  pluto-simplephone pluto-storage-devices pluto-x-scripts
8 upgraded, 0 newly installed, 15 downgraded, 0 to remove and 2 not upgraded.
Need to get 3749kB/33.5MB of archives.
After this operation, 98.3kB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.

Any ideas? (The install went fine, I even rebuilt one of the MDs in question)

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: apt-get tries to downgrade pacakges on MD
« Reply #1 on: March 09, 2010, 08:32:02 pm »
I see two possibilities:

1. Update your core and re-run /usr/pluto/bin/Diskless_CreateTBZ.sh then rebuild your MDs.

or

2. Remove the entry "deb file:/usr/pluto/deb-cache/ ./" from /etc/apt/sources.list on the affected MDs and then update/upgrade them.

I'm not sure why this is happening.

J.

stallione

  • Veteran
  • ***
  • Posts: 59
    • View Profile
Re: apt-get tries to downgrade pacakges on MD
« Reply #2 on: March 10, 2010, 07:36:14 pm »
The second solution you offered worked. What does it do? Does it ignore the downloaded cache?

Thanks!
Stallione

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: apt-get tries to downgrade pacakges on MD
« Reply #3 on: March 10, 2010, 08:17:27 pm »
I believe the /usr/pluto/deb-cache is a repository of .debs, used to build the diskless images, at the time you ran /usr/pluto/bin/Diskless_CreateTBZ.sh on your core. 

What is puzzling me is why apt isn't using the newer .debs from the online repos.

J.

stallione

  • Veteran
  • ***
  • Posts: 59
    • View Profile
Re: apt-get tries to downgrade pacakges on MD
« Reply #4 on: March 10, 2010, 08:26:48 pm »
aha! I see what's going on.. on my core, the /usr/pluto/deb-cache folder has corrupt files. for example look at the last file, it has a '%' instead of a '.' and there are lots of files like this..

Code: [Select]
-rw-r--r-- 1 root root    641090 2009-11-29 08:12 zaptel-modules-2.6.27-14-generic_1.4.11~dfsg-2+2.6.27-14.41_i386.deb
-rw-r--r-- 1 root root    641056 2009-11-29 08:12 zaptel-modules-2.6.27-15-generic_1.4.11~dfsg-2+2.6.27-15.43_i386.deb
-rw-r--r-- 1 root root    641120 2010-03-04 18:14 zaptel-modules-2.6.27-17-generic_1%3a1.4.11~dfsg-2+2.6.27-17.45_i386.deb

Can I safely remove all the files from here? Will it download all new files when I rerun the /usr/pluto/bin/Diskless_CreateTBZ.sh ?

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: apt-get tries to downgrade pacakges on MD
« Reply #5 on: March 10, 2010, 09:40:11 pm »
The script /usr/pluto/Diskless...TBZ.sh will re-create the MD images completely from scratch, including the /usr/pluto/deb-cache folder.

With the 'deb...' line removed from /etc/apt/sources.list the MD will not try to use files from that directory, you can use and update your MD as if nothing was different.  Apt's cache of downloaded .debs is still active and not affected by this change.

What remains is to determine why/when/how the filenames are being corrupted and by what.

J.