Archive > Orbiter - Developers

Orbiter on Zaurus III

(1/6) > >>

archived:
Chris.m
I finally got my hybrid/core built and am trying to run the orbiter on the zaurus. I have run into a bit of a problem that I hope is easily fixed. My orbiter loads etc. then segfaults out saying that it can't open the Arial font. Openzaurus doesn't distribute the MS fonts. Is there a way to do this without using the MS truetype fonts?

Rob

archived:
Hi Rob,

You could try getting the fonts for a linux box and copy them to your zaurus, it should work. Here's the path : /usr/share/fonts/truetype/msttcorefonts. You could copy all *.ttf files.

Best regards,
Cristian Miron

archived:
Chris,
Sorry I haven't gotten back to you on this, I've been doing a bit of traveling for the last few weeks.

I copied the arial*.ttf files from a windows box to /usr/share/fonts/truetype/msttcorefonts. Now I get a bunch of errors like this:

--- Code: newbielink:javascript:void(0); [nonactive] ---
ERROR: Xlib: ErrorHandler_Grabber() // static int X11wrapper::ErrorHandler_Grabber(Display*, XerrorEvent*)

Xlib: ErrorHandler_Grabber()
   type: 0
   display : 0x2473b0
   serial : 286
   error_code :
   request_code : .
   minor_code :
   resourcid : 48234501
ErrorText  : BadFont (invalid Font parameter)

Segmentation Fault

--- End code ---

Also above that I get:

--- Code: newbielink:javascript:void(0); [nonactive] ---
ERROR: Xlib: ErrorHandler_Grabber() // static int X11wrapper::ErrorHandler_Grabber(Display*, XerrorEvent*)

Xlib: ErrorHandler_Grabber()
   type: 0
   display : 0x40a00968
   serial : 261
   error_code :
   request_code : <
   minor_code :
   resourcid : 50331731
ErrorText  : BadGC (invalid GC parameter)

--- End code ---

All this is in the terminal that I start the Orbiter.

In the log file I get:

archived:
Let's try this one then : newbielink:http://only.mawhrin.net/~geometer/zaurus/fonts/mscf.html [nonactive] :)

archived:
Chris,

--- Quote ---
Let's try this one then : newbielink:http://only.mawhrin.net/~geometer/zaurus/fonts/mscf.html [nonactive] Smile
--- End quote ---

That is for Qtopia. I am running openzaurus GPE which uses X11.

The BadGC error is concerning as well. Any ideas?

Rob

Navigation

[0] Message Index

[#] Next page

Sitemap 
Go to full version