Author Topic: [SOLVED] DHCP question about fixed addresses.  (Read 788 times)

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
[SOLVED] DHCP question about fixed addresses.
« on: March 05, 2010, 01:03:57 am »
Hia,
my IP camera has the fixed adress of 192.168.80.220 and connecting it to the 192.168.80.0 net, webadmin -> Advanced -> Networks -> DHCP Leases shows it got 192.168.80.129.
But pinging to 192.18.80.129 fails and pinging to 192.168.80.220 works.
So, i edited the dhcpd.conf file and added the IP cam as static, so a random address ist not assigned to it. After restarting dhcpd server, it remains assigning the 129 to the IP cam.
Any hint?
TIA
Paulo
« Last Edit: March 10, 2010, 11:20:43 am by pw44 »

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: DHCP question about fixed addresses.
« Reply #1 on: March 05, 2010, 06:37:01 am »
yeah,
1) dont edit the dhcp server config file on the core, you will at best end up frustrating yourself and at worst breaking your install
2) set the camera to use dhcp
3) last resort, change the ip in the device data for the camera in the web admin

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: DHCP question about fixed addresses.
« Reply #2 on: March 10, 2010, 11:20:10 am »
Thx,
defining mac address and ip address in webadmin solved it.
Paulo
« Last Edit: March 10, 2010, 03:20:29 pm by pw44 »

Kooma

  • Veteran
  • ***
  • Posts: 102
    • View Profile
Re: DHCP question about fixed addresses.
« Reply #3 on: March 10, 2010, 07:36:31 pm »
Thx,
defining mac address and ip address in webadmin solved it.
Paulo
Wasn't able to get cameras working either.
Did you end up using dhcp in the camera or what solved your case? Your response above suggests not using dhcp in the camera.
Thanks.

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: [SOLVED] DHCP question about fixed addresses.
« Reply #4 on: March 10, 2010, 08:20:12 pm »
The camera is using dhcp, but i wanted to select an address range for this kind of devices. So when i added the camera in webadmin, i informed the mac address and the ip address for it, and lmce created the entries in the dhcpd.conf table. So every time the camera is plugged, it will allways get the same address.
Before i tried to set the camera with static address and tried to define it in the dhcpd.conf table. But wasn't working as i thought.