Author Topic: VoIP: Make/receive calls when logged in via external network?  (Read 749 times)

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Hey All,

Recently got VoIP configured and working, including using sipdroid on a google nexus one. Works a treat when @ home on the wifi network. Sipdroid also automagically patches outbound calls via SIP when at home (using the defaul phone interface).. very cool (and cheap!).

Today I changed the server settings to use the external domain, not the 192.168.80.1 IP (dyndns) and I was still able to login to the SIP server. My phone rings when connected over 3G when my home SIP number is called, however when I answer it I get dead air and it drops.

Q: Should VoIP work when connected via an external network?

Cheers,
WR

alx2k

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
Re: VoIP: Make/receive calls when logged in via external network?
« Reply #1 on: March 01, 2010, 11:44:54 am »
Probably you have tried this already, but it looks like LINUXMCE firewall is blocking incoming traffic (in your case, from your phone to the internal network). Also, it could be that you don't have your modem/router VoIP ports redirected to your core.

Check firewall rules.

Be careful when opening VoIP ports to the exterior, default passwords are not that secure, so a malicious guy could connect to your network and make long distance calls from it.

I don't know if there is an android port of openvpn, but you should google it. (also OpenVPN is already implemented in LinuxMCE, so probably you would only need to change some server options, like making it Server VS Roadwarrior, change passwords, etc...).

Tell me if it was the firewall thing.

P.S. It could also be asterisk related (local encapsulation in SIP packages), see post 2 in this link for more info: http://forums.whirlpool.net.au/forum-replies-archive.cfm/1230714.html
« Last Edit: March 01, 2010, 12:08:55 pm by alx2k »

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: VoIP: Make/receive calls when logged in via external network?
« Reply #2 on: March 01, 2010, 11:39:42 pm »
Probably you have tried this already, but it looks like LINUXMCE firewall is blocking incoming traffic (in your case, from your phone to the internal network). Also, it could be that you don't have your modem/router VoIP ports redirected to your core.

Check firewall rules.

Be careful when opening VoIP ports to the exterior, default passwords are not that secure, so a malicious guy could connect to your network and make long distance calls from it.

I don't know if there is an android port of openvpn, but you should google it. (also OpenVPN is already implemented in LinuxMCE, so probably you would only need to change some server options, like making it Server VS Roadwarrior, change passwords, etc...).

Tell me if it was the firewall thing.

P.S. It could also be asterisk related (local encapsulation in SIP packages), see post 2 in this link for more info: http://forums.whirlpool.net.au/forum-replies-archive.cfm/1230714.html


Thanks alx2k,

Yeah the firewall is setup by default to udp 5060, but it appears that I also need to open some others up. To test I opened them all up via UDP (1-65535) and it worked.

Obviously I'd prefer not to have this, so i'll see if I can find out the specific ones (reading through that other thread seems like it might not be cut and dry).

Thanks again.
WR

alx2k

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
Re: VoIP: Make/receive calls when logged in via external network?
« Reply #3 on: March 02, 2010, 08:43:36 am »
as it says in the post I gave you, in a normal asterisk instalation you'll find in /etc/asterisk/rtp.conf the range of UDP ports your asterisk is using, normally it goes from 10.000 to 20.000. Probably it is located in the same directory in linuxmce (I am unable to check it right now).

What I did in my office installation before I installed OpenVPN was to leave unmodified the rtp.conf file leaving all those ports open to the internal but on the router I redirected "only" about 20 ports (from 10000 to 10020). That did the trick for external calls.

If you leave ports open to asterisk I also recommend you change all your passwords on FreePBX and on your telephones, but it can be a bit tricky on cisco 7970 or similars.

Hope you have it working.

Alx.

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: VoIP: Make/receive calls when logged in via external network?
« Reply #4 on: March 02, 2010, 12:14:50 pm »
Yeah -  I was unable to check earlier also but now have and it is in the same place. I am thinking your are probably right and I might leave it protected and go the VPN route. Just have to root the phone first so I can install openvpn... Will post once I get a chance confirming. Thanks again for your help ;-)