Author Topic: Installation problem with Geforce 9500gt Video Card  (Read 2323 times)

dlwhite9

  • Newbie
  • *
  • Posts: 8
    • View Profile
Installation problem with Geforce 9500gt Video Card
« on: February 22, 2010, 09:09:01 pm »
I'm starting with a new installation of LMCE 8.10b2 and I'm also having problem installing and getting LMCE to come up. 

Hardware:
Pentium Dual Core - 4GB Memory
GeForce 9500 GT Video Card
Hauppauge 1600 Tuner
2 - Ethernet ports - one on Gigabyte board, 1 in PCI slot

I have installed the LMCE DVD Beta2, apt-get update, dist-upgrade and network LMCE install.   This all goes well.  The reboot happens and then I get a "Avwizard" popup with "Failed to Setup x".   I have done the following:

I have a problem with the eth0 device driver, but that's been resolved by going from the r8169 -> r8168 ethernet device driver.

I go to the alt terminal (Alt-Ctrl F3) and do a "startx", and I get the following:

NVIDIA: could not open the device file /dev/nvidia() (Input/output error).
(EE) ...NVIDIA(0):  Failed to initialize the NVIDIA graphics device PCI:1:0:0
(EE) ...NVIDIA(0):  Please check your system's kernel log for additinoal error....etc...etc.

xinit:  Connection refused (errno 111): unable to connect to X server
xinit:  No such process (errno 3):  Server error.

I have also done the following:

sudo apt-get update
sudo apt-get install --reinstall nvidia-glx-195

Any ideas would be more appreciated...  Thanks in advance...Don


jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: Installation problem with Geforce 9500gt Video Card
« Reply #1 on: February 22, 2010, 09:36:52 pm »
Does your motherboard have an onboard video chip that you are not using, but have not disabled?

dlwhite9

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Installation problem with Geforce 9500gt Video Card
« Reply #2 on: February 22, 2010, 11:05:15 pm »
The motherboard does NOT have any video board functions....only the Geforce 9500gt in a PCIV2 slot.

dlwhite9

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Installation problem with Geforce 9500gt Video Card
« Reply #3 on: February 23, 2010, 09:47:06 pm »
Does anybody else have any suggestions on this problem?   Thank you in advance...Don

daballiemo

  • Guru
  • ****
  • Posts: 244
  • Full Blown Addict
    • View Profile
Re: Installation problem with Geforce 9500gt Video Card
« Reply #4 on: February 23, 2010, 10:34:27 pm »
Running into exactly the same problem. A md a created without any problem (onboard video: 02:00.0 VGA compatible controller: nVidia Corporation GeForce 8200 (rev a2)) was recreated after advice I gotten from tkmedia (no Wake on Lan). Can't get anywhere with the system
 xorg.log:

(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"         
        compiled for 4.0.2, module version = 1.0.0       
        Module class: X.Org Video Driver                 
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA:     system's kernel log for additional error messages.   
(II) UnloadModule: "nvidia"                                           
(II) Unloading /usr/lib/xorg/modules/drivers//nvidia_drv.so           
(EE) Failed to load module "nvidia" (module-specific error, 0)         
(II) LoadModule: "mouse"                                               

(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"         
        compiled for 1.4.99.905, module version = 1.3.0
        Module class: X.Org XInput Driver             
        ABI class: X.Org XInput driver, version 2.1   
(II) LoadModule: "kbd"                                 

(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"         
        compiled for 1.4.99.905, module version = 1.3.1
        Module class: X.Org XInput Driver             
        ABI class: X.Org XInput driver, version 2.1   
(II) v4l driver for Video4Linux                       
(II) Primary Device is: PCI 02@00:00:0                 
(WW) Falling back to old probe method for v4l         
(EE) No devices detected.                             

Fatal server error:
no screens found   

Reinstall of nvidia, or complete dump of MD and generating new MD did not work
HP N40L12.04 KVM with virt LCME8.10/10.04
MD: FoxConn NetBox 330I - Samsung LE 26 (1360* 768)
MD: M2NPV-VM dual core AMD 64/3800/2Gb/NV6150 - Samsung UE 55 C8700 (full hd, 3d)
MD: FoxConn NetBox 330I - LG 32ld350

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: Installation problem with Geforce 9500gt Video Card
« Reply #5 on: February 24, 2010, 11:12:13 am »
Sounds like there is no Nvidia Module installed.

Anything like this in /var/log/syslog ?
Code: [Select]
Feb 23 15:09:49 moon44 kernel: [   29.659969] nvidia: module license 'NVIDIA' ta
ints kernel.
Feb 23 15:09:50 moon44 kernel: [   29.914750] nvidia 0000:01:00.0: PCI INT A ->
GSI 18 (level, low) -> IRQ 18
Feb 23 15:09:50 moon44 kernel: [   29.914820] nvidia 0000:01:00.0: setting laten
cy timer to 64
Feb 23 15:09:50 moon44 kernel: [   29.915050] NVRM: loading NVIDIA UNIX x86 Kern
el Module  195.30  Fri Dec 18 13:34:49 PST 2009

Send output of "lsmod |grep nvidia" :
Code: [Select]
nvidia               9865060  60
agpgart                42184  1 nvidia
i2c_core               31892  16 ves1x93,tda10023,dvb_pll,lnbp21,stb6100,stv0299,stb0899,dvb_ttpci,budget_av,budget_ci,dvb_usb_opera,budget_core,ttpci_eeprom,dvb_usb,i2c_piix4,nvidia

and "modinfo nvidia"
Code: [Select]
filename:       /lib/modules/2.6.27-16-generic/updates/dkms/nvidia.ko
license:        NVIDIA
alias:          char-major-195-*
alias:          pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias:          pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        agpgart,i2c-core
vermagic:       2.6.27-16-generic SMP mod_unload modversions 586
parm:           NVreg_EnableVia4x:int
parm:           NVreg_EnableALiAGP:int
parm:           NVreg_ReqAGPRate:int
parm:           NVreg_EnableAGPSBA:int
parm:           NVreg_EnableAGPFW:int
parm:           NVreg_Mobile:int
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_RemapLimit:int
parm:           NVreg_UpdateMemoryTypes:int
parm:           NVreg_UseVBios:int
parm:           NVreg_RMEdgeIntrCheck:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_MapRegistersEarly:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_NvAGP:int

and " dpkg -l|grep nvidia"
Code: [Select]
ii  nvidia-173-modaliases                      173.14.12-1-0ubuntu5.1                                     Modaliases for the NVIDIA binary X.Org drive
ii  nvidia-177-modaliases                      177.82-0ubuntu0.1                                          Modaliases for the NVIDIA binary X.Org drive
ii  nvidia-180-modaliases                      180.60-0ubuntu9                                            Modaliases for the NVIDIA binary X.Org drive
ii  nvidia-195-kernel-source                   195.30-0ubuntu1                                            NVIDIA binary kernel module source
ii  nvidia-195-libvdpau                        195.30-0ubuntu1                                            Video Decode and Presentation API for Unix
ii  nvidia-71-modaliases                       71.86.04-0ubuntu10                                         Modaliases for the NVIDIA binary X.Org drive
ii  nvidia-96-modaliases                       96.43.09-0ubuntu1.1                                        Modaliases for the NVIDIA binary X.Org drive
ii  nvidia-common                              0.2.4.2                                                    Find obsolete NVIDIA drivers
rc  nvidia-glx-180                             180.60-0ubuntu9                                            NVIDIA binary Xorg driver
ii  nvidia-glx-195                             195.30-0ubuntu1                                            NVIDIA binary Xorg driver
ii  nvidia-settings                            190.36-0ubuntu5                                            Tool of configuring the NVIDIA graphics driv
ii  pluto-nvidia-video-drivers                 2.0.0.44.09112922522                                       <insert up to 60 chars description>
root@dcerouter:/usr/pluto/diskless/44# dpkg -l|grep nvidia-glx
rc  nvidia-glx-180                             180.60-0ubuntu9                                            NVIDIA binary Xorg driver
ii  nvidia-glx-195                             195.30-0ubuntu1                                            NVIDIA binary Xorg driver

Greetings
Viking

daballiemo

  • Guru
  • ****
  • Posts: 244
  • Full Blown Addict
    • View Profile
Re: Installation problem with Geforce 9500gt Video Card
« Reply #6 on: February 24, 2010, 06:47:34 pm »
We'll on my system I find:

Code: [Select]
root@moon105:~# cat /var/log/syslog | grep nvidia
root@moon105:~#
root@moon105:~# lsmod | grep nvidia
root@moon105:~#
root@moon105:~# dpkg -l | grep nvidia
ii  nvidia-173-modaliases                      173.14.12-1-0ubuntu5.1                      Modaliases for the NVIDIA binary X.Org drive
ii  nvidia-177-modaliases                      177.82-0ubuntu0.1                           Modaliases for the NVIDIA binary X.Org drive
ii  nvidia-180-modaliases                      180.60-0ubuntu9                             Modaliases for the NVIDIA binary X.Org drive
ii  nvidia-195-kernel-source                   195.36.03-0ubuntu2                          NVIDIA binary kernel module source
ii  nvidia-195-libvdpau                        195.36.03-0ubuntu2                          Video Decode and Presentation API for Unix
ii  nvidia-71-modaliases                       71.86.04-0ubuntu10                          Modaliases for the NVIDIA binary X.Org drive
ii  nvidia-96-modaliases                       96.43.09-0ubuntu1.1                         Modaliases for the NVIDIA binary X.Org drive
ii  nvidia-common                              0.2.4.2                                     Find obsolete NVIDIA drivers
rc  nvidia-glx-173                             173.14.12-1-0ubuntu5.1                      NVIDIA binary Xorg driver
ii  nvidia-glx-195                             195.36.03-0ubuntu2                          NVIDIA binary Xorg driver
ii  nvidia-settings                            190.36-0ubuntu5                             Tool of configuring the NVIDIA graphics driv
ii  pluto-nvidia-video-drivers                 2.0.0.44.09112922522                        <insert up to 60 chars description>
root@moon105:~# modprobe nvidia
FATAL: Module nvidia not found.
root@moon105:~#

 >:(

I am going to dump the md and run "/usr/pluto/bin/Diskless_CreateTBZ.sh" once again. After that I will recreate the MD
« Last Edit: February 24, 2010, 06:49:10 pm by daballiemo »
HP N40L12.04 KVM with virt LCME8.10/10.04
MD: FoxConn NetBox 330I - Samsung LE 26 (1360* 768)
MD: M2NPV-VM dual core AMD 64/3800/2Gb/NV6150 - Samsung UE 55 C8700 (full hd, 3d)
MD: FoxConn NetBox 330I - LG 32ld350

dlwhite9

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Installation problem with Geforce 9500gt Video Card
« Reply #7 on: February 25, 2010, 03:18:59 pm »
I was able to resolve my issue with by updating the /boot/grub/menu.lst  file.   I found the first statement that started with "KERNEL" and appended the following:

" vmalloc=256M" 

at the end of the line.   You can see the error in the "syslog" file.

daballiemo

  • Guru
  • ****
  • Posts: 244
  • Full Blown Addict
    • View Profile
Re: Installation problem with Geforce 9500gt Video Card
« Reply #8 on: February 25, 2010, 09:12:32 pm »
It looks like I have got a kernel conflict, my core is running 2.6.27-16-generic, but when I run diskless setup it is telling about the kernel headers for 2.6.27-17. Although I thought it was no good idea to do an apt-get dist upgrade Mandingo told me to do so in the IRC channel So I will go ahead with it. Will report what the results are.
HP N40L12.04 KVM with virt LCME8.10/10.04
MD: FoxConn NetBox 330I - Samsung LE 26 (1360* 768)
MD: M2NPV-VM dual core AMD 64/3800/2Gb/NV6150 - Samsung UE 55 C8700 (full hd, 3d)
MD: FoxConn NetBox 330I - LG 32ld350

daballiemo

  • Guru
  • ****
  • Posts: 244
  • Full Blown Addict
    • View Profile
[Solved] Installation problem with Geforce 9500gt Video Card
« Reply #9 on: February 26, 2010, 09:15:29 am »
Well, Mandingo turned out to be right. I was a conflict in kernel version. As I did not perform an update to my core (apt-get dist-upgrade) but the diskless setup script retrieved the latest kernel the new MD was not able to build the right kernel modules because the kernel itself was version 16 and the libs version 17. The following actions took care of it:

Core > apt-get update
Core > apt-get dist-upgrade
Core > delete md via webadmin
Core > reboot
Core > /usr/pluto/bin/Diskless_CreateTBZ.sh
Core > reboot
MD > Netstart and give it time!!!! go through avwizard
Core > reboot
MD > netstart and go trough setup wizard

 ;D
HP N40L12.04 KVM with virt LCME8.10/10.04
MD: FoxConn NetBox 330I - Samsung LE 26 (1360* 768)
MD: M2NPV-VM dual core AMD 64/3800/2Gb/NV6150 - Samsung UE 55 C8700 (full hd, 3d)
MD: FoxConn NetBox 330I - LG 32ld350

MANDINGO

  • Guru
  • ****
  • Posts: 204
    • View Profile
Re: Installation problem with Geforce 9500gt Video Card
« Reply #10 on: February 26, 2010, 05:13:09 pm »
 ;D

Nice.........

Mandingo
For a Current List of Plug and Play Capture Cards/Devices
http://wiki.linuxmce.org/index.php/Capture_Cards