Author Topic: [solved]select hdmi in 8.10 fails ok in 7.10  (Read 3331 times)


  • Veteran
  • ***
  • Posts: 144
    • View Profile
[solved]select hdmi in 8.10 fails ok in 7.10
« on: February 22, 2010, 08:28:09 pm »

Bought a new hdd and swapped it with my old 7.10 hdd just to have a fallback plan since apparently this is a live system and needs to be working 24/7 (or at least when my son and wife is awake)  ;D

Using same hw as I had on 7.10 (which works)
Mobo is ABIT AN-M2HD with one Hdmi and one VGA
Kernel version:2.6.27-17-generic

I am confused.
I have a panasonic ae 3000 connected to the hdmi via an onkyo 906. same bios settings as before and Nothing changed except the hdd and off course the new 8.10.

When I try to choose the hdmi(720p 60hz or 50hz) via avwizard using temporary monitor connected to Vga. It just fires up the higher res. settings on the VGA output.

- I have tried using HDMI-2 option
- I can disable the hdmi audio in the bios and tried that one.(same bios settings though as being used currently in the 7.10)
- Tried changing the settings to what I want and then after lmce was up restarting and having only the hdmi connected.
- connected the Pana directly to the hdmi on the mobo
- been playing around with EDID(true and false) in the Xorg conf files
-changing xorg conf vertikal and horisontal freq. values to same as in 7.10
- hdmi connection works when using hdmi -> dvi cable connected to PC monitor..

I just dont understand this, I am now running the other hdd with 7.10 and that one works just fine..

Kernel, am I using the latest and greatest?
I attach a cropped version of the printout from when I was remotely logged into the system and started the avwizard, changing settings to my liking to log and see what was going wrong and in the end killed it(?) by hitting ctrl-c but I cannot find anything weird..

why work in 7.10 but not at all in 8.10?

« Last Edit: February 24, 2010, 07:56:07 am by johanr »


  • Veteran
  • ***
  • Posts: 144
    • View Profile
Re: select hdmi in 8.10 fails ok in 7.10
« Reply #1 on: February 22, 2010, 11:51:34 pm »
I strongly belieive this must be related to Xorg config and that the outputted signal is not accepted by my projector since it seem to work with the PC monitor

I have been trying to find in the forum and in the wiki how it all works. The custom resolution setting wiki and the avwizard wiki does however not answer my question or possibly I am just to stupid/blind.

as I have understood according to reading forum posts there are two places to edit if I need to activate EDID.
/etc/X11/xorg.conf and /usr/pluto/templates/

I cannot make sense of that, why is the same config in two places and which one is the one being updated after AVwizard?

I guess simply that the etc/X11.. .config is the master template and that avwizard generate this /usr/pluto/templates/ file after changing settings in the avwizard.

But then..
I found the xorg.conf.pluto.avwizardr in 710 not sure if this file is also in 810 but I guess it is.
  what does that do?

I have tried comparing the 710 configs with the 810 but they are off course not using the same structure so it's abit hard to see where something is missing.



  • Veteran
  • ***
  • Posts: 144
    • View Profile
re:[Solved]select hdmi in 8.10 fails ok in 7.10
« Reply #2 on: February 23, 2010, 03:00:00 pm »
guess noone really understood what the question was that I had. sad but also makes me have to learn even more..
 Anyway I solved it now.

edited the etc/X11/xorg.conf file to look similar (modeline and freq.) as in 710. Now the picture ends up in the right place and all seem ok. Tried setting the pci bus adress but that made the X not start and that was easily spotted in the Xorg log =) Excellent work guys!

Also even more important.. I couldn't remember that I activated the nvidia driver in the Kubuntu desktop.. Did that also.. this one may actually have been the issue that solved it all :-X

now 2hrs later I am almost back to where I left off with the 710. Have not tested it all yet so lets see. at least watching movies seem to work and controlling my 13 light devices.
Have found one issue reg. floorplans and DynAPI error, but that's probarbly something related to user error also or has been noticed before. will play around abit more and post about it later if I cannot find solution.

Keep up the good work guys, I am learning more and more every minute and hopefully one day I will also be able to help doing some hard work..

currently just a user


  • Guru
  • ****
  • Posts: 183
    • View Profile
Re: [solved]select hdmi in 8.10 fails ok in 7.10
« Reply #3 on: December 11, 2010, 11:19:42 pm »
Hi Johanr can you provide a copy of your etc/X11/xorg.conf  config.  I've been having the same problem and if someone found a fix, I'd like to know.  Don't know what my 710 config looked like as I did an install on top of the old system (won't do that again) and it appears that there are no other answers to this problem.  Appreciate all the help.