Author Topic: upgrade error  (Read 924 times)

rperre

  • Guru
  • ****
  • Posts: 264
    • View Profile
upgrade error
« on: February 16, 2010, 02:05:31 am »
ok ran a apt-get upgrade on my core and got the following errors:

Code: [Select]
dcerouter_1007666:/usr/pluto/bin# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up pluto-boot-scripts (2.0.0.44.10021322765) ...
mkdir: cannot create directory `/root/Desktop': File exists
dpkg: error processing pluto-boot-scripts (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of pluto-system-database:
 pluto-system-database depends on pluto-boot-scripts (>= 2.0.0.44); however:
  Package pluto-boot-scripts is not configured yet.
 pluto-system-database depends on pluto-boot-scripts (<< 2.0.0.45); however:
  Package pluto-boot-scripts is not configured yet.
dpkg: error processing pluto-system-database (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pluto-std-plugins:
 pluto-std-plugins depends on pluto-system-database (>= 2.0.0.44); however:
  Package pluto-system-database is not configured yet.
 pluto-std-plugins depends on pluto-system-database (<< 2.0.0.45); however:
  Package pluto-system-database is not configured yet.
 pluto-std-plugins depends on pluto-boot-scripts (>= 2.0.0.44); however:
  Package pluto-boot-scripts is not configureNo apport report written because the error message indicates its a followup error from a previous failure.
                                                                       No apport report written because the error message indicates its a followup error from a previous failure.
                 d yet.
 pluto-std-plugins depends on pluto-boot-scripts (<< 2.0.0.45); however:
  Package pluto-boot-scripts is not configured yet.
dpkg: error processing pluto-std-plugins (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 pluto-boot-scripts
 pluto-system-database
 pluto-std-plugins
E: Sub-process /usr/bin/dpkg returned an error code (1)

What's up with this and will this mess up my system?

Thanks,

Richard

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 942
    • View Profile
Re: upgrade error
« Reply #1 on: February 16, 2010, 02:15:23 am »
Did the same, my core and MDs had a file, not a directory at /root/Desktop so a directory couldn't be created.  It should be a directory though so I:
Code: [Select]
# rm /root/Desktop
# apt-get -f install
# apt-get upgrade

on each core and MD fixed it up for me.  I'm not sure when/how/why the /root/Desktop file was created.

J.

rperre

  • Guru
  • ****
  • Posts: 264
    • View Profile
Re: upgrade error
« Reply #2 on: February 16, 2010, 02:21:16 am »
i appreciate that, i'll make a ticket for this so it can be fixed

Richard

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: upgrade error
« Reply #3 on: February 20, 2010, 12:49:18 pm »
Thx phenigma,
got the same problem and your hint fixed it.

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 942
    • View Profile
Re: upgrade error
« Reply #4 on: February 20, 2010, 02:40:17 pm »
Your welcome.  This issue will only affect a few who upgraded at a very specific time.  The issue has been fixed for new installs and anyone who upgrades from before the issue arose.

J.