Author Topic: [solved]"Update 2009-02-13 22765 "  (Read 3108 times)

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: "Update 2009-02-13 22765 "
« Reply #15 on: February 17, 2010, 04:27:02 am »
Also need to update the Website sqlCVS repo, then the Hulu Player appears on the Software Modules page.

Add it, then the install runs, but there seems to be a missing binary file...

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: "Update 2009-02-13 22765 "
« Reply #16 on: February 21, 2010, 04:31:55 am »
Thom thanks, I just installed Hulu and it is working as it is expected now.
Cheers |[BEER]
Charlie,

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: [solved]"Update 2009-02-13 22765 "
« Reply #17 on: February 22, 2010, 04:45:46 pm »
has hulu_plugin.so been added to the install process?  I am still missing it...

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: [solved]"Update 2009-02-13 22765 "
« Reply #18 on: February 22, 2010, 07:57:11 pm »
jimbodude,
While I was debugging the problem I had with Hulu, I installed the plugin manually, and forgot to deleted, so I'm not sure if it was overwritten with the new one or it was not installed during the installation, it would be nice if someone else install Hulu from scratch and see if it works without any manual intervention.
Cheers |[BEER]
Charlie,

donpaul

  • Guru
  • ****
  • Posts: 300
    • View Profile
Re: [solved]"Update 2009-02-13 22765 "
« Reply #19 on: February 22, 2010, 09:32:53 pm »
I just did an apt-get upgrade, and installed hulu.

When I launch hulu, I get the message: I cannot play this media. Perhaps there is no a valid device in this entertainment area capable of playing it.

So it was not as simple as updating sqlcvs DCE and Designer repositories, and selecting Hulu Player from the software modules. There may be something else that needs to be done.

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: [solved]"Update 2009-02-13 22765 "
« Reply #20 on: February 22, 2010, 09:34:54 pm »
When I launch hulu, I get the message: I cannot play this media. Perhaps there is no a valid device in this entertainment area capable of playing it.

I believe this is because the hulu_plugin.so is missing.  I am experiencing the same issue.

donpaul

  • Guru
  • ****
  • Posts: 300
    • View Profile
Re: [solved]"Update 2009-02-13 22765 "
« Reply #21 on: February 22, 2010, 10:20:24 pm »
Makes sense. I can launch it from kde fine. Is this a bug, or is hulu simply not ready yet?

donpaul

  • Guru
  • ****
  • Posts: 300
    • View Profile
Re: [solved]"Update 2009-02-13 22765 "
« Reply #22 on: February 23, 2010, 03:11:17 am »
I did an apt-get install lmce-hulu-plugin on the core, and reloaded the router. Hulu works now.

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: [solved]"Update 2009-02-13 22765 "
« Reply #23 on: February 23, 2010, 03:27:10 am »
I did an apt-get install lmce-hulu-plugin on the core, and reloaded the router. Hulu works now.

um... I can't install that package... it doesn't exist.  Yes, I apt-get updated... Yes, I tried apt-cache search to see if there was a spelling error.  Yes, I checked to make sure it isn't already installed... No hulu packages anywhere.

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: [solved]"Update 2009-02-13 22765 "
« Reply #24 on: February 23, 2010, 05:18:06 am »
Right, so there were a few issues here...
1) Package lists aren't being updated for some people.  I'm one of them - this is why I got nowhere with the install.  http://svn.linuxmce.org/trac.cgi/ticket/615
2) There was some missing stuff related to getting the hulu plugin package - Thom added it, now it works right.  sqlCVS update the dce repo to get the changes.
3) I was unable to get the autogenerated scenario to appear on orbiters until I manually sorted them in the web admin several times.  This is because UpdateEntArea_Media.cpp assumes that it can just select iOrder numbers without checking what exists in the database.  In my case, one iOrder was used twice.

I now have Hulu running.  The Orbiter controls are not ready yet - you must use a remote with arrows or a keyboard.  Other than that, it looks like it works.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2935
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: [solved]"Update 2009-02-13 22765 "
« Reply #25 on: February 24, 2010, 09:35:22 am »
When sqlCVS updating, make sure to update each repo individually, and check all tables in the repo. For hulu, as Thom pointed out, you need the DCE repo and the designer repo.

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: [solved]"Update 2009-02-13 22765 "
« Reply #26 on: February 24, 2010, 04:08:23 pm »
And also the website repo, otherwise the Hulu Player option does not show up under software modules