Author Topic: NVIDA H264 Codec  (Read 8437 times)

FireMail

  • Regular Poster
  • **
  • Posts: 30
    • View Profile
Re: NVIDA H264 Codec
« Reply #60 on: March 01, 2010, 02:27:49 pm »
MPEG2 content should be vdpau accelerated through either xine or mplayer.  What container format (File extension) are the files?
hi, its m2ts - played via mplayer.

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: NVIDA H264 Codec
« Reply #61 on: March 01, 2010, 06:32:17 pm »
Previous issue: solved by setting on MD Audio settings to manual configuration (i think it makes a passthru).
VDPAU is working really fine.
All entries at /root/.mplayer/config were comented (no effect).
The only problems remaining are:
1) fast forward: for some files it does not work (no effect, even when displayed SPEED X  4.00)
2) fast back: not working.
3) stop watching the m2ts file makes the last screen remain as the backgroung image.
« Last Edit: March 01, 2010, 06:53:49 pm by pw44 »

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 920
    • View Profile
Re: NVIDA H264 Codec
« Reply #62 on: March 01, 2010, 07:29:56 pm »
FireMail:  I am seeing stuttering on 1080P material in LMCE now, I was not getting this before and I do not get this when playing the same titles from the command line.

The only problems remaining are:
1) fast forward: for some files it does not work (no effect, even when displayed SPEED X  4.00)
2) fast back: not working.
3) stopping watching the m2ts file make the last screen remain as the backgoung image.

I see similar issues on 1 & 2 here, pause is also not working.  The orbiter doesn't return when the media ends and the PSS doesn't restart when media ends nor when media is stopped manually.

For AAC audio over SPDIF only the following two lines in ~/.mplayer/config are required.
Code: [Select]
channels=6
af=scaletempo,lavcac3enc=1:640:3

J.

maverick0815

  • Addicted
  • *
  • Posts: 520
    • View Profile
Re: NVIDA H264 Codec
« Reply #63 on: March 01, 2010, 07:38:03 pm »
I just tried transformers in 1080p- still unwatchable...720p playes fine with mplayer.

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: NVIDA H264 Codec
« Reply #64 on: March 01, 2010, 07:43:50 pm »
On my system:
Blade Runer 1080p - ok. no suttering.
Pause - not working for any m2ts.
MD -> Audio Settings -> Manual Configuration = no need for /root/.mplayer/config
Ice Age - Dawn of the Dinossaurs 1080p - suttering :(
Julie and Julia - 1080p - stuttering. :(

niz23, any hint regarding ffw, fbw, pause and at stop the last screen remaining as background?
« Last Edit: March 01, 2010, 07:55:45 pm by pw44 »

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: NVIDA H264 Codec
« Reply #65 on: March 01, 2010, 10:28:57 pm »
these are known issues.
Om working on an updated Mplayer_player that Will use libplayer to interface mplayer against lmce.
Its partly working.

/niz23
 
On my system:
Blade Runer 1080p - ok. no suttering.
Pause - not working for any m2ts.
MD -> Audio Settings -> Manual Configuration = no need for /root/.mplayer/config
Ice Age - Dawn of the Dinossaurs 1080p - suttering :(
Julie and Julia - 1080p - stuttering. :(

niz23, any hint regarding ffw, fbw, pause and at stop the last screen remaining as background?

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: NVIDA H264 Codec
« Reply #66 on: March 02, 2010, 12:12:09 pm »
Thx niz23 for your reply.

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: NVIDA H264 Codec
« Reply #67 on: March 03, 2010, 08:30:07 pm »
Another problem detected with MPlayer_player:
after stopping the watch of a .m2ts movie, the mplayer process hangs, so i need to kiil -9 process #.
Anyone confirm this?
TIA.

FireMail

  • Regular Poster
  • **
  • Posts: 30
    • View Profile
Re: NVIDA H264 Codec
« Reply #68 on: March 04, 2010, 09:14:02 am »
Another problem detected with MPlayer_player:
after stopping the watch of a .m2ts movie, the mplayer process hangs, so i need to kiil -9 process #.
Anyone confirm this?
TIA.
works fine here

maverick0815

  • Addicted
  • *
  • Posts: 520
    • View Profile
Re: NVIDA H264 Codec
« Reply #69 on: March 10, 2010, 07:30:24 pm »
hmmm...I'm still having problems...I can play my files either as m2ts or mkv...but I will only have sound and no video..

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: NVIDA H264 Codec
« Reply #70 on: March 15, 2010, 09:32:11 pm »
On you core/hybrid or MD? On my core/hybrid, i can play the .m2ts files with sound and video, but on my MD, no video (did not test sound yet). :(
« Last Edit: March 15, 2010, 10:51:57 pm by pw44 »

maverick0815

  • Addicted
  • *
  • Posts: 520
    • View Profile
Re: NVIDA H264 Codec
« Reply #71 on: March 16, 2010, 06:48:33 pm »
I haven't tried on the core, but on my MD its really a very mixed bag.
So, if the file is not playing as mkv I rename it to m2ts...there its either out of sync or not running at all...while its playing on my windoze box

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: NVIDA H264 Codec
« Reply #72 on: March 16, 2010, 11:14:44 pm »
Trying on hybrid may be a good test. I will try to get a nvidia 8xxx or 9xxx to test and see if what is happening is due MPlayer_player or HW.
Today i try to watch the the movie MPlayer_player refuses with mplayer, and it worked... not perfect but it did, using -vo x11, which is not an option under hardware acceleration tab (webadmin -> media directors). The playback was not perfect, but it worked.... Did not notice sound sync because did not connected the MD to speakers or stereo.....

Beeker

  • Guru
  • ****
  • Posts: 267
    • View Profile
Re: NVIDA H264 Codec
« Reply #73 on: March 18, 2010, 05:45:53 pm »
Hi All,
All you guys have much more Linux cmd line experience then me, is there any simple way to test the different players ie mplayer and xine or vlc to see if my core and md's will play mkv and H264 files as per my previous posts, I am quite happy to go and buy new video cards if that will fix the problem.....my biggest question is that as I am using a 7600GS in both and when these were XP's pc's in previous lifes they played these types of files with out any hesitation so I am curious to find out why they now wont play under MCE

Cheers
Beeker

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: NVIDA H264 Codec
« Reply #74 on: March 19, 2010, 05:12:46 pm »
I have a problem with MKV files playback under 0810. Here is a mplayer log:
Code: [Select]
05      03/19/10 17:43:13.777           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[VD_FFMPEG] Trying pixfmt=0.| <0xb614cb90>
05      03/19/10 17:43:13.778           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |Could not find matching colorspace - retrying with -vf scale...| <0xb614cb90>
05      03/19/10 17:43:13.778           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |Opening video filter: [scale]| <0xb614cb90>
05      03/19/10 17:43:13.778           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |The selected video_out device is incompatible with this codec.| <0xb614cb90>
05      03/19/10 17:43:13.778           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |Try appending the scale filter to your filter list,| <0xb614cb90>
05      03/19/10 17:43:13.778           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |e.g. -vf spp,scale instead of -vf spp.| <0xb614cb90>
05      03/19/10 17:43:13.778           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[h264_vdpau @ 0x88ae6e0]decoding to PIX_FMT_NONE is not supported.| <0xb614cb90>
05      03/19/10 17:43:13.778           MPlayer_Player::Log [EngineOutputReader] Analyzing line: |[h264_vdpau @ 0x88ae6e0]decode_slice_header error| <0xb614cb90>
Any idea howto fix that?
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru