Author Topic: dist-upgrade error  (Read 1226 times)

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
dist-upgrade error
« on: February 11, 2010, 04:20:26 pm »
I just did an apt-get update and dist-upgrade on 810 and received the following errors
Code: [Select]
Setting up pluto-boot-scripts (2.0.0.44.10021122758) ...
/var/lib/dpkg/info/pluto-boot-scripts.postinst: line 104: /etc/skel/Desktop/LinuxMCE: No such file or directory
dpkg: error processing pluto-boot-scripts (--configure):
 subprocess post-installation script returned error exit status 1
Setting up libmysqlclient15-dev (5.0.67-0ubuntu6.1) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 pluto-boot-scripts
E: Sub-process /usr/bin/dpkg returned an error code (1)
Is this something I need to worry about? is it a bug?
If more info is needed ask and I'll try to provide.

-Coley.

ihcfan

  • First post!
  • Posts: 1
    • View Profile
Re: dist-upgrade error
« Reply #1 on: February 12, 2010, 04:43:59 am »
I had the same problem.  Looks like the script believes that /etc/skel/Desktop will exist.  to correct type:
Code: newbielink:javascript:void(0); [nonactive]
sudo mkdir /etc/skel/Desktop
then run the upgrade again
Code: newbielink:javascript:void(0); [nonactive]
sudo apt-get dist-upgrade

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
Re: dist-upgrade error
« Reply #2 on: February 12, 2010, 01:14:15 pm »
yeah that will allow the script to continue - but why is it looking for this in the first place?
Is it a mistake in the script or should it exist already?

-Coley.

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: dist-upgrade error
« Reply #3 on: February 12, 2010, 04:59:06 pm »
http://www.linfo.org/etc_skel.html

What is being put in the directory that is created?  Get that information, and open a ticket (if one isn't already opened).

chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: dist-upgrade error
« Reply #4 on: February 12, 2010, 05:19:39 pm »
Look here in the file /var/lib/dpkg/info/pluto-boot-scripts.postinst

Code: [Select]
## Add shortcut to the desktop to get back to LinuxMCE orbiter
cat <<eol >/etc/skel/Desktop/LinuxMCE
[Desktop Entry]
Encoding=UTF-8
Version=8.10
Type=Application
Exec=/usr/pluto/bin/ActivateOrbiterFromKDE.sh
Path=/usr/pluto/bin
Name=Back To LinuxMCE Orbiter
Icon=gnome-panel-launcher
eol

Script should really detect whether the folder exists,

[ -d /etc/skel/Desktop/ ] || mkdir /etc/skel/Desktop/


jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: dist-upgrade error
« Reply #5 on: February 12, 2010, 06:15:11 pm »

Script should really detect whether the folder exists,

[ -d /etc/skel/Desktop/ ] || mkdir /etc/skel/Desktop/


Yes, it probably should.  Open a ticket with that suggestion.
http://svn.linuxmce.org/trac.cgi/newticket

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1014
    • View Profile
Re: dist-upgrade error
« Reply #6 on: February 12, 2010, 11:18:52 pm »
This is also causing /usr/pluto/bin/Diskless_CreateTBZ.sh to error out long before finishing.

J.

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1014
    • View Profile
Re: dist-upgrade error
« Reply #7 on: February 13, 2010, 12:33:49 am »