Author Topic: WORKAROUND for Beta 2 Video Overscan  (Read 632 times)

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
WORKAROUND for Beta 2 Video Overscan
« on: February 01, 2010, 12:04:53 am »
Hya,

before installing beta2 (latest), i was running the november version. In this version, i installed the restricted nvidia 180 module after apt-get dist-upgrade.
With that, applying the ugly hack, and setting the useEDID flag to true solved the overscan issue.

With this new beta, the 195.30 nvidia drivers where installed , and even with the useEDID flag setted to true, the overscan issue is back.

No matter what i've tryed, i could not solve the overscan issue.

So, searching, i' ve found that i could use the nvidia-settings utility to solve the ovescan issue.
Opening nvidia-settings under kde, GPU-0 -> DFP-0 (in my case, Philips 37_42 LCD TV) and playing with te Ovescan Compensation ruler, i' ve found that 64 solves my ovescan problem.
Now, under nvidia-settings Configuration, Saving the curent configution created the file .nvidia-settings-rc.
Browsing this file, i've found the following line: dcerouter:0.0/OverscanCompensation[DFP-0]=64
Seraching and researching, i found the /etc/pluto/X-PostStart.sh, and it contained the following:
#!/bin/bash
nvidia-settings -a "SyncToVBlank=1"
nvidia-settings -a "XVideoTextureSyncToVBlank=1"
nvidia-settings -a "XVideoBlitterSyncToVBlank=1"
So, i did the following modification:
#!/bin/bash
nvidia-settings -a "OverscanCompensation[DFP-0]=64"
nvidia-settings -a "SyncToVBlank=1"
nvidia-settings -a "XVideoTextureSyncToVBlank=1"
nvidia-settings -a "XVideoBlitterSyncToVBlank=1"
After rebooting the system, the overscan issue was gone.
My personal feeling is that the image quality with the 180 nvidia restricted driver was better than the 195.30 driver.
Maybe someone can tell me why or can tell me how to improve the image (fonts, etc..) quality.
« Last Edit: February 03, 2010, 12:32:28 pm by pw44 »