Author Topic: MythTV problems beta 2 0810 - "I cannot play this media"  (Read 2486 times)

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
MythTV problems beta 2 0810 - "I cannot play this media"
« on: January 20, 2010, 11:04:05 am »
Hi All,

Recently installed the 0810 and had a few issues trying to get MythTV to work. Initially it failed to download, then after trying the below code (found in a Viking post via google) I was able to get the MythTV setup option in Computing and Mythweb up and running.

I had to remove some modules first (mythtv common) as it had 0.23 installed and this was conflicting with the mythtv backend it was trying to download. Once I removed it the below seemed to get me most of the way there:

- CORE:
Code: [Select]
apt-get install mythtv-backend=2:0.22.0-fixes22779-0ubuntu0 mythtv-common=2:0.22.0-fixes22779-0ubuntu0 mythtv-database=2:0.22.0-fixes22779-0ubuntu0  mythtv-frontend=2:0.22.0-fixes22779-0ubuntu0  mythtv-transcode-utils=2:0.22.0-fixes22779-0ubuntu0 libmyth-0.22-0=2:0.22.0-fixes22779-0ubuntu0
apt-get install mythweb=2:0.22.0-fixes22785-0ubuntu0

- MD (Hybrid device for me) :
Code: [Select]
apt-get install mythtv-frontend=2:0.22.0-fixes22779-0ubuntu0  libmyth-perl=2:0.22.0-fixes22779-0ubuntu0 libmyth-python=2:0.22.0-fixes22779-0ubuntu0
This also downgraded the libmyth-perl and libmyth-python that was installed by default.

Now I can record shows via Mythweb and play them back via the Media player within LinuxMCE, but if I try and launch TV via the Media scenarios I get the error:
"I cannot play this media. Perhaps there is not a valid device in this entertainment area capable of playing it."

I figure this manual fix has screwed something up but I am not sure what?

MythTV Player appears as a device under the onscreen orbiter for the hybrid. Is there something else I can do? Ideas, suggestions?

Thanks!
WR

Edit: Incidentally the  sudo /usr/pluto/bin/Diskless_CreateTBZ.sh is still spitting out the mythtv error:
Code: [Select]
E: Broken packages
#### Package pluto-mythtv-player failed (/tmp/tmp.RNVXu16861) - We wait 10sec and try again - to stop retrying press Ctrl-C.

Editing the source list didn't seem to help (as per Wiki http://wiki.linuxmce.org/index.php/Error_Running_Diskless_CreateTBZ.sh)

:*(



« Last Edit: January 20, 2010, 12:23:23 pm by wombiroller »

maverick0815

  • Addicted
  • *
  • Posts: 540
    • View Profile
Re: MythTV problems beta 2 0810 - "I cannot play this media"
« Reply #1 on: January 20, 2010, 05:20:37 pm »
I had the same problem when I ran an update on monday. this update also removed the pluto-mythtv-player package.
So I went to the irc and got quite nice support from the guys there. It appears that the avenard repo made another switch to mythtv .23
It also keeps the .22, but you need to do some workaround to keep it
just download the file I attached to /etc/apt. then run the apt-get update and apt-get-dist upgrade.
after that check if you also need to get the pluto-mythtv-player again.
This certainly did the trick with me.

Good luck

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: MythTV problems beta 2 0810 - "I cannot play this media"
« Reply #2 on: January 21, 2010, 10:49:50 am »
Thanks maverick0815 - that worked! Woohoo, almost there now with the Beta. Thanks to all involved!

itspac

  • Veteran
  • ***
  • Posts: 136
    • View Profile
Re: MythTV problems beta 2 0810 - "I cannot play this media"
« Reply #3 on: January 21, 2010, 01:52:37 pm »
experience the same problem and that fix worked for me.  Just curious if the preferences file will be a permanant addition to lmce to control what version of myth is installed   if say avenard changes again at a later date?

maverick0815

  • Addicted
  • *
  • Posts: 540
    • View Profile
Re: MythTV problems beta 2 0810 - "I cannot play this media"
« Reply #4 on: January 21, 2010, 04:31:25 pm »
I don't know the answer to that. But something has to be done. Perhaps the devs can update the preference file to download a higher version of mythtv, if they can also change the version linuxmce uses...or, they will start hosting their own repo...but I really don't know

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: MythTV problems beta 2 0810 - "I cannot play this media"
« Reply #5 on: January 22, 2010, 04:47:31 pm »

Quote from Possy in IRC

<@possy> BongoWongo, please post a note in the thread about the mythtv .23 snafu that a new installer is available that should fix the problem in general. Every existing install should create a preferences file as outlined in #574

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: MythTV problems beta 2 0810 - "I cannot play this media"
« Reply #6 on: January 22, 2010, 05:06:23 pm »
http://svn.linuxmce.org/trac.cgi/ticket/574

You will have to apt-get update, apt-get dist-upgrade, and possibly apt-get install pluto-mythtv-plugin pluto-mythtv-player after making that change