Author Topic: MD Setup NVIDIA Driver Issues  (Read 2949 times)


  • Newbie
  • *
  • Posts: 10
    • View Profile
MD Setup NVIDIA Driver Issues
« on: January 17, 2010, 12:15:59 pm »

I have been playing around with 8.10 beta2 for a bit an decided to
use my main PC as a MD (For testing purposes).

I wanted to test how well my hardware woud run on a diskless boot.
More specifically the optical output.

I ran the /usr/pluto/bin/ script and after it completed
I plugged my PC into the subnetwork for pluto.

All worked fine in terms of creation of the diskless boot files on pluto,
however when I rebooted and went through the start up sequence
It wanted to do a driver install for my 8800GT Nvidia card.

It appeard to download some packages and wanted to reboot,
However it went through the exact same cycle of wanting to install
the driver

The screen roll is quite fast but I can see that it's unable to resolve,
and there are serveral lines like this.

I did a fresh install of the core, thinking my previous tinkering may have broken somethin, I also diabled the firewall.

But the issue is still there.

Is ther somthing I need to do on the core to make this work, or can i install the driver on the
diskless partition from the core.

The core has a 6600 Nvidia card with the driver installed from the restriced driver section of Kubuntu,
installed prior to the MCE build scrip



  • Newbie
  • *
  • Posts: 10
    • View Profile
Re: MD Setup NVIDIA Driver Issues
« Reply #1 on: January 19, 2010, 09:57:15 am »
Due to the lack of response, I would say that either
the issue I have is an "Un-documented Feature", or is
due to me doing something really dull.

I'll opt for the latter, as this is the most likley ;)

Seeing that the data I have collected doesn't seem to be giving anyone
a hint to what is causing this issue, is there any way I can invoke a boot log,
and where would I access it from the core.
(MD never gets to a stage that I can open a terminal to login as it keeps rebooting at the end of
the Nvidia driver install script)

Just for a bit of background, before I reinstalled the core I had my laptop as a MD (Intel GFX),
and I did notice that I could not browse from the MD, but could on the core.

I didn't disable the firewall at that point, so I'm not sure if that's a contributing factor in the
MD (Nvidia GFX) not able to download the relevant sources.

I'll be reinstalling the core tonight, any recommendations on sequencing of updates to make this

I'm following to the letter with the exception
that I activate the Nvidia restricted driver before doing apt-get dist-upgrade.

Have I found a bug or am I being dull (need to know for my own sanity's sake  :P )



  • Regular Poster
  • **
  • Posts: 36
    • View Profile
Re: MD Setup NVIDIA Driver Issues
« Reply #2 on: April 17, 2010, 10:52:56 pm »
I'm having the exact same problem.  I had no issues with 0710 but I can't get either of my 2 MDs to work with the 0810 beta.


  • Regular Poster
  • **
  • Posts: 41
    • View Profile
Re: MD Setup NVIDIA Driver Issues
« Reply #3 on: April 19, 2010, 04:28:33 am »
    I had the same issue, and I still do, that my MD's can't access the internet through the core. The core can access the internet just fine, and IP forwarding is enabled.
I think the reason is doesn't work for me anyway, is that the core router is not doing NAT translation, so the next hop router sees 192.168. in the source address, and it's getting dropped.  If this is true, then this is not very secure and upstream networks and hosts can see actual addresses on the private 192.168.80 network.

    Since the MD can't find the internet, the automatic update process is not working, and that's the endless rebooting.
    The files on the MD can be edited directly in /usr/pluto/diskless/XX where XX is the MD you want to edit.  Careful they can be overwritten by templates.
I am able to update the MD with apt-get by putting a file called proxy02 in /etc/apt/apt.conf.d/02proxy in both the core and MD. See instructions on another thread.

You may also want to enable SSH on the media director.

To get around the automatic updates, I commented out the lines containing "confirmDependencies" in /usr/pluto/bin/
Then I copied all the files I needed from the core, video drivers, packages, etc.

I update the MD manually with apt-get.

I added a static route on my router.
# sudo route add -net <external IP of dcerouter>
And this worked, a terrible solution but it does get my MD internet access since NAT translation is implemented on the core.

If anyone having this problem and is using a linksys/netgear, then hopefully it will allow static routes to be added.
« Last Edit: April 20, 2010, 04:54:49 pm by THEVILLAIN »