Author Topic: Remote Storage [Solved]  (Read 1045 times)

Trav

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Remote Storage [Solved]
« on: January 30, 2010, 08:14:32 pm »
I curently am running 810 and I was woundering if someone had any suggestions to setup my remote storage.  I have a U.S robotics NAS but what it does is create windows shares or NFS Shares.  If you set up a Windows share it does not do simple sharing so you have to use a user name and a password.  MCE has no problem detecting the the windows shares with the plug and play but when it installs the files do not show up in the web admin but will play in the MD.  I have tried reinstalling and using different setings.  I have never got it to work with the NFS shares.  Does anyone have any sugestions which shares I should use and how to set it up to work properly? ???
« Last Edit: February 10, 2010, 05:37:30 pm by Trav »

epsolon77

  • Regular Poster
  • **
  • Posts: 15
    • View Profile
Re: Remote Storage
« Reply #1 on: February 03, 2010, 03:53:36 pm »
I have not tried this on linuxMCE, but under standard linux you can configure samaba to read a windows file share, and in-kind share with windows box's.

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Remote Storage
« Reply #2 on: February 03, 2010, 04:43:50 pm »
Make sure Nas is on internal net and set to use dhcp for IP address.
Boot the unit answer the prompts as a file server
enter  user-name and pw
select use linuxmce directory structure
move your music into the /public/data/audio/ folder on the nas
repeat for other media types into their respective directories (video etc)

Enjoy

Tim
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

Trav

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: Remote Storage
« Reply #3 on: February 07, 2010, 02:47:33 am »
Ok did that with three times now and each reinstall each time using windows shares on the NAS.  I have this problem where it shows the file names on the MDs and I can play them great but, the files do not show up in the Web Admin so i can set up the icons and all the other stuff.
Any suggestions on what I am doing wrong?

Trav

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: Remote Storage
« Reply #4 on: February 07, 2010, 04:06:47 pm »
Ok I have done that three times now and with each reinstall using windows shares on the NAS.  I have this problem where it shows on the MDs and I can play them great but, the files do not show up in the Web Admin so I can not set up the icons and all the other stuff.
Any suggestions on what I am doing wrong?
« Last Edit: February 07, 2010, 04:30:46 pm by Trav »

Trav

  • Regular Poster
  • **
  • Posts: 20
    • View Profile
Re: Remote Storage
« Reply #5 on: February 07, 2010, 09:40:57 pm »
Ok figured out the problem!  It was permissions.  In the window shares I could not set up the permissions so the mce server could have all the rights it needed (half ass USRobotics interface) so it could read but that was it. I made a NFS share on a seperate machine and was able to do a chmod to give the server what it needed.  I am still using the samba share (i have the option of both one one share on this particular NAS) to access my media through MCE.  Working Great  ;)