Author Topic: VDR first steps - /dev/dvb/adapter0/frontend1 - HOWTO configure?  (Read 2718 times)

Lexje

  • Guru
  • ****
  • Posts: 230
    • View Profile
VDR first steps - /dev/dvb/adapter0/frontend1 - HOWTO configure?
« on: December 18, 2009, 01:10:41 pm »
Hi folks,

Following my recent continuing problems to get Myth 0.22 going with my HVR-4000 I setup a new 0810 install with VDR instead of MythTV.

Unfortunately I have no experience whatsoever with VDR.
So all is in place and installed.
Choosing media > TV serves me a NO SIGNAL image.

I have followed the LMCE/VDR wiki page, and had to ad the -f 1 to the scan command in order for SCAN to use the secondary frontend of the HVR-4000.
Code: [Select]
sudo scan -f 1 -o vdr -p -u /usr/share/doc/dvb-utils/examples/scan/dvb-t/be-Schoten > channels.conf
Scanning worked allright, and gave me a nice channels.conf.
I'm not sure where uploading this file using pluto webadmin does put this file, but I found a channels.conf in /var/lib/vdr/channels.conf (owner root) and this was not the channels.conf file that I uploaded.
So, where does the channels.conf file need to go for LMCE?

Next I assume that analogous to MythTV, VDR should somewhere be told to use the correct frontendN of the DVB-T card?
Below is a list of what is in /dev/dvb/adapter0/
Code: [Select]
linuxmce@dcerouter:/dev/dvb/adapter0$ ls -l
total 0
crw-rw---- 1 root video 212, 1 2009-12-18 11:31 demux0
crw-rw---- 1 root video 212, 5 2009-12-18 11:31 demux1
crw-rw---- 1 root video 212, 2 2009-12-18 11:31 dvr0
crw-rw---- 1 root video 212, 6 2009-12-18 11:31 dvr1
crw-rw---- 1 root video 212, 0 2009-12-18 11:31 frontend0
crw-rw---- 1 root video 212, 4 2009-12-18 11:31 frontend1
crw-rw---- 1 root video 212, 3 2009-12-18 11:31 net0
crw-rw---- 1 root video 212, 7 2009-12-18 11:31 net1

Now where do I configure VDR to use frontend1?


VDRADMIN-AM
I have vdradmin-am up and running.
Is there someplace here to configure dvb card settings?

Thanks a lot for you help!

Erwin

Lexje

  • Guru
  • ****
  • Posts: 230
    • View Profile
Re: VDR first steps - /dev/dvb/adapter0/frontend1 - HOWTO configure?
« Reply #1 on: December 18, 2009, 01:25:13 pm »
Short update:
After rebooting I found my channels.conf to be in place (I had copied it manually over to /var/lib/vdr/channels.conf)

Having a look at the log:
Code: [Select]
== ATTEMPT FRESH START ==
1       12/18/09 13:14:01       Spawn_Device.sh 35 (spawning-device)    15665 Dev: 35; Already Running list: 15,16,18,19,30,31,21,27,22,25,26,23,
== FRESH START ==
1       12/18/09 13:14:01       Spawn_Device.sh 35 (spawning-device)    device: 35 ip: 127.0.0.1 cmd_line: VDR
0       12/18/09 13:14:01       35 (spawning-device)    Entering 35
========== NEW LOG SECTION ==========
1       12/18/09 13:14:01       35 (spawning-device)    Starting... 1
1       12/18/09 13:14:01       35 (spawning-device)    Found ./VDR
01      12/18/09 13:15:34.170           VDR.poll:in startup <0xb77bdb90>
01      12/18/09 13:15:34.172           VDR:A:pollVDRStatus state is now 2 <0xb77bdb90>
05      12/18/09 13:15:36.145           ReceivedDataDelimited: Last time we've called ReceiveData, it timed out! <0xb77bdb90>
01      12/18/09 13:15:37.145           VDR.parser: given input was 1 VRT - EEN
 <0xb77bdb90>
05      12/18/09 13:15:38.197           ReceivedDataDelimited: Last time we've called ReceiveData, it timed out! <0xb77bdb90>
05      12/18/09 13:16:08.217           ReceivedDataDelimited: Last time we've called ReceiveData, it timed out! <0xb67bbb90>
01      12/18/09 13:16:08.217           VDR not ok with command got 0 lines then got:  <0xb67bbb90>
05      12/18/09 13:16:08.217           void ClientSocket::Disconnect() on this socket: 0xb67ba288 (m_Socket: 8) <0xb67bbb90>
01      12/18/09 13:16:09.217           VDR.parser: given input was  <0xb67bbb90>
01      12/18/09 13:16:09.217           VDR.parser:Error parsing channel  <0xb67bbb90>
linuxmce@dcerouter:/var/log/pluto$

So I really guess I should somewhere point VDR to /dev/dvb/adapter0/frontend1/

Suppose you have more than one TV adapter in your system, how would you select adapter0 or adapter1 in VDR?