Author Topic: [SOLVED] Installed Beta2, but now no Autogenerated Media Scenarios  (Read 2326 times)

Xtra

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Hi there,
first off, congrats to the Beta2 looks very promising so far.
As the subject already told you, I have set up my core and successfully added a diskless MD (which crashed in the AVWizard as soon as I selected the TV out but I got around this after manually hacking the autodetection and switching of the video mode out of the av wizard script and configuring my xorg.conf by hand).
So far everything is as it should be aside from the fact that my Media Scenario list in the Orbiters is entirely empty except for the "Floorplan" option.
When I have a look at the web admin, I see that all default scenarios are missing in there aswell. It simply states "N/A" there.
So, here are my questions:
How can it happen that they are not autogenerated?
How can I manually "auto-generate" them or, what are the SQL values I have to hack into my DB to get them into my installation?

If anyone could give me a hint on those questions, even the slightest hint like suggestion of some shellscript files where I can dig up information myself should do as I am currently really lost here.

Regards
Chris
« Last Edit: December 17, 2009, 03:30:46 am by Xtra »

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
did you upgrade to beta2 from beta, or is this a fresh beta2 install from DVD?

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1026
    • View Profile
Scenarios are only generated for MDs which are in rooms.  If AVWizard crashed and you hacked past it then you never made it to the Setup Wizard to tell LMCE what room the MD is in.  You can either run the Setup Wizard from 'Advanced->Setup Wizard' using the onscreen Orbiter or...

Check the webadmin under Devices->Media Directors, each MD needs to be assigned to a room.   Each MD has a pull-down menu selection bar under the Device/Room heading, this is where the 'room' is defined for each MD.  If it says '- Please Select -' then the MD is not assigned to a room.  If you set the room in the web admin and then reload the router then regenerate all your orbiters the Media Scenarios should show up. 

Recently I added an MD and it didn't reach the setup wizard (I don't know why) and I set the room through the webadmin, reloaded then regened and the Scenarious appeared.

HTH.

J.

Xtra

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Thanks for your replies.

1. All my MDs are added to rooms.
2. I finished the AV Wizard. I just killed the part that alters the xorg.conf and that only on one MD (not the core, that one ran smoothly), therefore my systems should be setup correctly.

But I found out the source of my problems.
By searching via google I ended up that /usr/pluto/bin/UpdateEntArea is responsible for creating those devices.
So I jumped to the command line and fired it up:
Code: [Select]
root@dcerouter:/usr/pluto/bin# ./UpdateEntArea -h localhost -u root -D pluto_main
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup_EntertainArea (`FK_CommandGroup`, `FK_EntertainArea`, `Sort`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 2, 1, NULL, NULL, NULL, 0, NULL)] Duplicate entry '0-2' for key 1
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup_EntertainArea (`FK_CommandGroup`, `FK_EntertainArea`, `Sort`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 2, 1, NULL, NULL, NULL, 0, NULL)] Duplicate entry '0-2' for key 1
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup_EntertainArea (`FK_CommandGroup`, `FK_EntertainArea`, `Sort`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 2, 1, NULL, NULL, NULL, 0, NULL)] Duplicate entry '0-2' for key 1
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup_EntertainArea (`FK_CommandGroup`, `FK_EntertainArea`, `Sort`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 2, 1, NULL, NULL, NULL, 0, NULL)] Duplicate entry '0-2' for key 1
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup_EntertainArea (`FK_CommandGroup`, `FK_EntertainArea`, `Sort`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 2, 1, NULL, NULL, NULL, 0, NULL)] Duplicate entry '0-2' for key 1
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup_EntertainArea (`FK_CommandGroup`, `FK_EntertainArea`, `Sort`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 2, 1, NULL, NULL, NULL, 0, NULL)] Duplicate entry '0-2' for key 1
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup_Command_CommandParameter (`FK_CommandGroup_Command`, `FK_CommandParameter`, `IK_CommandParameter`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (46, 29, "4", NULL, NULL, NULL, 0, NULL)] Duplicate entry '46-29' for key 1
Cannot perform query: [insert into CommandGroup_EntertainArea (`FK_CommandGroup`, `FK_EntertainArea`, `Sort`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 2, 1, NULL, NULL, NULL, 0, NULL)] Duplicate entry '0-2' for key 1
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Cannot perform query: [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, "TV", "Office", 0, 0, 0, NULL, NULL, 33, NULL, 11, "2009-12-17 01:17:48", 0, 32, 1, NULL, NULL, NULL, NULL, 0, NULL)] Unknown column 'FK_Text' in 'field list'
Segmentation fault (core dumped)
So, the first entries are added and then it misses a column "FK_Text".
Eventually it crashes with an segmentation fault.

A strace session provides me with:
Code: [Select]
[...]
write(3, "01\t12/17/09 1:33:11.087\t\t\33[31;1mTable_CommandGroup::Commit Cannot perform query [insert into CommandGroup (`PK_CommandGroup`, `FK_Array`, `FK_Installation`, `Description`, `Hint`, `CanTurnOff`, `AlwaysShow`, `CanBeHidden`, `FK_Criteria_Orbiter`, `FK_DesignObj`, `FK_Template`, `AltID`, `FK_Icon`, `AutoGeneratedDate`, `Disabled`, `TemplateParm1`, `TemplateParm2`, `FK_Text`, `psc_id`, `psc_batch`, `psc_user`, `psc_frozen`, `psc_restrict`) values (0, 5, 111726, \"TV\", \"B\303\274ro\", 0, 0, 0, NULL, NULL, 33, NULL, 11, "..., 661) = 661
poll([{fd=4, events=POLLIN|POLLPRI}], 1, 0) = 0
write(4, ":\0\0\0\3UPDATE CommandGroup set psc_mod=0 WHERE PK_CommandGroup=0", 62) = 62
read(4, "0\0\0\1\0\0\0\2\0\0\0(Rows matched: 0  Changed: 0  Warnings: 0", 16384) = 52
poll([{fd=4, events=POLLIN|POLLPRI}], 1, 0) = 0
write(4, "B\0\0\0\3UPDATE CommandGroup_Command set psc_mod=0 WHERE FK_CommandGroup=0", 70) = 70
read(4, "0\0\0\1\0\0\0\"\0\0\0(Rows matched: 1  Changed: 0  Warnings: 0", 16384) = 52
poll([{fd=4, events=POLLIN|POLLPRI}], 1, 0) = 0
write(4, "\306\0\0\0\3UPDATE CommandGroup_Command_CommandParameter JOIN CommandGroup_Command ON FK_CommandGroup_Command=PK_CommandGroup_Command set CommandGroup_Command_CommandParameter.psc_mod=0 WHERE FK_CommandGroup=0", 202) = 202
read(4, "0\0\0\1\0\0\0\"\0\0\0(Rows matched: 1  Changed: 0  Warnings: 0", 16384) = 52
poll([{fd=4, events=POLLIN|POLLPRI}], 1, 0) = 0
write(4, "?\0\0\0\3UPDATE CommandGroup_Room set psc_mod=0 WHERE FK_CommandGroup=0", 67) = 67
read(4, "0\0\0\1\0\0\0\2\0\0\0(Rows matched: 0  Changed: 0  Warnings: 0", 16384) = 52
poll([{fd=4, events=POLLIN|POLLPRI}], 1, 0) = 0
write(4, "H\0\0\0\3UPDATE CommandGroup_EntertainArea set psc_mod=0 WHERE FK_CommandGroup=0", 76) = 76
read(4, "0\0\0\1\0\0\0\2\0\0\0(Rows matched: 2  Changed: 0  Warnings: 0", 16384) = 52
poll([{fd=4, events=POLLIN|POLLPRI}], 1, 0) = 0
write(4, "%\0\0\0\3select * from Room where `PK_Room`=3", 41) = 41
read(4, "\1\0\0\1\0176\0\0\2\3def\npluto_main\4Room\4Room\7PK_Room\7PK_Room\f?\0\v\0\0\0\3\3B\0\0\0F\0\0\3\3def\npluto_main\4Room\4Room\17FK_Installation\17FK_Installation\f?\0\v\0\0\0\3\1\0\0\0\0>\0\0\4\3def\npluto_main\4Room\4Room\vFK_RoomType\vFK_RoomType\f?\0\v\0\0\0\3\0\0\0\0\0>\0\0\5\3def\npluto_main\4Room\4Room\vDescription\vDescription\f!\0Z\0\0\0\375\0\0\0\0\0006\0\0\6\3def\npluto_main\4Room\4Room\7FK_Icon\7FK_Icon\f?\0\v\0\0\0\3\0\0\0\0\0N\0\0\7\3def\npluto_main\4Room\4Room\23ManuallyConfigureEA\23ManuallyConfigureEA\f?\0\1\0\0\0\1\0\0\0\0\0F\0\0\10\3def\npluto_main\4Room\4Room\17HideFromOrbiter\17HideFromOrbiter\f?\0\1\0\0\0\1\1\0\0\0\0T\0\0\t\3def\npluto_main\4Room\4Room"..., 16384) = 1027
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV (core dumped) +++
So we appear to be crashing when reading the result from the Query: "select * from Room where `PK_Room`=3"

I am wondering how to tackle that one now.

Regards
Chris

Xtra

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
So, now I did manually:
Code: [Select]
ALTER TABLE CommandGroup ADD COLUMN FK_Text INT(11);
And now the binary crashes without any message but the first room is at least now correct. I can see all the Scenarios in the web admin.
Sadly it still crashes on the Query: "select * from Room where `PK_Room`=3".

When I issue it by hand in the mysql command line client, I see that zero rows match.
So there might be some problem handling empty result sets in this file.

I'll keep on digging.

EDIT/ADD:
I just found out why the Query returns zero rows. That is simply because I deleted that room. My Rooms have the IDs 1,2,4,5 and 3 is deleted.
So I simply added the missing entry back in with the following statement:
Code: [Select]
INSERT INTO Room (PK_Room,FK_Installation,FK_RoomType,Description,psc_mod) VALUES (3,111726,2,"Closet",NOW());

After that I fired for a last time:
Code: [Select]
/usr/pluto/bin/UpdateEntArea -h localhost -u root -D pluto_main

And guess what? It ran through smoothly without error.

So there is definatly a bug in UpdateEntArea for non existing rooms (or rooms that do not exist anymore).
I was not able to locate the exact position in source where this happens but I hope the information in this Thread will help you devs to figure it out.

Regards
Chris
« Last Edit: December 17, 2009, 02:20:50 am by Xtra »

krys

  • Addicted
  • *
  • Posts: 583
    • View Profile
Re: [SOLVED] Installed Beta2, but now no Autogenerated Media Scenarios
« Reply #5 on: December 17, 2009, 04:16:43 pm »
Xtra,
Did you update from alpha/beta to beta2, or is it a fresh DVD install of beta2? I ask because I had the exact same problem when i took the upgrade path, and i just ended up doing a fresh install of beta2 from DVD.

Xtra

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: [SOLVED] Installed Beta2, but now no Autogenerated Media Scenarios
« Reply #6 on: December 17, 2009, 06:25:10 pm »
Yes, it was an upgrade from alpha to beta. Which I guess is the reason the missing column wasn't added.
But the main Problem was the unhandled "Deleted room" I guess.
I wonder what will happen if I delete the room again but do not want to risk this installation for too much testing.

I think I will have to install another innstallation directly from beta ad try there to add and then delete a room for checking if it also breaks UpdateEntArea.

Regards
Chris

Kaelix

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: [SOLVED] Installed Beta2, but now no Autogenerated Media Scenarios
« Reply #7 on: December 29, 2009, 04:54:48 am »
I had part of this same issue upgrading from an alpha install. I didn't have a removed room but I was missing the FK_Text column, which was causing my bedroom MD to not show the 'TV' button. I ran ALTER TABLE CommandGroup ADD COLUMN FK_Text INT(11); Then I ran /usr/pluto/bin/UpdateEntArea -h localhost -u root -D pluto_main. It ran without any issues. I regenerated all orbiters and reloaded the router and the button appeared. However today I ran UpdateEntArea again and i'm receiving a bunch of errors like:

Cannot perform query: [update CommandGroup set `PK_CommandGroup`=83, `FK_Array`=5, `FK_Installation`=1000836, `Description`="Manage Drives", `Hint`="Bedroom (Master)", `CanTurnOff`=0, `AlwaysShow`=0, `CanBeHidden`=0, `FK_Criteria_Orbiter`=NULL, `FK_DesignObj`=NULL, `FK_Template`=34, `AltID`=NULL, `FK_Icon`=17, `AutoGeneratedDate`="2009-12-28 19:04:12", `Disabled`=0, `TemplateParm1`=0, `TemplateParm2`=0, `FK_Text`=1995, `psc_id`=0, `psc_batch`=0, `psc_user`=0, `psc_frozen`=0, `psc_restrict`=1995 where `PK_CommandGroup`=83] Duplicate entry '0' for key 2

It won't complete, not matter what I've tried, If i set the value it's setting to 0 to NULL then it picks the next row and sets that to 0, causing another button to not be visible. I've run the script, looked for which value was set to 0 and updated the sql table to set to NULL until it finally got down to the last row in the table CommandGroup, and now the missing button is 'Manage Drives' on the bedroom MD. I can't get past this to run the script successfully, what causes it to want to update psc_id to 0 rather than leaving it NULL? How can I fix this? Thanks

jamesh

  • Newbie
  • *
  • Posts: 10
    • View Profile
My Rooms have the IDs 1,2,4,5 and 3 is deleted. So I simply added the missing entry back in with the following statement:
Code: [Select]
INSERT INTO Room (PK_Room,FK_Installation,FK_RoomType,Description,psc_mod) VALUES (3,111726,2,"Closet",NOW());

After that I fired for a last time:
Code: [Select]
/usr/pluto/bin/UpdateEntArea -h localhost -u root -D pluto_main

And guess what? It ran through smoothly without error.

Same problem and same solution here. Mine was a fresh DVD install of beta2. I had deleted a room before I set up the MD and for whatever reason UpdateEntArea was looking for the room that didn't exist.
LinuxMCE 810b2 + SiliconDust HDHomeRun
MD: BIOSTAR TF7050-M2 NVIDIA GeForce 7050PV
Core: VMware Server 2.0.0

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: [SOLVED] Installed Beta2, but now no Autogenerated Media Scenarios
« Reply #9 on: March 13, 2010, 10:25:36 pm »
Can confirm this behaviour and offer a different solution.

I was completing the 810 beta2 setup wizard when it reset itself back to the beginning after I had defined the rooms. Carried on but obviously created the database problem outlined above.

My solution after reading this thread, was to use the web admin to delete the room. Then re-run the setup. This corrected the error and saved me a lot of time reinstalling.

Hope this helps someone.

jrd261

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: [SOLVED] Installed Beta2, but now no Autogenerated Media Scenarios
« Reply #10 on: March 19, 2010, 05:30:09 am »
I've encountered the same problem. Fresh DVD 0810beta install. No scenarios are generated.

The setup wizard crashes/restarts when I add a new room for a md, but the room still gets created and md attached. I can complete the wizard if the md is already attached to a room, but no scenarios are generated of course.

I did not have the same success as b4rney with deleting and re-adding the room.

I believe the problem lies herein:

xxxx@dcerouter:/usr/pluto/bin$  /usr/pluto/bin/UpdateEntArea -h localhost -u root -D pluto_main
Segmentation fault

Ruh-row. Ideas?


« Last Edit: March 19, 2010, 05:33:48 am by jrd261 »

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5505
  • DOES work for LinuxMCE.
    • View Profile
Re: [SOLVED] Installed Beta2, but now no Autogenerated Media Scenarios
« Reply #11 on: March 19, 2010, 07:20:00 pm »
Sorry you're having the problem. This isn't something we've been able to reproduce....

are you using unmanaged rooms for any of your rooms? how many rooms are you defining?

-Thom

jrd261

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: [SOLVED] Installed Beta2, but now no Autogenerated Media Scenarios
« Reply #12 on: March 22, 2010, 04:22:26 am »
No I wasn't using any unmanaged rooms. I defined two rooms, one for my core MD and one for my diskless MD. I'm still playing so I just picked "Family Room" and "Home Theater" I believe.

Problem persisted with DVD install. Tried again, and no luck. Note I am running in virtualbox.

Installed from repo (first time repo install worked for me, virtualized or normal) and this problem went away.

Everything works fine now, well except for... http://forum.linuxmce.org/index.php?topic=9843.0.