Author Topic: HVR-4000 - SOLVED  (Read 6719 times)

Lexje

  • Guru
  • ****
  • Posts: 230
    • View Profile
Re: HVR-4000 - SOLVED
« Reply #15 on: December 30, 2009, 03:48:39 pm »
Ola Frank,

Are you aware within Myht 0.22 - when in mythtv-setup - while doing capture card setup:
- You should have several Card types from which to choose
-> You should pick Card type: DVB DTV capture card (v3.x)
-> You should be able to change the DVB Device number according to your adapter0/frontend0 or adapter0/frontend1
- The Frontend IDentification should change accordingly - one for SAT the other for DVB-T, the ID should read something like Conexant CX22702 DVB-T Subtype: DVB-T

Can you confirm this?

Have a look at the attached screenshot - ATTENTION - this is a capture of Myth 0.21 (which is not multi frontend capable!)

Hope this helps!

Erwin

Nuwis

  • Regular Poster
  • **
  • Posts: 43
    • View Profile
Re: HVR-4000 - SOLVED
« Reply #16 on: December 30, 2009, 05:23:57 pm »
Erwin thanks for your patient,

Yes it is OK, i have it with both fornteds 0:0 for the DVB-S and 0:1 for the DVB-T, I had configure both fronteds in the setup-->capture cards, but only i use 0:1 for the DVB-T.
Mythtv is the last version 0.22 updated from lmce repos this week, also what i had configured in the setup of mythtv is the references regarding the country from the US to Spain, all the rest are by default. There are something to set more in the setup?

rgrds
Frank Galan

An Spanish LMCE user
http://wiki.linuxmce.org/index.php/User:Nuwis

Lexje

  • Guru
  • ****
  • Posts: 230
    • View Profile
Re: HVR-4000 - SOLVED
« Reply #17 on: December 30, 2009, 08:04:51 pm »
Frank,

Off course I'm not sure about this, but I can tell you I have been fighting with this for something like a month or so.
I did countless installs, all kinds of Ubuntu / Kubuntu various versions, various kernels etc.
I have plenty of hd's, and also since 0810 beta you can now have more than one installation next to another. This makes it easier to compare stuff.
If you install v4l-dvb using hg clone http://linuxtv.org/hg/v4l-dvb try using hg clone -r 13486 http://linuxtv.org/hg/v4l-dvb instead.
This will install the exact same repo / driverset I am using.
I have found that using a more recent repo version DID NOT WORK. Don't ask me why, because I don't know.
Also, I would advise to use the same version of firmware I'm using, as this is known working.

I have been using the 'newest' one available in the beginning, and it didn't work out. Again, I don't know why...

Another point of information:
I haven't found any information on this, but I THINK that Kaffeine does not use firmware, or, it may use it differently.
Why I say this? I have read that in some cases it may be sufficient that 'the firmware' has been loaded once (e.g. using M$ Windows) so this may be the case for Kaffeine, I'm not sure.

As for the country settings:
Are you aware that you can use various tools to scan for channels? Google around if you don't know yet.
For Kaffeine you can find what I call 'presets' with frequency information in ~/.kde/share/apps/kaffeine/dvb-t/
There you will find from es-Albacete to es-Zaragoza. Don't know what region you're in, but pick the one of your location.
When you install v4l-dvb, it installs similar 'presets' but to a different location - use slocate to find if needed.
Indeed it may make a difference, in my case e.g. there is no setting for Belgium, so scanning default for Australia the range of channels scanned is different according to location.

For comparison's sake I installed Ubuntu 0904. Then sudo apt-get install mythtv and everything works out of the box!
(different kernel - and myth 0.21) so all I had to do was make the symbolic links to make myth 0.21 see the second frontend.

I guess this is about all I can really tell...
Hope this helps....

Erwin

PS You can also compare your lspci -v to mine attached in Mandingo's post. (txt attachment)
« Last Edit: December 30, 2009, 08:07:02 pm by Lexje »

Schmich

  • Veteran
  • ***
  • Posts: 116
    • View Profile
Re: HVR-4000 - SOLVED
« Reply #18 on: April 16, 2011, 08:39:48 pm »
My 4000 doesn't lock on to DVBT either. I am in the same position as Nuwis. My log after doing a "tail" is pretty much the same as his - same firmware is uploaded.

I'm running LMCE 8.10 (snapshot 23887). My HVR-1200 locks on to channels and I'm using the same config and even same cable for the 4000. Any suggestions?