Author Topic: Wrong kernel on MD ?  (Read 588 times)

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Wrong kernel on MD ?
« on: December 07, 2009, 10:50:53 am »

On the MD I get this error :


# apt-get dist-upgrade
Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
  linux-image-2.6.27-14-generic
The following packages will be upgraded:
  linux-image-diskless
1 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/57.6MB of archives.
After this operation, 94.5MB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  linux-image-2.6.27-14-generic linux-image-diskless
Authentication warning overridden.
(Reading database ... 141336 files and directories currently installed.)
                                                                        Unpacking linux-image-2.6.27-14-generic (from .../linux-image-2.6.27-14-generic_2.6.27-14.41_i386.deb) ...
                                        Done.
                                             dpkg: error processing /var/cache/apt/archives/linux-image-2.6.27-14-generic_2.6.27-14.41_i386.deb (--unpack):
                  trying to overwrite `/boot/vmlinuz-2.6.27-14-generic', which is also in package linux-image-diskless
                                                                                                                      dpkg-deb: subprocess paste killed by signal (Broken pipe)
                                     Preparing to replace linux-image-diskless 2.6.27-14-generic-lmce1 (using .../linux-image-diskless_2.6.27-15-generic-lmce1_i386.deb) ...
                                  Unpacking replacement linux-image-diskless ...
                                                                                dpkg: error processing /var/cache/apt/archives/linux-image-diskless_2.6.27-15-generic-lmce1_i386.deb (--unpack):
                                                       trying to overwrite `/lib/modules/2.6.27-15-generic/initrd/vesafb.ko', which is also in package linux-image-2.6.27-15-generic
                                          dpkg-deb: subprocess paste killed by signal (Broken pipe)
                                                                                                   Errors were encountered while processing:
   /var/cache/apt/archives/linux-image-2.6.27-14-generic_2.6.27-14.41_i386.deb
                                                                               /var/cache/apt/archives/linux-image-diskless_2.6.27-15-generic-lmce1_i386.deb
                  E: Sub-process /usr/bin/dpkg returned an error code (1)

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: Wrong kernel on MD ?
« Reply #1 on: December 07, 2009, 11:09:58 am »
there was apparently two different kernels on the system !?
Did an :
apt-get remove linux-image-2.6.27-15-generic

apt-get dist-upgrade
apt-get -f install


After that it was OK, but what kernel packages should be there ?

Code: [Select]
dpkg -l |grep linux-image-
ii  linux-image-2.6.27-14-generic              2.6.27-14.41                                Linux kernel image for version 2.6.27 on x86
rc  linux-image-2.6.27-15-generic              2.6.27-15.43                                Linux kernel image for version 2.6.27 on x86
ii  linux-image-diskless                       2.6.27-15-generic-lmce1                     Linux kernel image for version 2.6.27-15-gen

is the "linux-image-2.6.27-14-generic" not supposed to be there ?

Viking