Author Topic: Taking up Media Director again - Can't execute MythTV_Player  (Read 1820 times)

Lexje

  • Guru
  • ****
  • Posts: 230
    • View Profile
Taking up Media Director again - Can't execute MythTV_Player
« on: January 22, 2010, 11:33:19 am »
Hi everyone,

Short intro:
It's been quite a while since I have been working / setting up MD's.
In my first 0704 / 0710 install, I had a couple and each of them had a PVR-150 on board. Taking into account that at that time my knowledge (if any) of MythTV was not very impressive, I today stumble over some basic questions, so her goes:

Situation:
Core/Hybrid
0810 beta2 on Asus M3N78-EM
1 Hauppauge HVR-4000
RS232 to Onkyo Receiver

MD
Acer Aspire Revo R3600
no TV card or USB TV device

It should be noted that I have had an extreme 'fight' to get the HVR4000 running first with Myth 021 now with 022.
To get this to work, I had to do extensive testing, during which, admittedly, from time to time some detail on information got lost, or mixed up with 'another trial'.
It's also important to notice that I'm running 2.6.28-11-generic kernel.

So yesterday picked up the R3600 and hooked it up as an MD. At first, after enabling PXE, the MD got stuck after a reboot. Then I realized maybe this had to do with me running a 2.6.28-11 kernel on the core?
I adapted the boot images of my MD, and also copied over the complete relevant modules directory.
I also switched AMD64 to i386 via PlutoAdmin.
After that, the Revo continued booting and seems to work fine...

Next I tried to start TV on the Revo-MD.
This does not work...
At this point I started doubting: does my MD need it's own TV tuner? I don't think so, the front-end of the MD should be able to connect to the back-end on the core, and use the HVR-4000 tuner on the core - if it is available. (Could someone please confirm if I'm correct here?)

Next I had a look at the ##_MythTV_Player.log to find:
Code: [Select]
sambahelper@moon41:/var/log/pluto$ cat 49_MythTV_Player.log
== ATTEMPT FRESH START ==
1       01/21/10 19:36:38       Spawn_Device.sh 49 (spawning-device)    18861 Dev: 49; Already Running list: 42,43,45,
== FRESH START ==
1       01/21/10 19:36:39       Spawn_Device.sh 49 (spawning-device)    device: 49 ip: 192.168.80.1 cmd_line: MythTV_Player
3       01/21/10 19:36:40       Spawn_Device.sh 49 (spawning-device)    Can't execute MythTV_Player

Now I wonder:
- Is this caused by the changed kernel?
- Are there 'known' objections against upgrading the kernel?
- What steps do I have to take to modify the MD image, so that newly created MD's will use the correct kernel and modules?
- What is missing to make MythTV run on this MD?

I realize this is quite a lengthy post, but I feel the information is necessary to understand the situation.

Thanks a lot for all the great work and for your help!

Erwin

klanmce

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: Taking up Media Director again - Can't execute MythTV_Player
« Reply #1 on: January 22, 2010, 12:11:03 pm »
I have been having a similar issue. Checked the dcrouter, Spawn_device*.log and Create*.log, which did not show any clear fault why the mythv and linuxmce mthtv components were not installed. What I realized by chance is, adding another MD (physicall PXE booting another machine) caused the remaining software to be installed. Thus I kept a spare machine, just for that purpose, until I can figure out what causing this issue or run a script to have the remaining components installed.

I have seen the obvious, that information for the devices installed is stored within the database, thus getting a list of what is installed or not would be relatively easy. My hindrance at the moment, is getting the exact process responsible for triggering the install of the remaining components.

Yesterday I got another issue, the install failed as some dependencies were at the wrong version
Quote
mythtv-backend: Depends: mythtv-common (= 2:0.22.0-fixes23193-0ubuntu0) but 2:0.23.0~trunk-23168-0ubuntu0 is to be installed
                  Depends: mythtv-transcode-utils (= 2:0.22.0-fixes23193-0ubuntu0) but it is not going to be installed

This was an easy fix, did not manually install the remaining stuff, wanted it to work as should.

Opened a thread initially for this issue
Quote
http://forum.linuxmce.org/index.php?topic=9363.0

Lexje

  • Guru
  • ****
  • Posts: 230
    • View Profile
Re: Taking up Media Director again - Can't execute MythTV_Player
« Reply #2 on: January 22, 2010, 12:40:08 pm »
Klanmce,

Thanks for posting;
Indeed our situation seems similar. I'll give adding another MD a try, but I realize in view of my different kernel, I should modify / prepare the MD image. Looking for more info on how to do that.

Apparently myth is not installed on my MD either.
Code: [Select]
Last login: Fri Jan 22 09:57:55 2010 from 192.168.80.242
sambahelper@moon41:~$ apt-cache policy mythtv
mythtv:
  Installed: (none)
  Candidate: 2:0.23.0~trunk-23168-0ubuntu0
  Version table:
     2:0.23.0~trunk-23168-0ubuntu0 0
        500 http://www.avenard.org intrepid/release Packages
     2:0.22.0-fixes23193-0ubuntu0 0
        500 http://www.avenard.org intrepid/release Packages
     2:0.22.0-fixes23167-0ubuntu0 0
        500 http://www.avenard.org intrepid/release Packages
     2:0.22.0-fixes23163-0ubuntu0 0
        500 http://www.avenard.org intrepid/release Packages
     2:0.22.0-fixes23140-0ubuntu0 0
        500 http://www.avenard.org intrepid/release Packages

Erwin

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: Taking up Media Director again - Can't execute MythTV_Player
« Reply #3 on: January 22, 2010, 04:08:35 pm »

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: Taking up Media Director again - Can't execute MythTV_Player
« Reply #4 on: January 22, 2010, 04:46:41 pm »
Quote from Possy in IRC

<@possy> BongoWongo, please post a note in the thread about the mythtv .23 snafu that a new installer is available that should fix the problem in general. Every existing install should create a preferences file as outlined in #574

Lexje

  • Guru
  • ****
  • Posts: 230
    • View Profile
Re: Taking up Media Director again - Can't execute MythTV_Player
« Reply #5 on: January 22, 2010, 09:44:00 pm »
Guys, thank you all for your input :-)

MythTV issue resolved. Not playing nicely at the mo, Myth issues a
Code: [Select]
Video frame buffering failed too many times message - will search and look into this.

What did I do?
Tried and tested several ways.
At a certain point I realized I had not run the Diskless_CreateTBZ.sh script.
I don't remember ever doing this with earlier installs.

Could someone point me too where this popped-up and why?

Next deleted all MD's, ran the script, adapted /etc/apt/preferences, and built the MD anew.
I added the Myth 0.22 pin to /etc/apt/preferences as suggested.
After first reboot, MD froze.
Copied over kernel relevant files & modules to the MD.
Reboot and all went well.

I'd still like to know how / where to modify the different vmlinuz & initrd.img and /lib/modules/new-kernel-version to have new MD's build properly from the first time?

Thanks a lot!

Erwin

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: Taking up Media Director again - Can't execute MythTV_Player
« Reply #6 on: January 22, 2010, 10:07:56 pm »
Did you fix the MythTV version on the Core, or has it not been updated? Check with:
dpkg -l | grep myth

If you have .23's in there, you need to "apt-get update" and "apt-get dist-upgrade", and possibly "apt-get install pluto-mythtv-player pluto-mythtv-plugin".  You may have to upgrade the Core anyway if the MDs are getting a newer version than the Core has.

If the Myth versions don't match between Core and MD or Myth on Core is having issues, then you will probably have strange errors.

Lexje

  • Guru
  • ****
  • Posts: 230
    • View Profile
Re: Taking up Media Director again - Can't execute MythTV_Player
« Reply #7 on: January 22, 2010, 10:19:27 pm »
Jimbodude,

I didn't touch the core, only the MD.
Just for information here's the listings. They seem at par. (no 0.23)

I did a google on this error and found quite some mentioning, also track issues. No solution yet.

Thanks for posting!
Great to feel the help!

Erwin

Core:
Code: [Select]
linuxmce@dcerouter:/var/log/pluto$ dpkg -l |grep myth
ii  libmyth-0.21-0                             2:0.21.0+fixes-22228-openglvdpau2-0ubuntu2                 Common library code for MythTV and add-on mo
ii  libmyth-0.22-0                             2:0.22.0-fixes23069-0ubuntu0                               Common library code for MythTV and add-on mo
ii  libmyth-perl                               2:0.22.0-fixes23069-0ubuntu0                               A PERL library to access some MythTV feature
ii  lmce-mythtv-scripts                        2.0.0.44.09120322558                                       <insert up to 60 chars description>
ii  mythtv-backend                             2:0.22.0-fixes23069-0ubuntu0                               A personal video recorder application (serve
ii  mythtv-common                              2:0.22.0-fixes23069-0ubuntu0                               A personal video recorder application (commo
ii  mythtv-database                            2:0.22.0-fixes23069-0ubuntu0                               A personal video recorder application (datab
ii  mythtv-frontend                            2:0.22.0-fixes23069-0ubuntu0                               A personal video recorder application (clien
ii  mythtv-transcode-utils                     2:0.22.0-fixes23069-0ubuntu0                               Utilities used for transcoding MythTV tasks
ii  mythweb                                    2:0.22.0-fixes22991-0ubuntu0                               Web interface add-on module for MythTV
ii  pluto-mythtv-player                        2.0.0.44.09112922522                                       <insert up to 60 chars description>
ii  pluto-mythtv-plugin                        2.0.0.44.09122522639                                       <insert up to 60 chars description>
linuxmce@dcerouter:/var/log/pluto$

MD (Revo R3600)
Code: [Select]
sambahelper@moon60:~$ dpkg -l |grep myth
ii  libmyth-0.21-0                             2:0.21.0+fixes-22228-openglvdpau2-0ubuntu2  Common library code for MythTV and add-on mo
ii  libmyth-0.22-0                             2:0.22.0-fixes23229-0ubuntu0                Common library code for MythTV and add-on mo
ii  libmyth-perl                               2:0.22.0-fixes23229-0ubuntu0                A PERL library to access some MythTV feature
ii  lmce-mythtv-scripts                        2.0.0.44.09120322558                        <insert up to 60 chars description>
ii  mythtv-backend                             2:0.22.0-fixes23229-0ubuntu0                A personal video recorder application (serve
ii  mythtv-common                              2:0.22.0-fixes23229-0ubuntu0                A personal video recorder application (commo
ii  mythtv-frontend                            2:0.22.0-fixes23229-0ubuntu0                A personal video recorder application (clien
ii  mythtv-transcode-utils                     2:0.22.0-fixes23229-0ubuntu0                Utilities used for transcoding MythTV tasks
ii  pluto-mythtv-player                        2.0.0.44.09112922522                        <insert up to 60 chars description>
sambahelper@moon60:~$

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: Taking up Media Director again - Can't execute MythTV_Player
« Reply #8 on: January 22, 2010, 11:44:54 pm »
The most recent (as of last night) MythTV 0.22 packages are here:
Code: [Select]
ii  libmyth-0.22-0                             2:0.22.0-fixes23193-0ubuntu0                               Common library code for MythTV and add-on mo
ii  libmyth-perl                               2:0.22.0-fixes23193-0ubuntu0                               A PERL library to access some MythTV feature
ii  mythtv-backend                             2:0.22.0-fixes23193-0ubuntu0                               A personal video recorder application (serve
ii  mythtv-common                              2:0.22.0-fixes23193-0ubuntu0                               A personal video recorder application (commo
ii  mythtv-database                            2:0.22.0-fixes23193-0ubuntu0                               A personal video recorder application (datab
ii  mythtv-frontend                            2:0.22.0-fixes23193-0ubuntu0                               A personal video recorder application (clien
ii  mythtv-theme-blootube-osd                  2:0.22.0-fixes22924-0ubuntu1                               The blootube-osd MythTV Theme
ii  mythtv-theme-blueosd                       2:0.22.0-fixes22924-0ubuntu1                               The blueosd MythTV Theme
ii  mythtv-theme-graphite                      2:0.22.0-fixes22924-0ubuntu1                               The graphite MythTV Theme
ii  mythtv-theme-iulius-osd                    2:0.22.0-fixes22924-0ubuntu1                               The iulius-osd MythTV Theme
ii  mythtv-theme-metallurgy                    2:0.22.0-fixes22924-0ubuntu1                               The metallurgy MythTV Theme
ii  mythtv-theme-mono-osd                      2:0.22.0-fixes22924-0ubuntu1                               The mono-osd MythTV Theme
ii  mythtv-theme-mythbuntu                     2:0.22.0-fixes22924-0ubuntu1                               The mythbuntu MythTV Theme
ii  mythtv-theme-projectgrayhem-osd            2:0.22.0-fixes22924-0ubuntu1                               The projectgrayhem-osd MythTV Theme
ii  mythtv-theme-retro-osd                     2:0.22.0-fixes22924-0ubuntu1                               The retro-osd MythTV Theme
ii  mythtv-theme-titivillus-osd                2:0.22.0-fixes22924-0ubuntu1                               The titivillus-osd MythTV Theme
ii  mythtv-themes                              2:0.22.0-fixes22924-0ubuntu1                               Themes for MythTV
ii  mythtv-transcode-utils                     2:0.22.0-fixes23193-0ubuntu0                               Utilities used for transcoding MythTV tasks
ii  mythweb                                    2:0.22.0-fixes23097-0ubuntu0                               Web interface add-on module for MythTV

Even more updates came in today... fixes 23229, I believe.

You have a version discrepancy between the MD and the Core, since they keep changing so fast...  2:0.22.0-fixes23229-0ubuntu0 on MD, 2:0.22.0-fixes23069-0ubuntu0 on core.  Upgrade everything, try again.

You're also missing the themes... I think you need at least one - I'm not sure why I have them all...  I believe the themes are dependencies of the frontend package, but I'm not positive.

Your plugin and player are also different versions than what I have, but mine look older... not sure why that is.
« Last Edit: January 22, 2010, 11:48:06 pm by jimbodude »

Lexje

  • Guru
  • ****
  • Posts: 230
    • View Profile
Re: Taking up Media Director again - Can't execute MythTV_Player
« Reply #9 on: January 22, 2010, 11:49:10 pm »
Jimbo,

Thx for pointing out.
I figured if all was 0.22 I was good. Not so.
Can I just sudo apt-get update myth*? -> No, you moron, you can't!! :-)

Code: [Select]
Sudo apt-get dist upgrade did the thing
Nearly all packages on both Core and MD are at 2:0.22.0-fixes23229-0ubuntu0 now.
MythTV playing on MD now as I  write :-)

Will look into the theme packages.
One thing I noticed though nothing to do with MD -
Myth recordings miss their jpg image in the Orbiters media -> video view...?
Browsing to \\dcerouter\mythweb -> show recorded programs lists those jpg's nicely though...

Any idea?

Thx a lot!

Erwin
« Last Edit: January 23, 2010, 11:21:24 am by Lexje »

jimbodude

  • Guru
  • ****
  • Posts: 372
    • View Profile
Re: Taking up Media Director again - Can't execute MythTV_Player
« Reply #10 on: January 25, 2010, 03:59:02 pm »
No idea... that has "just worked" for me ever since it was added.  Maybe something is gummed up in the thumbnail maker stuff with all the version changes... I'm not sure where that lives, but a system reboot would be one sure way to clear any version change leftovers.  Could first try reloading the router and restarting mythtv-backend under /etc/init.d