Author Topic: LinuxMCE 8.10 beta install issues - Nvidia vdpau fail :(  (Read 3351 times)

valent

  • Guru
  • ****
  • Posts: 381
    • View Profile
    • /kernel_reloaded/
LinuxMCE 8.10 beta install issues - Nvidia vdpau fail :(
« on: November 29, 2009, 12:24:15 pm »
Hi, I installed LinuxMCE 8.10 three times yesterday. First time I messed things up by manually trying to install .deb packages by not using install script on desktop.

All three times Kubuntu installed without problems. Second time after install I updated the system and installed NVidia 180 driver via proprietary driver tool and then started the LinuxMCE install.

Third time right after Kubuntu install I started LinuxMCE install without previously installing NVidia driver or doing the update of the system.

Both times I got into same issue. After the install of all packages system needed to be restarted, I did that. After restart I got a screen showing white flashing text with statuses of things that system was doing - what packages are being installed, etc...

But after some time I just got blank screen and saw no system activity, hdd wasn't working and cpu wasn't loaded... I could only start a VT via CTRL-ALT-F1 and work from there, VT7 was just "frozen".

After ispecting I saw that apt-get got stuck... I would get messages:
package nvidia-180-libvdpau failed to install/upgrade: trying to overwrite `/usr/lib/libvdpau.so.1', which is also in package nvidia-glx-180

I managed to fix the issue via: sudo apt-get remove nvidia-glx-180

After that installing package nvidia-180-libvdpau still fails:

sudo apt-get install nvidia-180-libvdpau
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following packages were automatically installed and are no longer required:
  nvidia-settings
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  nvidia-180-libvdpau
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/758kB of archives.
After this operation, 1552kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  nvidia-180-libvdpau
Authentication warning overridden.
(Reading database ... 157574 files and directories currently installed.)
Unpacking nvidia-180-libvdpau (from .../nvidia-180-libvdpau_180.53-0ubuntu1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/nvidia-180-libvdpau_180.53-0ubuntu1_i386.deb (--unpack):
 trying to overwrite `/usr/lib/libvdpau.so.1', which is also in package libvdpau0
Errors were encountered while processing:
 /var/cache/apt/archives/nvidia-180-libvdpau_180.53-0ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Any ideas? Is this a know LinuxMCE 8.10 bug?

UPDATE: found this bug:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/460717

UPDATE 2: Now everytime I restart the LinuxMCE Core I get the same issue. There is somwhere a script that tries to install nvidia-180-libvdpau package but that kills apt-get and makes is impossible to install any other package after that. So I need to manually remove nvidia-glx-180 package every time I do a reboot :( How can I fix this?
« Last Edit: November 29, 2009, 01:09:40 pm by valent »
LinuxMCE - If it was easy, everybody would be doing it!!
My setup - http://wiki.linuxmce.org/index.php/User:Valent

sp00nhead

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: LinuxMCE 8.10 beta install issues - Nvidia vdpau fail :(
« Reply #1 on: November 29, 2009, 06:57:05 pm »
Think i ran into this last night while doing a clean install. i was also having fun getting the diskless TBZ to build.
 i *think* that i edited the /etc/apt/sources.list and removed the deb http://www.avenard.org/files/ubuntu-repos testing line and replaced with
deb http://www.avenard.org/files/ubuntu-repos intrepid release

Give it a go and see.
I've not got access to that machine again till later this week.


niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: LinuxMCE 8.10 beta install issues - Nvidia vdpau fail :(
« Reply #2 on: November 30, 2009, 01:35:19 pm »
Try the beta2. It should not contain any of the issues mentioned.

See www.linuxmce.org

valent

  • Guru
  • ****
  • Posts: 381
    • View Profile
    • /kernel_reloaded/
Re: LinuxMCE 8.10 beta install issues - Nvidia vdpau fail :(
« Reply #3 on: November 30, 2009, 05:56:19 pm »
I commented that apt sources line and did apt-get update then tried installing it but I still get this error:

dpkg: error processing /var/cache/apt/archives/nvidia-glx-180_180.11-0ubuntu1~intrepid1_i386.deb (--unpack):
 trying to overwrite `/usr/lib/libvdpau.so.1', which is also in package libvdpau0
LinuxMCE - If it was easy, everybody would be doing it!!
My setup - http://wiki.linuxmce.org/index.php/User:Valent

valent

  • Guru
  • ****
  • Posts: 381
    • View Profile
    • /kernel_reloaded/
Re: LinuxMCE 8.10 beta install issues - Nvidia vdpau fail :(
« Reply #4 on: November 30, 2009, 06:01:15 pm »
Try the beta2. It should not contain any of the issues mentioned.

See www.linuxmce.org

Thank you. I'm dowloading it.
LinuxMCE - If it was easy, everybody would be doing it!!
My setup - http://wiki.linuxmce.org/index.php/User:Valent

ShyGuy91284

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: LinuxMCE 8.10 beta install issues - Nvidia vdpau fail :(
« Reply #5 on: December 06, 2009, 08:26:33 pm »
I've reproduced this using the online diskless install labeled beta2. I did the following, restarting between each step:

1.  Installed Kubuntu
2.  Updated all the packages while staying at 8.10
3.  Installed the latest Nvidia drivers available for my system through the restricted driver manager (180.11).

Could this have something to do with the Nvidia driver version or the point in which I installed it? It looks like the LMCE-customized xine binaries want their own vdapu file, which is why they are trying to overwrite that. I noticed while trying the Beta2 disc (which I haven't had a lot of luck with) that it Had 190 nvidia drivers.

maverick0815

  • Addicted
  • *
  • Posts: 545
    • View Profile
Re: LinuxMCE 8.10 beta install issues - Nvidia vdpau fail :(
« Reply #6 on: December 07, 2009, 08:56:58 am »
as far as I remember you don't need to do any updates prior to install Linuxmce. I only found the CD-menu a little bit misleading, since it states Install kubuntu and install linuxmce.
At first I only went to the first option and of course didn't really get anywhere easily from there. if you go straight to install linuxmce you should be fine. As soon as the kubuntu install is finished, you should start the installerscript for linuxmce. The only obstacle is the nvidia driver really- you should use basic ui for the first generation of the orbiter- once everything is finished, got to kde-desktop, open a terminal and run nvidia-xconfig. Reboot from there and go through the AVWizard again, this time you can select ui2 with alphablending- it should be using nvidia 195.22 then.