Author Topic: asterisk  (Read 1118 times)

maverick0815

  • Addicted
  • *
  • Posts: 546
    • View Profile
asterisk
« on: November 26, 2009, 07:52:04 pm »
I have some issues with asterisk. My router provides ip-telephony via sip....so I setup one account inside my router, I get a username,password and registrar to be used with the ip-telephone. With this I went on to configure asterisk. I created a amp-script as described in the wiki and edited the provider_list.txt. Now when I select the proper provider and type in the required data- I don't get anything there- nothing shows up, so I guess the configuration doesn't get applied.
Does anyone have an idea, on how to get it working?

maverick0815

  • Addicted
  • *
  • Posts: 546
    • View Profile
Re: asterisk
« Reply #1 on: November 28, 2009, 05:16:02 pm »
After some checking around, I found out that asterisk has quite some problems. there is some connection erros with the asterisk manager port 5038 and some error about retieve_conf. Is anyone having asterisk running successfully at the momen?

maverick0815

  • Addicted
  • *
  • Posts: 546
    • View Profile
Re: asterisk
« Reply #2 on: December 20, 2009, 01:53:09 pm »
I'm still having some trouble getting along with asterisk
I found that the only script working for setting up a sip-trunk is broadvoice. I tried copying the script and modify it, so that it will configure asterisk to work together with my fritzbox- but that doesn't work- nothing registers. If I use the originial broadvoice-script and put in the logindata for the fritzbox, its working so far, that I suddenly have to lines  showing with the data- one for fritzbox, one for broadvoice. Then, whenever I want to make a call- either inbound or outbound- I get a recorded message, that the number I have called is not in use. I have no idea what to do. For testing purposes I  installed x-lite softphone on my computer and with the help of the wiki I set it up, so that it successfully registers with linuxmce, but I still cannot make even one call with it.
Any suggestions, anybody?

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: asterisk
« Reply #3 on: December 20, 2009, 05:15:23 pm »
I use the VOIP features in lmce without problems with Broadvoice, single line.

-Thom

maverick0815

  • Addicted
  • *
  • Posts: 546
    • View Profile
Re: asterisk
« Reply #4 on: December 20, 2009, 11:56:46 pm »
Well, Thom, I suspected you'd say that...and I wish I could too
so far, when I use the automatic configuration, select broadvoice and then put in the login-data for the fritzbox, it creates two lines- none of which I could delete from this page.
If I go to manual configuration, I find one trunk named broadvoice and a user context named fritzbox.
I also tried the intercom calling from one md to another or to the softphone- it gets dropped because there is no route.
Other than that I find those messages in the status page:
Quote
Could not reload the FOP operator panel server using the bounce_op.sh script. Configuration changes may not be reflected in the panel display.
Added 7 minutes ago
Quote
retrieve_conf failed to sym link the /etc/asterisk/sip.conf file from modules
Quote
Retrieve conf failed to copy file(s) from a module's agi-bin dir: copy(/usr/share/asterisk/agi-bin/list-item-remove.php): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/directory): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/dialparties.agi): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/recordingcheck): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/fixlocalprefix): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/enumlookup.agi): failed to open stream: Permission denied
copy(/usr/share/asterisk/agi-bin/checksound.agi): failed to open stream: Permission denied