Author Topic: 8.10 installation notes  (Read 1838 times)

foolsh

  • First post!
  • Posts: 1
    • View Profile
8.10 installation notes
« on: November 14, 2009, 10:00:51 pm »
hello this, I believe, is my first post.
    
    I've been waiting so long for lmce to get this version of mythtv for, it seems, forever. Thank you, Thank you, and Thank you to everyone who worked on this.

I wanted to add my install notes from 8.10, and what I've had to do to get a usable system, and what I'd like to do to keep the wife and kids happy.

Step 1.   Installed from the web using the instructions here http://wiki.linuxmce.org/index.php/LinuxMCE-0810_beta#Internet_Installation

Step 2.  /usr/pluto/bin/Diskless_CreateTBZ.sh   #I think this is called in the install script but i ran it again to be safe

Step 3.  from http://wiki.linuxmce.org/index.php/Diskless_setup_failed_error_in_0810_beta
     in file /usr/pluto/bin/files.d/fstab-diskless
      I changed
     mkdir -p "${Parm_RootLocation}/var/spool/asterisk"  needed a "

Step 4.   to add mythtv database info manually I had to change the /usr/pluto/bin/MythTvDailyFillDB.sh script

     # WaitUntilMythTvInitialRunXMinutesOld 2

     And I had to change /usr/pluto/bin/MythTvCommon.sh around line 149

      function WaitUntilMythTvInitialRunXMinutesOld {
             STARTTIME=`date +%s`
             if [ -r $FILLDBINITRUN -a -s $FILLDBINITRUN ] ; then
                STARTTIME=$(cat $FILLDBINITRUN)
             else
                      return
             fi
    
      I got this info here http://forum.linuxmce.org/index.php?topic=5814.0

Step 5. After booting the MD and getting the failed to startx screen change the root passwd on the MD in question using these instructions on the core http://wiki.linuxmce.org/index.php
/Logging_In#Media_Director

     then Alt-f1 log in as root at the MD and "dpkg-reconfigure -p high xserver-xorg" then "apt-get install envy-ng*"
     then envyng -t and install the driver you probably need for that discount nvidia card you bought just for this purpose.

That's it, I was up and running, but far from finished



Hack 1.
installed huludesktop
       and edited /usr/pluto/bin/startkde-keepdcop and added to the beginning
    
       huludesktop
       usr/pluto/bin/RestartX.sh XX xxx.xxx.xxx.xxx #custom to each MD.
       exit 0

       I won't be using kde besides its to heavy for my stuff.

Hack 2.
used nvidia-settings to get the gamma and performance tweaked and saved the config then edited /usr/pluto/bin/LaunchOrbiter.sh adding to the second line

        nvidia-settings --load-config-only &

        this loads the settings I saved

Hack 3. I had to use alsamixer and alsactl store/restore to get the volume normalized I added "alsactl restore" to  /usr/pluto/bin/LaunchOrbiter.sh aumix seems not to work for me.

And some other things but specific to my hardware so I won't list them. but I'm still not done.

Gripe 1. does mythtv launched from lmce always have to start with live tv we rarely and I mean maybe my finger slipped and started it, ever watch live tv, since we program it to record anything we want to see.

Gripe 2.
Myth frontend doesn't keep my sound setting located in Setup-General. only buy telling mythtv to use the internal sound settings PCM does any sound come out at all

Gripe 3.
where are my key press repeats at. it sucks pressing a button 99+ times just to look through a list. not everyone has a cool wii mote or gyro thingy mouse.

Aside from that I'm smiling ear to ear thanks again people
« Last Edit: November 15, 2009, 06:00:22 pm by foolsh »