Author Topic: Start_NewMD_interactor.sh takes a lot of CPU  (Read 507 times)

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Start_NewMD_interactor.sh takes a lot of CPU
« on: November 13, 2009, 04:38:08 pm »
Hi,

I have noticed that on my system /usr/pluto/bin/Start_NewMD_interactor.sh takes a lot of CPU.

It starts "/usr/pluto/bin/interactor-server" ( whatever it does) in a loop. And it seems that if it already for some reason is running, then interactor-server says that the port is already used and exits. That creates a lot of starts and take quite some CPU.

Something like this might be better :

Code: [Select]
#!/bin/bash

while :; do
        killall /usr/pluto/bin/interactor-server 2>/dev/null
        sleep 1
        /usr/pluto/bin/interactor-server
done

Greetings
Viking

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: Start_NewMD_interactor.sh takes a lot of CPU
« Reply #1 on: November 13, 2009, 06:18:45 pm »
I have noticed that on my system /usr/pluto/bin/Start_NewMD_interactor.sh takes a lot of CPU.

Have you checked to see if more than one copy of the script is running?  I had this issue after an update about a month ago and found that 2 copies of the script were launched.  I did a 'sudo kill xxxx' to kill the 2nd process and my CPU usage dropped to normal levels.  I think I performed a re-install and the problem did not return afterwards so I am unsure what caused the 2nd script to be executed in the first place.  If I recall correctly I had 2 copies of many things that launched erroneously on boot during that time period.

J.

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: Start_NewMD_interactor.sh takes a lot of CPU
« Reply #2 on: November 15, 2009, 09:11:50 pm »
I only noticed one script. There at more processes listing the script., but that has to do with the way it is started (IIRC).

I will reinstall after the next beta is out - to test if it is gone.

Greetings
Viking