Author Topic: How to get MythTV working again .21  (Read 1317 times)

MANDINGO

  • Guru
  • ****
  • Posts: 204
    • View Profile
How to get MythTV working again .21
« on: November 12, 2009, 08:48:08 am »
1. Install Fresh from the beta1 dvd and select install LinuxMCE option.
2. Once Kubuntu is installed go into adept installer-->Third Party Software and uncheck the avenard repo.
3. Open a terminal copy and paste below and run this to add medibuntu and key to your source list/Third Party Software.

    sudo wget http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list \
    --output-document=/etc/apt/sources.list.d/medibuntu.list &&
    sudo apt-get -q update &&
    sudo apt-get --yes -q --allow-unauthenticated install medibuntu-keyring &&
    sudo apt-get -q update

   Next install all updates.

4. NVIDIA - Get the latest Nvidia drivers 190.42 and install, to install log out of kubuntu and log back in as console and run the installer
            and say yes for creation of xorg.conf goto step 5

   INTEL - Intel Chipset and video add the lines below to your source list, go into Adept installer-->Third Party Software-->Add
           and add each line below.

           deb http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu intrepid main
           deb-src http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu intrepid main
          
           Next Open a terminal copy and paste below and run this to add the key to your source list/Third Party Software.

      sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys AF1CDFA9
   
      Next Fetch list and update adpt and install all updates.
      Log out of kubuntu and log back in, in console mode and run:

      sudo X -configure

           This will generate a new xorg.conf.new in your home directory and copy it to /etc/X11/xorg.conf

5. Double click on LinuxMCE icon and install
6. After LinuxMCE is installed and configured run below from a term for MD'S

   /usr/pluto/bin/Diskless_CreateTBZ.sh

7. Edit /usr/pluto/bin/files.d/fstab-diskless and change the last line to include the "

        mkdir -p "${Parm_RootLocation}/var/spool/asterisk <--- missing "
        mkdir -p "${Parm_RootLocation}/var/spool/asterisk" <-- should look like this

8. Start your MD to create its diskless image once created it will not boot into X fix this by copying over your xorg.conf into the moons X11 directory

        sudo cp /etc/X11/xorg.conf /usr/pluto/diskless/##/etc/X11 <-- where ## is your moon number

9. Setup Myth and watch, this is myth .21 not .22 which has vdpau support untill the issue is resolved .21 will work

I have a template that is for the HVR-1600 and i am currently working on the blaster feature of it, i will summit it into the CVS when completed.

Hope this helps others out.
« Last Edit: November 12, 2009, 10:02:17 am by MANDINGO »
For a Current List of Plug and Play Capture Cards/Devices
http://wiki.linuxmce.org/index.php/Capture_Cards

klanmce

  • Veteran
  • ***
  • Posts: 133
    • View Profile
Re: How to get MythTV working again .21
« Reply #1 on: November 13, 2009, 12:34:09 pm »
I have been plagued with this for a while, quick question.

How did you handle the exception for the kernel line, when using nvidia driver, for your MD's

My device template, simple did not work in 710, as such, I took the manual route, installing the card on an upgraded kernel, and manually configuring mythtv, and when I installed my pvr-500 (got it on ebay) the system never loaded the orbiter, had to take it out eventually.

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: How to get MythTV working again .21
« Reply #2 on: November 13, 2009, 11:05:48 pm »
This is solved in next beta.
Fixed in svn and pre beta2 testing in ongoing to verify that fix really work.

the actual bug causing this problem is a tracked all the way back to debian.
Seen, http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=512309

/niz23