Author Topic: After 0810 alpha to beta update the regenereated MD is still alpha  (Read 1146 times)

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Hi,

I updated today my production enviroment to the latest 0810 :)

Worked quit well. Just had the problems that som others also had. That the quote was missing in the fstab and Network manager made MD not boot after dist-upgrade.

But I also tried regenerating my MD using the webinterface and it was then still 0810 alpha. What can I do to get the MD updated. I assume I have to run one of the /usr/pluto/bin/Diskless_* scripts. Maybe Diskless_CreateTBZ.sh ?

Greetings
Viking

merkur2k

  • Addicted
  • *
  • Posts: 513
    • View Profile
Re: After 0810 alpha to beta update the regenereated MD is still alpha
« Reply #1 on: November 01, 2009, 08:09:12 pm »
ssh or chroot to the md in question and follow the same upgrade process that you did for the core.

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: After 0810 alpha to beta update the regenereated MD is still alpha
« Reply #2 on: November 03, 2009, 06:13:33 am »
merkur,
I also have the same issue as Viking, I have a hybrid and 4 MDs, after Alpha 2.24, I was able to update the core every week, all the way to Beta without any problem, but that not the case with the MDs after Alpha 2.24, I Login in from the core with SSH, and do "apt-get update" & "apt-get dist-upgrade",  it will take about 30-45 minutes to get updated, then it will fail the reboot, that happens on all the MDs, so I go back to the WebAdmin and do regenrate MD, then it will put me back to "Version:2.0.0.44.0805082200-Sat  June 27" where my Hybrid is "Version: 2.0.0.44.0805082200-Thu Sep 3", after I tried this several times, I just gave up on updating my MDs.

Is there any other way to do this, without reinstalling my Hybrid ???
Cheers |[BEER]
Charlie,

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: After 0810 alpha to beta update the regenereated MD is still alpha
« Reply #3 on: November 03, 2009, 09:11:26 pm »
Hi Charlie,

that it does not boot there is a fix for.
See here http://forum.linuxmce.org/index.php?topic=8425.msg61276#msg61276

Greetings
Viking

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: After 0810 alpha to beta update the regenereated MD is still alpha
« Reply #4 on: November 03, 2009, 09:12:29 pm »
ssh or chroot to the md in question and follow the same upgrade process that you did for the core.
OK, that was what I did. just hped that there was a solution that would bring the image up to current version so that one did not have to do the update process.

Greetings
Viking

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: After 0810 alpha to beta update the regenereated MD is still alpha
« Reply #5 on: November 04, 2009, 05:08:46 am »
Viking,
Thanks, that link solved my MD upgrades problem. :)
Cheers |[BEER]
Charlie,

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: After 0810 alpha to beta update the regenereated MD is still alpha
« Reply #6 on: November 04, 2009, 09:59:32 am »
No problem :)

If you have time, please report it to trac so that it can be fixed.

I am a bit in time problems - too much work and too much family (3 kids ;)).

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: After 0810 alpha to beta update the regenereated MD is still alpha
« Reply #7 on: November 04, 2009, 08:52:33 pm »
viking,
I just created a ticket for the issue
http://svn.linuxmce.org/trac.cgi/ticket/411
Cheers |[BEER]
Charlie,

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: After 0810 alpha to beta update the regenereated MD is still alpha
« Reply #8 on: November 06, 2009, 12:45:55 pm »
Great :)