Author Topic: 810 beta "Failed to start Open GL" error message  (Read 1635 times)

struggler

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
810 beta "Failed to start Open GL" error message
« on: October 18, 2009, 06:34:41 pm »
Hello,
I tried to install 810 beta and everything looks ok although after installation process and after starting dcerouter I get the black sceen saying "Failed to start OpenGL"

I'm using the same hardware that I run 710 without issues:
AMD M2 64 processor
1 GB RAM
nvidia 6200

I've tried with nvidia 6600LE but with the same result.

Any clues?

thanks

ckerkhoff

  • Regular Poster
  • **
  • Posts: 34
    • View Profile
Re: 810 beta "Failed to start Open GL" error message
« Reply #1 on: October 18, 2009, 07:03:06 pm »
To get mine to install I had to install the latest nvidia drivers when the kde desktop showed up during the installation. When I didn't install the nvidia drivers before I continued with the installation I couldn't see anything on the screen after a reboot. I don't know if this will help you out, but it's worth a shot.

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: 810 beta "Failed to start Open GL" error message
« Reply #2 on: October 18, 2009, 10:03:07 pm »
check your xorg.conf, do you have the line:

Driver "nvidia"

under the 'Device' heading

I did not and had the same issue you have.

I ran:

sudo nvidia-xconfig

it told me there was an issue with my xorg.conf and that the program would try to correct it.  It replaced my xorg.conf, I rebooted run the AV Wizard again selected 1080p and UI2 (this is what I wanted) and it now looks the same as it did in 0710

fastie81

  • Veteran
  • ***
  • Posts: 136
  • SSDD
    • View Profile
Re: 810 beta "Failed to start Open GL" error message
« Reply #3 on: October 18, 2009, 10:19:43 pm »
Hi Guys

Have you activate the OpenGl in the webmin?
It will not install you Nvidia driver with out selecting OpenGL from the Webmin.
Give it a go and see if that works.. if not then you would have to install the nvidia driver first.
This Alpha wiki page does give a lot of info.
http://wiki.linuxmce.org/index.php/LinuxMCE-0810_alpha2

Chris

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: 810 beta "Failed to start Open GL" error message
« Reply #4 on: October 18, 2009, 11:27:41 pm »
I made this mistake first time around also - gotta enable the restricted drivers in kubuntu before running the linuxmce install script I think....

fastie81

  • Veteran
  • ***
  • Posts: 136
  • SSDD
    • View Profile
Re: 810 beta "Failed to start Open GL" error message
« Reply #5 on: October 19, 2009, 01:21:39 am »
Hi
This is a quote from the Alpha site..
Quote
nVidia Restricted Driver
Install the nVidia restricted driver (177) from KDE using the Hardware Manager before installing LinuxMCE 0810 Alpha for the best results The installer will now automatically choose and install the correct restricted driver during setup.It will be installed after selecting "OpenGL" on your Media Director in web admin page.
Like I said this works and if it does not then yes install the nvidia driver.
Chris

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: 810 beta "Failed to start Open GL" error message
« Reply #6 on: October 19, 2009, 05:32:53 am »
Installing the drivers at the Kubuntu Desktop is not on the instructions for the Beta DVD. Therefore I, and a few other went straight past it and caused the issue.

To recover you can follow the instructions in my post above.

struggler

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: 810 beta "Failed to start Open GL" error message
« Reply #7 on: October 19, 2009, 11:50:26 am »
Hello All,
Thank you for all the feedback. I'll give a try on your suggestions and report results.

Best Regards
JD

struggler

  • Regular Poster
  • **
  • Posts: 39
    • View Profile
Re: 810 beta "Failed to start Open GL" error message
« Reply #8 on: October 20, 2009, 11:15:54 am »
Guys,
No luck, I've activated restricted drivers and after the reboot (before running linuxmce install script) the KDE showed up with HUGE fonts.
I've tried to install the 177 nvidia driver but after reboot the KDE had the same font problem.

Then I ran the linuxmce installation script (even with the font issue) and when it finished everything on the screen was huge, the flickr images were so magnified that I could see only a part of the picture.

Then I activated openGL on Media Director webadmin page and LMCE installed the nvidia drivers (new hope) although when it finished I got a black screen, even after reboot.

When I install the Nvidia drivers manually the X window crashes at startup complaining on compatibility issues between nvidia module and Kernel headers (?!?). On version 710 I was constantly updating the nvidia drivers without problems.

This night I will try another from the scratch installation, maybe I will just activate the restricted drivers and start LinuxMCE installtion without rebooting the server.

If anyone remembers anything else please help.

thanks


pigdog

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1008
    • View Profile
Re: 810 beta "Failed to start Open GL" error message
« Reply #9 on: October 20, 2009, 12:55:18 pm »
Hi,

I've always done it this way and never had any video driver problems...

After initially loading and restarting Kubuntu 810 and logged in as root

Run aptitude update and aptitude dist-upgrade to get the latest Kubuntu updates.

      Enter...

      apt-get update
      apt-get dist-upgrade


With Nvidia card installed, enable the most recent NVIDIA restricted (video) driver.

      This can be done by

      a) selecting the hardware icon on the task bar and activating the recommended version.

      b) navigating via the K Launch Manager to Applications > System > Hardware Drivers.
      Enter your password (if required) and highlite the latest version.
      Then select the Activate button to download and install the driver.

      c) If your card can not be enabled from a or b open the K Launch Manager to 
      Applications > Add/Remove Software Adept Installer and search for NVidia. 
      Select the latest binary X.org driver.

      (The latest nvidia driver should be 180.)

      Restart the system to activate the latest nvidia driver.

Then start LMCE install.

Hope this helps.